View Full Version : unable to join system link game for xbox

09-09-2006, 05:52 PM
hi, i'm new here and i recently bought BFII to play with my roommate. We hooked up our xboxes through a lan router, which we know works because we play halo 2 quite often. when one of us goes to create a new game for BFII over system link, the other cannot see it in the searching for games screen. we have tried multiple things, we cannot get the two xboxes to talk when BFII is in there. What's going on? has anyone else had this problem of being unable to play BFII over system link? any help would be appreciated. thanks.

09-17-2006, 05:36 PM
dude, ive had so much trouble with this , so anyone with a solution PLEASE POST!

10-26-2006, 04:23 PM
Oh crap, didnt notice this.
although this is hard to diagnose the problem without actually seeing it, i would suggest changing the port number on the router. ( if you know how to, of course) It is strange how it allows you to play ahlo 2 and not BF2, but this could be because that BF2 may not recognise the same port no.s as H2. Sorry about the late reply, and hope this works.

10-06-2012, 09:21 PM
I had this problem too. I would search but never find the other local Xbox.

Turned out I had one copy of Battlefront 2 that was a "platinum hit" release... and another copy that wasn't.

I purchased another original copy and it worked correctly without any port changing on my router.

I know you have to have (or not have) the same DLC on each XBOX. It looks like you also have to have the same "edition" regardless of any additional content it may or may not contain.

Maybe the platinum hit version just don't work with system link.

I was doing system link with two Xbox 360s btw.