PDA

View Full Version : Need help editing bodies :@


Sarthos
09-19-2006, 06:40 PM
Ok, I'm using 3ds max 7, with NWMax, to try to edit bodies. I do the following

Extract the binary model and it's mdx file from KOTOR.

Use MDLops, select the model, uncheck "Extract animations", uncheck "convert skin to Trimesh" and click "Read and Write model.

Open 3ds max, and load the ascii model (import geom only), and edit the mesh (moving vertexes of the editable mesh)

select the green base of the model, and go to the modifiers tab.

I click "Export Geom Only"

Sanity check fails.

Basically, it says that all the vertices need to be welded.

What do I do?

foolproof
09-19-2006, 08:51 PM
Umm im no expert , and i havent done any editing for a while now but dont u need to link the vertexesto the base of model? i think u missed that part ... it should be the last thing u do before u try and export ... otherwise model wont appear in-game (visible anyway).
hope this helps. sorry for run on sentences and if anyhting doesnt make sence ... im kind of in a rush. peace out

Kha
09-19-2006, 09:49 PM
If in the log file you have only warning about vertices that need to be welded see if the model loads in the game, because you can not weld all the vertices of your mesh otherwise your texture will get a little screwed up.

Sarthos
09-19-2006, 10:25 PM
I didn't weld, but it crashed the game. What is this stuff about linking the vertexes?

foolproof
09-19-2006, 10:55 PM
Err, nvm the vertices part i worded that badly. Just go over the tutorials that come with MDLOps. However I think they use just Gmax when they give examples of how its all done. srry about the confusion

Sarthos
09-20-2006, 05:45 PM
But I have 3ds max, not Gmax

oldflash
09-21-2006, 04:30 AM
Hint: use nwmax v.07 to get rid of sanity check errors and get a good compileready ascii file.
Gmax is some sort of 3dsmax v.5 whitout some functions. All tutorials for gmax are good dor 3dmax users.

Sarthos
09-21-2006, 10:36 PM
I turned off sanity checks, but the model crashes the game XD

T7nowhere
09-22-2006, 12:19 AM
Only turn off the "weld to nearest cm" or something like that, sorry its been a while. The other sanity checks are usefull.

Make sure your compiling the model correctly with mdlops, you need the orginal binary mdl + mdx in the same folder as your exported ascii, but remember to rename the exported ascii before dropping the 3 files in the same folder.

Sarthos
09-23-2006, 03:48 AM
and the renaming part is where I'm currently stuck. whatever I do, MDLops can't find the MDS file.