PDA

View Full Version : .2da files open in Paint...


MrChainsaw4129
09-26-2006, 01:09 AM
Don't ask me how this happened, because I don't know.

All my .2da files now open by default in Paint... (Properties... Open With: Paint)

How can I fix this problem? What program should they open in?

SithRevan
09-26-2006, 01:36 AM
First off welcome to LF:waive1:

Second 2da files should not open in a defualt program such as paint like you are saying, they should not even open when you click on them. So basically just don't click on them and open them up directly with kotor tool and you should be fine. So I hope this helps and I hope it was what you were looking for.:D

stoffe
09-26-2006, 05:20 AM
Don't ask me how this happened, because I don't know.
All my .2da files now open by default in Paint... (Properties... Open With: Paint)
How can I fix this problem? What program should they open in?

You've probably associated them with Paint by mistake when double-clicking on them some time. You can undo that by opening a Windows Explorer window, go to the Tools menu and pick "Folder options" or some such (I don't have an English version of Windows so I don't know the exact name). In the window that opens, select the "File types" tab (the one on the right) and scroll down to "2DA" in the listing and select it. There you an either remove the association entirely, or associate it with KotorTool.

If you do the latter KotorTool will open and display the file when you doubleclick on it, but keep in mind that for some reason a new instance will open every time you open a file this way with KT.

ChAiNz.2da
09-26-2006, 08:57 AM
A shortcut to stoffe's method is to Shift+Right-Click a .2da file and choose the "Open With..." function. It'll bring up a browser window.

Choose an appropriate program (KT) and there's also a checkbox function where you can set "Always open with this program".. :)

goldberry
09-26-2006, 06:11 PM
OMG! Shift + Right Click??? Chainz.2da, you are a GOD! Do you have any idea how annoying it is having to scroll down to open with every time i want to open a .tga in photofiltre instead of photoshop? You've probably just saved a minute out of every day spent modding (about three minutes of my life then :P).

Hang on, I take it all back. There's no difference between shift and right click and right click. No life saved... *sniffle*.

ChAiNz.2da
09-27-2006, 09:01 AM
Hang on, I take it all back. There's no difference between shift and right click and right click. No life saved... *sniffle*.

1) only works in XP or higher (without registry editing)

2) try right-clicking (or shift+right-click) the file's icon not the text part of the file and see if that helps. It's a basic XP function so you should be getting that context menu unless your system is wanting to be pain in the arse for ya' :xp: hehehe...

Darkkender
09-27-2006, 10:47 AM
Even if you are using a non-XP system the Open-with option should be there. Simply by choosing the new program you want a particular file to open with and making sure that you check the "Always Open with This program box" will do the trick. I've been doing this since Win95.