PDA

View Full Version : Annoying Graphical Glitches In KOTOR


zombieman
12-28-2006, 11:27 PM
I'm playing KOTOR for the umpteenth time, and I'm having odd graphical glitches in the cantinas and the sewers of Taris. It's like some of the textures of whatever room I'm in are missing, and I can see through doors and walls. Screenshot here:
http://img184.imageshack.us/img184/1839/graphicserroryz7.png
I've never had these problems before. I've tried all possible combinations on the graphics options, lowering screen resolution, turning off AA and antistropy, and all the other stuff. No joy.
So, has anyone else had the same problem, and how do I fix it, it's making my game impossible to play? :(

[SWKotOR]
ReportDateTime=29/12/2006 03:18:53
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
C:\pagefile.sys=1536

[CPU]
CPUCount=1
CPUSpeed=1813
CPUFamily=15
CPUModel=1
CPUStepping=2
CPUVendor=Intel
CPUName= Intel(R) Pentium(R) 4 CPU 1.80GHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=33.12GB
D: (NTFS), UNICODE=21.89GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\,F:\,G:\
Drives=PIONEER DVD-RW DVR-105,SAMSUNG DVD-ROM SD-616F

[Video]
Video Card Name=NVIDIA GeForce4 Ti 4200 with AGP8X
Video Memory=128
Desktop Resolution=1024x768x32 @ 85Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=1.5.7
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce4 Ti 4200 with AGP8X/AGP/SSE2
NVidia Driver=6.14.10.9371
Vid Card Status=Pass
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Sound Blaster Audigy
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=75
Voiceover Volume=94
Sound Effects Volume=94
Movie Volume=95
Force Software=0
EAX=3
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1
Environment Effects Nonstreaming=1
Environment Effects Streaming=1

zombieman
12-30-2006, 01:50 PM
Hmmm, I'm getting the exact same problem in TSL as well, but not in any other games. I'm confused!

bluewhale
01-03-2007, 12:17 AM
Hello! Based on your single screenshot, I think I had the same problem. Unfortunately, this was on my first playthrough of the game, so I basically wasn't able to fully enjoy the game as intended.

While enduring a ridiculously circular e-mail exchange with LucasArts Support, I read through numerous posts on forums trying to find the answer, and finally found a response that worked.

Basically, the newest NVIDIA drivers breaks functionality with KOTOR 1 and 2, and thus, the only way to fix it is to go back to an older driver set. Here's (http://forums.lucasarts.com/thread.jspa?threadID=113327&tstart=50) the relevant forum post I found. LucasArts finally wrote back a similar response, a day after I found this. Also, just in case the link doesn't work for some reason, here's the copied response:

I was having the same exact problem.....I noticed the places this problem occured at its worst for me was in the Taris Cantina, the Taris Sewers, Manaan Ahto West, The Kasyyyk Lower Shadowlands (really bad), and The Starforge (where it was literally really really bad).

Just to let you know this graphics glitch also occurs in KOTOR2.

I believe its driver related, and luckily there seems to be a solution....what you need to do is roll back your drivers, I rolled them back to 81.24, but some say its recommended you roll back to 77.77.

I rolled back my drivers to the Nvidia 81.24 and the problem literally went away in KOTOR2, and I decided to see if it went away in KOTOR as well....it seemed like it did, I had to start a new game since I deleted my saves so I only tested it as far as the Taris Cantina, but everything seemed to be fine up to that point and it fixed the problem I used to have there, so I'm pretty sure that fixed the problem in the other places too.

Basically follow these steps to roll back your drivers:

1) Download Nvidia ForceWare 84.21 and/or 77.77 and a program called DriverCleaner Professional.
2) Install the DriverCleaner
3) Uninstall your current driver by using Control Panel and Add/Remove Programs (look for NVIDIA Display Driver).
3) Then restart when prompted and boot into Windows Safe Mode by pressing and holding F8 until a menu appears then select the Safe Mode.
4) Once in Safe Mode, run DriverCleaner, select nVidia from Cleaning Selection drop-down menu and start cleaning.
5) Next, Install the ForceWare 84.21 drivers by running the installation package file.
6) Reboot when prompted after 84.21 driver installation.
7) Check the game now.

If it doesnt work, redo the steps but roll back to the 77.77 driver.

Hope this helps.

If you need to get the older drivers, I found them here: 3dChipset.com (http://www.3dchipset.com/drivers/nvidia/official/index.php)

Also, DriverCleaner Pro is no longer free, although you can still find a free version out there somewhere if you look for one. You should be able to just uninstall the drivers using the normal windows control panel. The DriverCleaner Pro route is if you want to be extra safe, I guess.

Anyways, I hope this helps. I think this may be starting to be a common problem. There should really be a stickied "common problems" thread that has fixes to questions people ask.

zombieman
01-04-2007, 03:02 PM
I'll give that a go later, thanks for your help :D

Edit: It worked a treat, many thanks!

Zeophite
10-04-2007, 08:18 PM
i have the same video card......same problem

Sinapus
04-19-2008, 11:47 PM
Out of curiosity, does this problem still exist with the latest nvidia Forceware drivers?