View Full Version : A little help, please...

02-11-2007, 12:06 AM
Does anyone have any idea why transparent items would not show as transparent, in game?

02-11-2007, 12:47 AM
Well the only thing that I can think of would be that your "Frame Buffer Effects" option in the "Advanced Graphics" section of the "Options" menu is either not on or not available. From what I see though your computer should be able to support that. So my advice is to go and see if that option is selected, if so then I am not sure what is going on. Hope this helps you out.:D

02-11-2007, 01:29 AM
Thanks, but yes, it is turned on. What's happening, apparently, is that in the alpha channel, what I black out, becomes shiny. It's just more pronounced than the grey areas. Any advice would be appreciated.

EDIT: Oh, is it possible to have multiple alpha channels?

02-11-2007, 01:52 AM
Well that would be only caused by a modifier (ie: a .txi file). You could try renaming the texture if you can but other then that I am not sure what else there is that can be done.

Now to your second question my answer is not likely. I have tried to do that before and it did not work out so to my knowledge it cannot be done. I could be wrong though. Sorry.:(

02-11-2007, 09:17 AM
Well, thanks. I'll see what I can dig up. :D

EDIT: Okay, I'm havin' a little problem diggin' up the .txi file for some specialized armour. How would I go about findin' the .txi file, or possibly replacin' it?

Edit 2: Where can I find the .txi files for armour?

02-13-2007, 01:08 AM
Where can I find the .txi files for armour?
You don't, they are part of the tpa file... When you view the skin file in KotOR Tool you can see a little white text box in the bottom corner of the image viewer, that is the txi info. When you extract the tpa to a tga there is a checkbox to extract the txi info as well. ;)

02-14-2007, 11:51 PM
Oh, okay. Thanks. Is there already a thread on how to edit .txi?

02-15-2007, 05:14 AM
Don't need one you can make and edit one with windows notepad. Simply open the ones you extract with KT up with notepad and edit them to taste and save them. ;)

02-20-2007, 12:41 AM
Is there a thread on editing *.txi?

02-20-2007, 11:39 PM
TXI files are simple text files that contain info the game uses for a texture, that's all they are.

What about my above posts are you having trouble with?

02-21-2007, 10:29 AM
I'm not familiar with the way .txi work. I'm fairly new to this. Glovemaster has given me help, however, I'm not understanding why things are shiny, instead of transparent.

02-21-2007, 12:41 PM
A .txi file tells the game to apply a shader on the places with blackes out alpha channels on the texture. If you want the texture to be transparent, you save an empty text file in notepad, re-name the file to be the exact same as your old file that you extracted with the texture (also make it a .txi instead of .txt by re-naming it).

Hope that clears it up :).

02-21-2007, 02:27 PM
That didn't work. I don't know what else to try. Thanks anyways, though.

03-09-2007, 04:32 PM
Alright. I made the .txi blank. I named it exactly the name of the file that I needed. Still it uses the baremetal coding instead of the transparent.

03-09-2007, 10:27 PM
You may have already sortedthis out so sorry if it's a stupid suggestion, but sometimes i find the simple solution is often the correct one. Have you checked to make sure if the appearance.2da is using the correct envmap? If you are making armor that is. If you want it for a party member you neet to change the "Party_NPC_whoever" envmap, or if it is for everyone all of the "Party_NPC_whoever" lines as well as the "P_FEM and P_MAL" envmap's to whatever it is you want to use.

03-09-2007, 11:22 PM
Well, I just changed every envmap in the appearance.2da to default, those that weren't "****". Still doesn't work. I also have the .txi that is empty, still. Anyone else have any ideas?

03-12-2007, 12:21 AM

03-12-2007, 12:49 AM
If your still getting a Shiny surface then it means that you haven't put your new 2da file in your main override directory. Also don't bother with the TXI file if it is a blank TXI. The only reason a TXI file is needed is to force a specific texture alteration to a specific texture as compared to the appearance.2da which effects all textures for the entire appearance.

03-12-2007, 12:51 AM
Okay. I will delete the .txi. However, the 2da that I edited, was already in the main override. I've opened it a few times, just to be sure.