PDA

View Full Version : A problem I have


TheRealDem
04-03-2007, 08:16 PM
I know how to edit uti files but I cant edit the restrictions you see I have this mod I cant remember the name of but anyways it gives you robes for bao dur.And It has a restriction like Cannot Equip:Bao Dur and the Useable by:Bao Dur thing how do I remove the restriction???????


*********Sin*********

stoffe
04-03-2007, 09:34 PM
I know how to edit uti files but I cant edit the restrictions you see I have this mod I cant remember the name of but anyways it gives you robes for bao dur.And It has a restriction like Cannot Equip:Bao Dur and the Useable by:Bao Dur thing how do I remove the restriction???????


I believe this is tied to the base item type of the item, and nothing you can change for an individual UTI template. If you want to make a new robe that Bao-Dur can wear you'll need to create a new base item type for those robes in baseitems.2da, and then set your Bao-robes to use that Base Item in the UTI. Copy&paste one if the existing robe lines (35 for normal, 37 for master) in baseitems.2da to use as base.

TheRealDem
04-04-2007, 01:06 PM
It still didnt work I did everything you said.Im using the hidden compartment mod so yea I have no idea what to do.

stoffe
04-04-2007, 01:21 PM
It still didnt work I did everything you said.Im using the hidden compartment mod so yea I have no idea what to do.

On your new line in baseitems.2da, did you change the value in the reqfeat0 column to **** and itemtype column to 37?

Did you remember to change the BaseItem field in your UTI to the new base item you just added (it's easier to use a GFF editor to just set the line number directly rather than try to find it in KotorTool's dropdown menu).

Did you try to equip the robe in-game? The "Cannot be used by..." text is part of the item description and won't change automatically even if he can equip it, as far as I remember. :)