PDA

View Full Version : Folders locked in Windows?


stoffe
06-29-2007, 08:36 AM
When I tried to download something yesterday Firefox complained that it didn't have permission to write in the destination folder and canceled the download. Examining the folder in Windows Explorer revealed that the "Write Protected" checkbox was checked, but dimmed. Clicking the checkbox seems to check/unckeck it as usual, but closing the property window and then re-opening it again the setting is still shown as a dimmed checked checkbox no matter what I left it at. (It did seem to allow me to download files to the folder again though.)

Since I haven't intentionally locked this folder, and I could download to it no problem the day before, I found this a bit odd. Examining things further it looks like every single folder on the computer is shown to be "write protected but dimmed" when examining its properties in Windows.

Do anyone know if this is normal and just not something I've noticed before, or is there some sort of "lock all folders" setting I've accidentally turned on that's causing this? If so, how do I turn it off?

Ray Jones
06-29-2007, 08:53 AM
Usually a dimmed checkbox means that if you have selected more than one folder/file some of them have that attribute set and the other not. However, a write protected folder should not keep you from storing files into it, it's just more or less "protected" against deletion or a rename.

It is more likely an issue of the user's permission to write to that folder. Have you checked the security settings already?

stoffe
06-29-2007, 12:24 PM
Usually a dimmed checkbox means that if you have selected more than one folder/file some of them have that attribute set and the other not. However, a write protected folder should not keep you from storing files into it, it's just more or less "protected" against deletion or a rename.

It is more likely an issue of the user's permission to write to that folder. Have you checked the security settings already?

I seem to be able to copy files to the "dim-checked" folders in windows, and nothing I do seem to be able to change it from showing the checkbox set that way. Since I'm using Windows XP Home Edition (SP2) there aren't much in the way of security settings to mess with.

It's possible the folders have always been shown that way, and I just took notice of it yesterday when I suddenly couldn't get Firefox to save new downloads in my inbox folder any more, and ATI Tray Tools suddenly stopped saving screenshots in the screenshot folder. :confused:

ChAiNz.2da
06-29-2007, 12:58 PM
Are you logged in as an Admin? also, is the folder earmarked "Read-Only"? Write -Protect can't be turned off on a read only folder...

Another step you can try is a hostile takeover :devsmoke: I wasn't aware that XP Home prefers to do this in Safe Mode though? That's a new one or me :giveup:

http://support.microsoft.com/default.aspx?scid=kb;en-us;308421&sd=tech

http://support.microsoft.com/default.aspx?scid=kb;en-us;308418