PDA

View Full Version : Vista/Securom Problems


JMartin25
07-07-2007, 11:04 PM
Recently after installing vista on my new Dell XPS 210 I ran into compatability issues while attempting to play KOTOR and TSL.

Is there a way to fix these problems?

My stats are below:

KOTOR:

[SWKotOR]
ReportDateTime=6/26/2007 8:07:26 PM
SysInfoVersion=v1.00.19
GameExists=1
GameVersion=v1.00.514058
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR\

[OS]
Name=Win9x
Version=Windows 9X v6.0 build 6000
Service Pack=None
Status=Fail

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=1862
CPUFamily=6
CPUModel=15
CPUStepping=6
CPUVendor=Intel
CPUName=Intel(R) Core(TM)2 CPU 6320 @ 1.86GHz
Status=Pass

[Memory]
RAM=2046
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=202.37GB
D: (NTFS), UNICODE=5.51GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\
Drives=

[Video]
Video Card Name=
Video Memory=1024
Desktop Resolution=1280x720x32
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=2.0.6288 Release
OpenGL Vendor=ATI Technologies Inc.
OpenGL Renderer=256MB ATI Radeon X1300PRO
Vid Card Status=Warning
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers / Headphones (SigmaTel High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=100
Force Software=0
EAX=3
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1

[Game Options]
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=1
Difficulty Level=1
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1

[Movies Shown]
Movie 0=0
Movie 1=0
Movie 2=0
Movie 3=0
Movie 4=0
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=1
Anti Aliasing=0
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1

[Autopause Options]
Mine Sighted=1
End Of Combat Round=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[config]
firstrun=0

***

TSL:

[SWKotOR]
ReportDateTime=6/26/2007 9:03:48 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.10.427
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=1861
CPUFamily=6
CPUModel=15
CPUStepping=6
CPUVendor=Intel
CPUName=Intel(R) Core(TM)2 CPU 6320 @ 1.86GHz
Status=Pass

[Memory]
RAM=2048
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=199.48GB
D: (NTFS), UNICODE=5.51GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\
Drives=TSSTcorp DVD+-RW TS-L632D

[Video]
Video Card Name=
Video Memory=1024
Desktop Resolution=0x0x0
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.0.6479 Release
OpenGL Vendor=ATI Technologies Inc.
OpenGL Renderer=Radeon X1300/X1550 Series
ATI Driver=(null)
Vid Card Status=Warning
Vid Card Driver Status=Fail
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers / Headphones (SigmaTel High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0

[Game Options]

[config]
firstrun=0

****

If there's a driver or a patch or someway to fix this problem please let me know I wish to get back into the grove with these games



Mod note: Moved thread to the help forum since it isn't about modding. ~M

LiquidZoo
07-08-2007, 04:22 PM
There is a way, but I can't remember exactly what I did. I know it involved sending them an email and they sent me a fixed copy of the exe that would work on Vista.

Try contacting SecuROM. They should be able to help you out.

JMartin25
07-08-2007, 05:38 PM
tried that, did what someone recommended for the other one. I'll try doing that for KOTOR as well

Please don't use a bumping post. When people have an answer available, they will post it. People volunteer their help here, and this is not tech support, and sometimes it just takes time and you have to be patient. --Jae