PDA

View Full Version : [TSL] A TSLRP Companion Question Thread


SD Nihil
11-30-2007, 12:29 PM
Yesterday on file front: http://knightsoftheoldrepublic.filefront.com/file/K2RP_A_TSLRP_Companion;84731 A new version of this mod was recleased. It includes M4-78. I have a few questions regarding the new mod.

1. After installing the new version will I have to start a new game for it to work?
2. Do I need to install the Fixes listed in the last version?
http://knightsoftheoldrepublic.filefront.com/file/K2RP;83115
They are below and are at http://www.team-gizka.org/downloads.html
Dxun Equation Puzzle Fix
Fuel For Telos Quest Fix
Handmaiden Training->Cutscene Fix
Hidden Compartment Fix
Mira Spacesuit Fix
Skippable Mebla Dialogue Fix
Starport Visa Trade Fix
Telos Academy Imprisonment Cutscene Fix
Tienn Tubb's Store Fix
Visas Teaches Force Sight Fix
Nihilus-Visas In-Game Cutscene Tweak

3. Has the escaped criminals glitch in this mod been corrected? Please see the thread above that links you to the last version of this mod to see that JediExcel agrees with me it is a glitch. I have posted the glitch on the Team Exile forms first here where the team suggested a work around by talking to Lorso and that you can only get the criminals on DS. I have posted the glitch on the bug report thread

So has it been fixed or are they still only able to be killed on DS?

DarthStoney
11-30-2007, 02:05 PM
1.Yes you should start a new game because if it includes M4-78 it also adds a whole new bunch of globals for m4-78.

2.If the read me says to than yes install them.

3.Don't know about this one.

SD Nihil
11-30-2007, 02:15 PM
Thanks.

jedimaster81
12-02-2007, 09:10 AM
Does the USM mod work with this update or do we have to wait for another patch?

Darth Balor
12-02-2007, 08:19 PM
There won't be another patch, as it is to troublesome to make a patch just so that you can play USM. Also since the main object is to be compatible with TSLRP, USM compatiblity will eventually be impossible.

Qui-Gon Glenn
12-03-2007, 01:25 PM
There won't be another patch, as it is to troublesome to make a patch just so that you can play USM. Also since the main object is to be compatible with TSLRP, USM compatiblity will eventually be impossible.

My hope is that the mighty creators of the USM release a RP-intended modification of their mod, that will include as many of the sabers as is possible (avoiding the RP saber-specific script conflicts, if any), the random loot script, and Bao-Dur's armor. Love that armor, ChAiNz :)

I love the USM's added dialogue, the training scripts, etc.... and mean no disrespect to the USM in that regard. The TSLRP simply contains an altered and in most cases enriched version of those concepts, and will render the USM additions in those regards somewhat obsolete.

If you want to play the K2RP mod, I guess you have to accept this incompatibility... it will eventually be ok, when the TSLRP is released.

You could partition your HD and install TSL on the new partition, and play your USM modded TSL on one partition, and the RP modded one on the other ;)

RedHawke
12-04-2007, 02:29 AM
My hope is that the mighty creators of the USM release a RP-intended modification of their mod,
Well my hope is just the opposite, I hope that the people who make the newer mods buck-up like all the others modders before them and try to work out compatibility issues with older mods on their end (or use the patcher), but sadly that doesn't appear to be the case with some of the the 'new' mod makers.

DarthStoney
12-04-2007, 08:09 AM
Well my hope is just the opposite, I hope that the people who make the newer mods buck-up like all the others modders before them and try to work out compatibility issues with older mods on their end (or use the patcher), but sadly that doesn't appear to be the case with some of the the 'new' mod makers.

How come everyone is jumping all overthis mod not being compatible with USM
when TSLRP also states that when it is released it most likley will not be
compatible with USM and they are not going to make it compatible?

Arátoeldar
12-04-2007, 02:40 PM
Well my hope is just the opposite, I hope that the people who make the newer mods buck-up like all the others modders before them and try to work out compatibility issues with older mods on their end (or use the patcher), but sadly that doesn't appear to be the case with some of the the 'new' mod makers.

While I agree with you for the most part. However we know that Obsidian wanted to do a content patch. Admittedly we don't know exactly what Obsidian wanted to restore. However Team Gizka is restoring and bug fixing most of the game inline with most likely would have been in the content patch. Team Gizka is the only exception I would make to your rule.

RedHawke
12-05-2007, 01:02 AM
How come everyone is jumping all overthis mod not being compatible with USM
Who's jumping?

when TSLRP also states that when it is released it most likley will not be
compatible with USM and they are not going to make it compatible?
This place was formed from cooperation between modders and not exclusion... for it is statements like "they are not going to make it compatible" that makes their vaunted mod a pass.

Team Gizka is the only exception I would make to your rule.
Rule? I see no rule in my statements?

Sorry but mods like theirs are the reason for the sentiment, not the exception.

Darth Balor
12-05-2007, 07:19 AM
We'll can we really blame TG? Thev'e been wokring on their mod for 2 1/2 years now, they wouldn't spen more time to make a USM version.

Now the reason we won't make one is because; Our goal is to be fully compatible with TSLRP,eventually things will be lined up and scripted so our mod won't work right or even install without tSLRP on the machine. So if theire mod won't be compatible, how could ours?

stralight
12-05-2007, 10:15 AM
hey what up guys i got some question about what you can use with the K2RP A TSLRP Companion because i like to if i can put in stuff like the Coruscant - Jedi Temple and the HK-Factory Reconstructed and the HK-Factory Reconstructed Update (1.1) and the Tomb of Azgath N'Dul and the weapon rehaul 0.8 and the Feat Progression and Feats Fast Plus and Increased Attributes & Skills and TSL Difficulty Options and the TSL Multi-Stim and i want know if it ok to put in the K2RP Fixes and the K2RP USM Compatibility Patch for the Ultra Saber Mod if not please let me know ok please get back to me as soon as you can ok

Darth Balor
12-05-2007, 08:57 PM
There are no, "K2RP Fixes". The usm compatibility patch will not work with this version unless you want Vash to be silent during the Rebuilt Enclave scene. The Coruscant - Jedi Temple mod won't work since it uses the Galaxymap, which is used for m4-78. The other stuff should work.

Alkonium
12-05-2007, 09:57 PM
I noticed that this file seems to be gone from Filefront. Any chance it will be posted again?

Inyri
12-05-2007, 10:28 PM
That is not a likelihood, due to the plagiarized content the mod included. Shem and I discussed the issue and decided that the mod needed to go, especially given the author's poor attitude and refusal to properly credit all the borrowed content.

Darth Balor
12-05-2007, 10:39 PM
But we didn't use any content from team bantha, afaik. DSTONEY642000 did everything for M4-78, so if the loading screens are the same talk to him.

Inyri
12-05-2007, 11:04 PM
You'll have to take that up with Shem. I typically trust Devon, but I'm not familiar with your mod or his.

Shem
12-05-2007, 11:36 PM
But we didn't use any content from team bantha, afaik. DSTONEY642000 did everything for

M4-78, so if the loading screens are the same talk to him.Since you want to take this public I have no problem discussing this with you here. You have a history of plagiarism. Yes, you did credit Team Gizka's fixes when you included them in your original mod release a few months ago and I specifically told you that you either had to get permission from the authors or link users to the site where to get them. You handled that fine.

However you decided to use Darth333's work in your "revised" version of Deadeye Duncan on Manaan. I asked you to ask her for permission to use the files that you included in your mod release. You refused to do so and wouldn't even admit you were using any of them and it didn't seem to phase you that I had her mod right in front of my face comparing the files. I don't like being lied to. That is why that mod would not go up.

When Devon approached you about getting permission to use the work they did on M4-78, you made excuses and even went as far as saying:

"Also if you want to put that "using other poeple's work without their permission" stuff on me, then what about Modders? Aren't we using the developers files without permission? Havn't very legal mods been shutdown or taken to court because they are using another person's property without permission?"Sounds like to me your using that as a scapegoat.

Then you decided to publicly say this on FileFront:

"Emperor Devon is being psycho and taking down the mod, because he thinks we used some of Team Bantha's old files."We have proof you did. I'm sure since both Pavlos and Devon were on the former M4-78 know their own work and know that you stole it.

Originally Devon was going to be cool about it. Here is how this played out.

"Shem, do you know where Darth Balor got those M4-78 loading screens in his mod? They're completely identical to the ones Pavlos made when we were working om M4-78. Dunno if he asked for permission, tho given his past history I'd doubt it"Later:

well, I spoke with Pavlos. He didn't get permission from him either, and Archon II hasn't been around in ages. No credit was given in the readme anyway; I suppose we should e-mail him about this

"I don't think that would be worth a few loascreens myself, but we can't tolerate plagiarism. (Although that's assuming he refuses to ask permission from Pavlos/me for whatever reason.)"After replying and talking to Devon about it, we both agreed to just let you ask permission to use the files and we would have let it go. Talk about being nice about it and we didn't have to be.

Now you're asking surprised that you're banned from FileFront for your attitude and making excuses that it wasn't your fault that it was someone else's. You need to learn to take responsibility for your actions.

You are a talented modder, but you also seem to think that your talent gives you the right to be above the rules. You're going to learn hard lessons in life that talent doesn't get you out of trouble. This case is closed and I hope the mods shut down this thread and your release thread in the TUCE because you need to learn hard lessons for your stubbornness.

Malaksjaw
12-05-2007, 11:40 PM
Sorry but mods like theirs are the reason for the sentiment, not the exception.

I agree. I was really looking forward to playing TSLRP with the USM installed. I guess that won't be happening now :(




WOW. Shem owned.

Sith Holocron
12-06-2007, 12:11 AM
Archon II has prototype M4-78 loading screens on his Photobucket account. That would seem to be the likely source.

DarthStoney
12-06-2007, 12:52 AM
Archon II has prototype M4-78 loading screens on his Photobucket account. That would seem to be the likely source.

I just want to go on record saying I in no way used anything from anybody
elses work ,those screenshots are not from my M4-78mod. here is a link to download screenshots from my mod. http://h1.ripway.com/dstoney/Screenshots.rar

If it will help I sent a copy of my mod to MasterZionosis a while back he has seen the mod and can confirm it is not someone elses work.

Shem
12-06-2007, 01:26 AM
I can't believe Team Exile is still arguing this.

Here is so everybody can see for themselves. Here are the loadscreen screenshots made by Archon II.

http://img401.imageshack.us/img401/943/loadscreen1le2.jpg

http://img504.imageshack.us/img504/4702/loadscreen2bf0.jpg

Here's another giveaway that this was stolen from Team Bantha.

http://img254.imageshack.us/img254/6166/thecopyrightnq7.jpg

The text on both screenshots should have been a red alert to Team Exile as shown in that screenshot portion you see right in front of your face that you will see in the full sized screenshots posted (anyone of the 637 downloaders of this mod before it was deleted can varify it), but they refused to believe it was going to be a problem nor cared to ask for permission to use them, nor did they want to ask permission after being asked to do so. If Team Exile would have just done what we asked instead of arguing and flaming us, the mod would be still up and the fix would have been already uploaded. I just don't understand people.

I've had enough of all of this. This case is closed. Arguing this with me or Devon is not very smart because all you're doing is digging a hole and ruining your credibility in the process. You had two choices.

1. Ask for permission when called on and keeping your project alive and welcomed on FileFront

2. Decided to pretend you didn't steal work and argue.

You decided option #2 and decided to flame Devon who not is only one of my staff members, but a member of Team Bantha. Yeah, that was a great idea. :rolleyes: Now, he'll never give your team permission to use them.

Now people are going to be upset because the future of this mod is in jeopardy and the only people they should be mad at is Team Exile.



EDIT: I just got a PM from one of Team Exile's members that is a devastating blow to their defence, but he may not be ready to say it publicly yet. Devon, Inyri Forge and I have briefly talked about it on MSN and have now decided that after their bans are served that they will only be welcomed back as members to FileFront, but their mods will not be accepted anymore. They can post their stolen work someplace else as far as I'm concerned. If anybody was excited for this mod, I appologize for your disappointment. They have only themselves to blame.

RedHawke
12-06-2007, 02:12 AM
Well as this thread really is redundant (As the mod has a release thread) I am going to close it.

Edit: This is confusing Shem the mods are still available?

http://knightsoftheoldrepublic.filefront.com/file/K2RP;83089
http://knightsoftheoldrepublic.filefront.com/file/;83115#Download
http://knightsoftheoldrepublic.filefront.com/file/K2RP_USM_Compatibility_Patch;83217

Until they are taken down I can't really close the mods Release thread... Unless we get more info as to why this needs to be done from the modders involved (Via PM please).