PDA

View Full Version : Lightsaber Modelling??


Darth_HaHa
12-31-2007, 01:55 PM
Okay, I'm trying to learn to model, and here's what's going on.

I can model my new hilt, (however, it'll only work if I use the verts, faces, etc. that were already on the lightsaber. How can I add my own custom shapes?) and I can get the modelled hilt in game.

When I equip it, however, The blade is very faint and can only be seen full brightness from one angle. When the PC extinguishes their lightsaber, the blade remains visible.

Can someone help me fix that?

Inyri
12-31-2007, 03:27 PM
Check the A-Z of Lightsaber Modeling tutorial and read the section on rigging. Follow it step-by-step and you should no longer have any problems.

Darth_HaHa
12-31-2007, 03:46 PM
That's not what I mean.

I was thinking more like, if I wanted to, adding a sphere to the bottom of the hilt and getting it to work in game.

The rigging section refers to replacing the hilt completely with one of your own.

Inyri
12-31-2007, 03:48 PM
It's still applicable, and if you don't follow the instructions you won't get the desired result (as you seem not to).

Darth_HaHa
12-31-2007, 05:57 PM
Okay, I got the hilts working.

Does the same apply for the blade?
It's still invisible from a few different angles, and is still visible when oyu extinguish your lightsaber.


[[Sorry for being the pitiful specimen of the day. I'm a complete noob, is all :p]]

Inyri
12-31-2007, 06:05 PM
If you're having the same problem with the blade then you obviously didn't follow the tutorial properly. It actually is important to do what it says regarding the replacer.