PDA

View Full Version : TXI file not working


Kalos
01-01-2008, 04:48 AM
I don't get it. Txi files I make for custom skins don't work. I copy another TXI file that works and has the baremetal thing in it and rename it to the exact name of my texture file and make it a txi file. I have the alpha layer all set up and working for my texture, but it doesn't use baremetal shaders ingame like my TXI tells it to. It uses the default transparent one. Why won't my txi file work?!?

90SK
01-01-2008, 05:49 AM
txi files don't determine what shaders work on a model, I think that's in the appearances.2da file. In all honestly, I've never understood the point of txi files to begin with - they don't do anything. If the model uses the shader by default, it'll work, and if not, the txi doesn't change it.

I dunno. What model are you trying to apply the shader to?

Kalos
01-01-2008, 06:03 AM
The tunics from KOTOR 1. Apparently, judging by this mod which I am using as a base for mine: http://knightsoftheoldrepublic.filefront.com/file/Movie_Jedi_Robes_and_Armours;73982

they were included in Kotor 2. The skin and everything is working but the TXI file won't.

Silveredge9
01-01-2008, 08:14 AM
As far as I've figured out, the main difference between using .TXI files and editing the appearance.2DA file is...

With TXI files, the shader settings added (for example CM baremetal) would only be applied to the associated .tga texture file of the same name and wouldn't effect anything else.

With an edited appearance.2DA, the shader settings added (Again, for example CM baremetal) would be applied to everything that the character wears automatically. Which sucks if you intentionally want transparency on some items, yet want reflective surfaces on others.

TXI files work better.

Have you checked to see if the text within the .txi file is correct? For CM_Baremetal, all you need within a .txi file is:

envmaptexture CM_Baremetal

Kalos
01-01-2008, 07:52 PM
Yep, that's exactly what I have in it.

stoffe
01-02-2008, 10:03 AM
I don't get it. Txi files I make for custom skins don't work. I copy another TXI file that works and has the baremetal thing in it and rename it to the exact name of my texture file and make it a txi file. I have the alpha layer all set up and working for my texture, but it doesn't use baremetal shaders ingame like my TXI tells it to. It uses the default transparent one. Why won't my txi file work?!?

I'm no expert at modeling so I don't know what exactly, but in my experience TXI files only have any effect on some models. So presumably something must be set in the model itself for the game to be able to use TXI information on it.