View Full Version : SWBF2 doesn't work in SINGLE OR MULTIPLAYER!!!

02-13-2008, 12:37 AM
Well, I usually just get on the computer and play SWBF2 like a casual person. But today I got on and when I went to play it, instead when I went to Multiplayer mode and clicked on the -=WGO= server it went to the "Joining Session" thing and counted to "1" and then the screen went black like usual before going to the loading screen of the map I was going to play on "Mos Eyesley" but it didn't go to the loading screen.

Instead it went back to Windows. I thought this was just a basic firewall problem because I restored windows earlier after this little spam device got on my computer that I fixed easily and is no longer on my computer.

I fixed it earlier (flashback ends).

Then I wanted to make sure that, THAT was the problem. But it wasn't because I went to SINGLE PLAYER MODE and went to TRAINING MODE, and it did the exact same thing but just went black screen-windows without the "Joining Session" thing ( because it wasn't a mulitplayer game).

I then reinstalled the game 2 TIMES, REMEMBER 2 TIMES. I uninstalled the game and went to the LuscaArts Folder and deleeted all the leftover files and when I installed it I made sure it put in all new files like when I first installed it and when I uninstalled it I made sure it deleted everything.

Now everything is gone and everything is back like I just bought the game and started playing it like on December 30th, 2007.

I tried the game again and IT DIDN'T WORK AGAIN!!!

I uninstalled xfire, i have no utorrent. I got nothing that is bad. I manually checked Luscas Arts folder for abd stuff. I did a anti-spyware scan with spybot. I even tried playing other games like StrongHold 2 and it works fine.

For some reaosn it doens't work and I am so lost and confused and I am in need of help =(.

Is it a simple solution of a complicated bug? Please post in this topic and help me or e-mail me at davidcagle93@yahoo.com.

Please Help Guys, and Thank You. (^_^)

02-16-2008, 08:03 PM
anyone going to respond or help at least a bit?

02-29-2008, 12:06 PM
you click ex. training and it goes to windows? Try to disable sound, if it works update drivers for youre sound decive. And shut down all programs using microphone or else.

09-24-2008, 05:57 PM
Okay, if your computer is a dual core, this might help. If not, I can't do anything.

Put in the CD, and let the BFII launch menu come up. Don't start the game. Press CTRL-ALT-DEL, and that will bring up Task Manager. Click on the tab, "Processes". Look through the list and find "LaunchBFII.exe". Right-click that, scroll down the clicky menu, and click on "Set Affinity". In this dialog box, uncheck "CPU 2". Now exit these windows, and go back to your launch menu. Start the game.