PDA

View Full Version : IRQ troubles; of BSODs and no sound


Sabretooth
06-05-2008, 04:27 AM
It seems that my system has been having trouble with IRQ, the existence of which I learnt only recently. I still have no clear idea as to what it is, so any educational help in that direction will be appreciated.

First come the BSODs. My XP is very stable, but very rarely did it come at me with a BSOD saying IRQL_NOT_LESS_OR_EQUAL, sometimes DRIVER_IRQL_NOT_LESS_OR_EQUAL. The problem happens in some (not all) Unreal-based gams, it seems at first.

This happened in Republic Commando and Brothers in Arms: Road to Hill 30 at very specific points in the game. For eg. In RC's first prologue scene, I got the BSOD when I moved my mouse to the right. Then it would sometimes crash if I had the night-vision mode or sniper zoom on. Sometimes it would happen randomly. In BiA, I can't progress past a level - after capturing a farmhouse and receiving the next objective, the game seems to crash regardless of where I am.

The problems seem to have escalated when I tried Planescape: Torment. With it, the game crashes at absolutely random points, usually 3-10 minutes into the game. I've also noticed it occur outside the game now more often. My system isn't crippled or unusable yet, because it's still like once or twice a week, if at all.

Yesterday my sound just stopped functioning. I reinstalled the drivers, and still nothing (much as I had expected). A quick look at System Properties' Hardware tells me that my sound device "cannot start" with a Code 10. Some research tells me that it has something to do with "IRQ" that is assigned to various PCI devices. I can't say I'm too well-versed with such things, so any help would be nice.

I've explored my BIOS options completely and not come to any solution so far. Halp!

Boba Rhett
06-05-2008, 04:42 AM
What's the exact error code? Can you see your list of IRQs in you bios? Is there much sharing going on? Did this start after updating any of your drivers?

In the mean time, a lot of the time this can be caused by a ram problem. Try reseating your memory. In fact, reseat your cabling too. If that doesn't fix it, run memtest86 (http://www.memtest86.com/) and see what it says.

Q
06-05-2008, 06:08 AM
The next step would be to reinstall the drivers for your sound and video cards. Make sure that you use Driver Cleaner Pro (http://downloads.guru3d.com/download.php?det=745) when doing so. That worked for me when I had this problem.

Sabretooth
06-05-2008, 12:58 PM
What's the exact error code? Can you see your list of IRQs in you bios? Is there much sharing going on? Did this start after updating any of your drivers?
Don't remember updating any drivers all year, so I can assure all you guys that it is most likely not connected to drivers.

I don't remember the error code since its a BSOD, but I can have it written down if its really necessary. As for the sound issue, it says that there is a "Code 10" on my sound device; i.e. the device failed to start.

I can see a list of IRQs in my BIOS, which lets me set whether each IRQ no. should be set automatically or reserved. I tried switching everything to either option, with no headway.

Not sure what you mean by sharing - again, I don't know much about IRQ other than it's called Interrupt Request and it has something to do with resources.

I'm thinking of resetting my cabling alright. One idea I have in my mind is to take off the sound card, start the system, shut down and then put it back in. Or a variant of that approach.

Sabretooth
06-05-2008, 11:26 PM
Alright, it looks like I've got my sound working now. I had a power crash, and my feeble motherboard quickly doled out a "CMOS settings reset" message. I knew that this can only be good. When I booted Windows, tada: sound ist werking perfectly!

Astrotoy7
06-06-2008, 12:25 AM
Hmmm... IRQ conflicts are tricky buggers. I'd monitor that sabre. They are intrinsically related to devices that are using PCI/USB bus >>which your PSU doesnt do. CMOS will reset after an unstable power event, whether its internal or external... its a safety thing and may not have necessarily fixed your issue(or even be related to it!) If the *original cause was a power management issue, then thats a different story, and definitely could have caused your issue. ie. power management to a particular PCI/USB bus is not working properly, causing the CPU to mis-identify it when its request is sent through... said power management issue eventually causes the CMOS reset >> an interesting interplay of events, where the IRQ is more of a symptom of a deeper underlying cause !

What is IRQ ?? An Interrupt ReQuest is exactly that. Your CPU is happily doing what its doing, then a device says "stop that! take care of me!" The CPU dumps some of what it doing to ram/HDD cache and attends to your device request. Unfortunately, devices commonly share IRQ values, and your CPU can get frazzled figuring out what and how :) Up to 100 devices can sometimes share an IRQ value. Fortunately, some extra controls are built into modern devices/cards that minimise this, like 'IRQ holder for PCI steering' or 'ACPI IRQ Holder for PCI IRQ Steering' controls. Its much less of a problem now than mainboards and hardware back in pre XP days for example.

common fixes. Uninstall >> reinstall into another PCI slot. Unplug any usb devices(incl modem), reinstall devices one at a time, differentiating between what the troublemaking component(s) are. My friend had a "usb stick from hell" >>whatever he plugged it into, it caused all sorts of problems...plugged it out, all was happy again :)

Anyway if whatever has happenned has actually fixed it, good. But just keep an eye out ;)

mtfbwya

Sabretooth
06-06-2008, 02:13 AM
It seems that the problems occurs in any game now. I was just playing Sacrifice a few moments ago when it gave me a blue screen about 4 minutes into the game. This time it pointed out to "ipnat.sys" (the Planescape ones showed me atapi.sys).

I think I'll break it up and do the Astro approach of adding things one-by-one on Sunday, if and when I get the time. Frankly speaking, it must be my really old motherboard that must have gotten fried.

But whatever the case, the BSOD occurs the most only in games, which is somewhat disturbing, since none of the cases appear linked to graphics (I has an AGP card lulz). I haven't played much games for a few weeks now, so I probably didn't notice. But I can swear that there was absolutely nothing wrong about a month and a half ago, at least.

So yeah, at least I have sound now.

Ray Jones
06-06-2008, 04:49 AM
IRQL doesn't equal IRQ

IRQ = Interrupt ReQuest
IRQL = Internal ReQuest Level

However, possible causes are (physically) bad memory or a bad driver.

http://msdn.microsoft.com/en-gb/library/ms793589.aspx

Astrotoy7
06-06-2008, 11:25 AM
Both of these are drivers that control background system processes...albeit quite important ones :)

ipnat.sys is related to networking processes and atapi.sys to IDE/Hard disk control processes.

Did you do end up nuking that linux partition... who knows , something in windows may have become corrupt in the repartitioning/formatting that ensues.

If it still bothers you and you've tried everything else, reformat before you consider ditching your mainboard ;)

mtfbwya

Sivy
06-06-2008, 12:06 PM
i have come across the 'DRIVER_IRQL_NOT_LESS_OR_EQUAL etc. etc.' on a number of occassions... well three times... on two of them it was bad RAM and the other was a faulty video card.

could be the same with you; especially seeing as it happens during games, as this is time when your RAM and video card are working the hardest.

i remember googling it when i first got that message and there's no definite answer. it's such a vague and misleading error message as it automatically makes you think there's it's to do with drivers or IRQ/IRQL... but it could be a number of things. trial & error is the only way to go... but the first thing to check is the memory. if you've got more than one stick of RAM installed try them out individually and run memtest like Rhett suggested.

Sabretooth
06-08-2008, 08:53 AM
Update time, folks. I went through the MSDN article Ray linked, it was a good read, albeit not extremely helpful. It did suggest running a memory diagnostic, so I decided to go for it. But first, just to make sure, I took off the memory sticks, cleaned them (dusted them, to be more precise) and put them back in. As a quick run of Morrowind suggested, this made no difference.

I had memtest86+ on my Kubuntu disc, so I went with it. During Test I I got about 31,000+ errors, with all sorts of hex codes and the lot. All the other tests went flawlessly. To double-check, I downloaded Microsoft's Windows Memory Diagnostic, which reported zero errors on all tests. Strange.

Meanwhile, some research told me that anti-virus programs can also sometimes cause the BSOD. This brings me to an unusual suspect: AVG Anti-virus. About a month or two ago, I had it updated to AVG 8.0, which is the new and swanky version. I also have Spybot running to take out spyware. The thing is, AVG is pretty much the most recent prominent software that I have installed, and I know that there were no problems before it (except with BiA and RC).

The recent troubles only started after AVG, but I can't really say they started as soon as I had AVG installed. My gaming has been pretty on-and-off for the past three months. :( So some of you guys may want to take a look at the anti-virus direction here...

Meanwhile, there's that memory thing, yeah.

Q
06-08-2008, 09:21 AM
You play games with your antivirus running? :confused:

You should clean boot your system before you run any games. I even do it with ancient games like Baldur's Gate 2.

Sabretooth
06-08-2008, 12:03 PM
You play games with your antivirus running? :confused:
Well, the AVG tray thingie sticks around in the system tray... :/

While clean-boot-then-play is good advice, I think the matter here is far more, shall we say, material. :p

Sivy
06-09-2008, 05:30 AM
a lot of people are saying that their computers have slowed down after upgrading to avg 8 and that it uses a lot more memory than previous versions.

have you got scheduled scaning and update checking turned on? don't, turn them both off... do them manually.

Sabretooth
06-09-2008, 09:28 AM
Nope, don't have either going Sivsky. :(