View Full Version : Error when starting game

11-28-2008, 09:52 PM
I decided to start playing Jedi Outcast again, just like old times :)
But after I try and start it, the console comes up brifely, the game tries to start and then it goes back to my desktop.

I managed to take a screenshot of the console before it disappeared:


Any ideas? :confused:

11-30-2008, 05:54 PM
Look, I know people are reading this. Can someone actually post a reply and help me?

12-04-2008, 09:17 PM
Come on! 56 views and 0 replies? What's wrong with you people?! XD

12-05-2008, 03:16 PM
Maybe just noone knows an answer to your prob, it seems to be quite exotic. And the screenshot you posted isn't particularly helpful either, since the displayed contents seem to be ok; the error probably occurs later.
You could post your system specs, for starters (in particular viedo card & drivers).

12-05-2008, 04:27 PM
I've seen other people post similar screenshots and have their problem solved in the past.

But here you go:

Microsoft XP
Version 2002
Service Pack 3

Celeron(R) CPU 2.40GHz
2.41 Ghz, 1.00 GB of RAM

Graphics Card:
ATI RADEON 9600TX-VIO, all drivers up-to-date.

12-05-2008, 08:09 PM
I've seen other people post similar screenshots and have their problem solved in the past. ...
That's because those screenshots actually contained an error message hinting at the cause of the problem, yours doesn't (it seems you've shot before the actual problem occurred).

At any rate, try launching jk2 in safe mode (from the start menu); if that works, your problem is probably easy to remedy.
If it doesn't, maybe you'll have to downgrade the video driver (I think quite a few people have had problems running jk2 on ATIs with more recent video drivers).
But first things first.

12-05-2008, 08:47 PM
Just tried running it in safe mode and the console appeared for a second time, showing this:

JK2: v1.03 win-x86 May 3 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets5.pk3 (4 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

14978 files in pk3 files
execing default.cfg
couldn't exec autoexec.cfg
...detecting CPU, found Intel Pentium IV

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )
GLW_StartOpenGL() - could not load OpenGL subsystem

I guess I need to downgrade my ATI's driver then, huh?

12-05-2008, 10:21 PM
Well, you could give the 1.04 patch a try first, if you don't mind it.
In the meantime, lemme google for "GLW_StartOpenGL() - could not load OpenGL subsystem" first; that's a common error with quite a few possible causes.

You could give these drivers a shot: http://omegadrivers.net/ati_winxp.php

Before going to that length, try this first: Open the Catalyst control center and browse through the settings. Make sure that acceleration is set to maximum, OpenGL is enabled (if there is any way to disable it, that is; I don't have an ATI so I can't really tell if there's still such an option in the latest driver versions), and if you have multiple displays attached to your video card, deactivate all but one.
And while you're at it, check out the version number of your Catalyst driver suite and post it here.

Next option is to try the fix suggested at the bottom of this thread:

And if that doesn't work, try the Registry fix provided here:

12-06-2008, 10:58 AM
Wow, now that's more like it nizwiz! (Y)

I've already tried the 1.04 patch - no results.

Installing the Omega drivers now...

All settings in CCC seemed ok.

I really can't understand what that guy is saying, lol.

I'll try the Registry fix if the Omega drivers don't work.

12-06-2008, 11:20 AM
Installed the drivers and restarted my computer. JK2 now says that "There is no 3D hardware installed in your system. Please see the Troubleshooting Guide for a list of supported 3D video cards."

And where do I put the Registry fix?

12-06-2008, 04:10 PM
Since the omega driver didn't work, you could as well re-install the 8.11 ATI driver / CCC suite. After uninstalling the omega drivers but before installing the ATI drivers, could you check out some registry settings, please? Like this: Press <WindowsMeta>+R, type regedit, then <enter>. Then press <Ctrl>+F and search for OpenGLDriverName. If you find anything, scroll a few lines down (in the right hand view) and post a screenshot here.
Then repeat the same after installing the ATI driver suite.
And finally do the following: press <WindowsMeta>+R and enter dxdiag. Then press the "save all information button" and PM it me.

Screw it, I've run out of ideas. You might wanna follow this thread:
If anyone finds a solution there, it'll most likely work for you, too.

12-07-2008, 03:59 PM
Could not find OpenGLDriverName with the Omega drivers installed.
Uninstalled Omega drivers and attempted to re-install ATI CCC but got this message - "This display driver is not compatible with the display adapter(s) installed in your system."
The setup was then terminated. :confused:

12-07-2008, 04:22 PM
Right now I'm going through previous versions of the drivers (http://ati.amd.com/support/drivers/xp/previous/radeon/radeonxip-cat810-xp.html), hopefully one of them will install successfully and then make JK2 work.