PDA

View Full Version : Script Compiler issue - fp editing


devicem
03-06-2009, 07:53 AM
Hello,

Forgive me if I missed out the directions and posted on the wrong forum. Recently I was browsing trough the forums to find a way how to modify the fp durations to other values rather than the default ones. I read all the tutorials, guides, threads in which there were attempts, failures, successes etc. and I just don't understand one thing.

Whenever I try to compile sth using nwnnsscomp.exe I end up with a line where it states that Neverwinter Nights path was not specified.

I passed the part where I'm supposed to edit the k_inc_force.nss and extract k_sp1_generic.nss along with k_inc_debug.nss, but I just can't work out the compiling part and get the k_sp1_generic.ncs.

Once again, sorry for being newbie or accidentally missed out an important thread where it explains all this.

Star Admiral
03-06-2009, 12:40 PM
Did you put the nwscript.nss file in the same directory as the nwnsscomp.exe file? That might be the reason it didn't compile.

- Star Admiral

devicem
03-06-2009, 03:45 PM
Yes, sir, I did. The problem (as the compiler suggests) is being unable to locate or open Neverwinter Night. I tried all the methods with both compilers. Same problem. And I simply don't understand how I'm supposed to do it with KTool.

Star Admiral
03-06-2009, 04:20 PM
Which compiler are you using?

- Star Admiral

devicem
03-06-2009, 06:40 PM
Tried with both Fred Tetra's and HazardX's.

Darth333
03-06-2009, 07:06 PM
Did you read this? http://www.lucasforums.com/showthread.php?t=143681 There are several methods described, including a one click Kotor tool solution in the second post.

If it doesn't work, could you please post the exact error message you are getting?

devicem
03-06-2009, 07:53 PM
Yes I have, Darth333. I was specifically referring to your guide before I came here and sought help. Here's what I do, step by step, by all means please correct me if I'm wrong.

I made a new folder, in which I have placed all the necessary files needed(nwscript.nss, k_sp1_generic.nss, k_inc_force.nss, k_inc_debug.nss).

Then I put the 'nwnnsscomp.exe' in that same folder.

Using 'run' I go to cmd. Since I can't execute it directly, I have to "cd" to the folder where it's placed.

Writing the cmd "nwnnsscomp -c -v1.00 k_sp1_generic.nss" I get this msg:

'Star Wars: Knights of the Old Republic' Script Compiler/Decompiler
based on 'Neverwinter Nights' Script Compiler/Decompiler
Copyright 2002-2003, Edward T. Smith
Modified by Hazard <hazard_x@gmx.net>

Unable to locate or open Neverwinter Night

Darth333
03-06-2009, 09:16 PM
Sounds like you don't have Kotor installed.

Anyway, it should work with NWNSSCOMP port for KotOR Script Compilerby stoffe and tk102 available on our website: http://www.starwarsknights.com/tools.php#sct

Drop it in the same folder as your scripts and then:
nwnnsscomp -c myscript.nss

devicem
03-07-2009, 06:09 AM
Erm, ofc I do, I have KOTOR 2 installed, not KOTOR 1, if that counts then...where else could I have extracted the .nss from if not from the .bifs ?

As for the other thing you gave me to try, it worked. THANKS alot!