View Full Version : Jedi Knight issues on XP

12-12-2009, 12:46 PM
I decided to dig out my old copy of Jedi Knight recently as I been on a Star Wars kick, but sadly I been facing some issues leaving me unable to get it running.

First is the problem that the setup file does not open. The launcher, setup.exe and copying files over to the computer all end up with the setup just not starting up, and having to go into task manager to end the process tree. I tried all compatibility modes and choices, but it still does not run.

So I tried to do the manual install, following the guide step by step, but here I face a new challenge in that a small window pops up and shows this message


So it seems there's no way to get Jedi Knight to run as of now. I'm running XP SP3, and the Jedi Knight copy is my legit one, and has no scratches or anything. Does anyone have any idea if this is fixable? The install for Phantom Menace also has the same problem that it just does not open at all.

Hope someone has an answer, thanks

03-01-2010, 05:53 AM
It IS possible, try a search here, I swear there are about a dozen similar threads out there. I assume this is a legit copy and you have the 1.01 patch. The next step is to check JKhub.net for possible fixes.

03-14-2010, 04:12 PM
I am running JK DF2 on two differnt installs of XP, one SP2 and one SP3 and both intalled and run seamlessly. I am not sure why you have had trouble. I am not using the 1.01 patch, but i am using the JKE and JKUpdate of texture packs mods..and it makes for a stunning game.

03-31-2010, 04:54 PM