View Full Version : TFU will not start.

12-28-2009, 01:54 AM
I just got TFU off of Steam and after the lengthy download and massive install, the game will not start. I am able to get to the "launch" screen where you have the option to choose your resolution and controls and such, but once i hit "play" nothing happens. i tried reinstalling but the same thing happens. I run win 7 64 bit edition with 4 gig ram and a radeon 5850.

your assistance is appreciated.

12-28-2009, 04:19 PM
Try running the game with admin rights and in compatibility mode.

Nova Rift
06-27-2010, 09:58 PM
At least your getting that, I launched a new game and bam it started to play and it was halfway through the intro cutscene and then it crashed, so I relaunched the game and now the menu won't load and it is just 4 flashing dots like it is trying to load (sat there for an hour and it still didnt load) Kinda annoyed to be quite honest, I loved this game on the Wii and the 360 and was kinda stoked to play it on the PC.

My specs are actually probably just under the system requirements but I have no problem playing any other game (such as Mass Effect 2, Modern Warfare 2, APB, Global Agenda, Fallout 3, Assassins Creed 1 and 2, and Borderlands.)

Running Windows 7 32-bit, 3.5GB of RAM, 9800 GT, 1.8ghz amd 64 and disabled UAC while running it as administrator. Is there a way to set steam game to run in compatibility mode?

06-29-2010, 10:27 AM
I too 'Steamed' TFU a few days ago. Completed the download early Monday morning !!
I've not had any major issues so far, except a crash when trying to FRAPS video a sequence in the game.

I have noticed that the main menu seems to cover 2/3rds of the screen; the remaining space is just black.
I'd also like to be able to lower my screen resolution too. Lowest it can go is, 1280:720.

Nova Rift, your specs may actually be the problem here. When purchasing from Steam it does warn that you need a dual core processor or equivalent at least.
Granted; Mass Effect 2, MW2...etc may work, but those are PC optimised games.
TFU, evidently, is not !!
As a result you have an inflated port, needing inflated specs to run at a locked frame rate of 30fps.