PDA

View Full Version : [PC] Game in Slow Motion


mavickx
04-11-2010, 02:36 AM
Please help me!

I downloaded the game from Steam, and immediately started playing. I set the graphics to 1600x1200 and started the game. The game ran from the beginning as if it were in slow motion. I thought this must be because I had high detail set, with a high resolution, but the display seems fine, and the camera isn't really choppy. I turned the resolution to the lowest setting and turned off high detail, and it is still having the problem.

Steam is set to automatically update the game, so I'm not sure if a patch is the problem.

I'm running Windows 7 64x on a Intel I5 2.67ghz quad core, 8gb ddr3, and an Nvidia Geforce 210. I know the processor is only being pushed to about 25%, and the ram about 40%, so the only thing I can think of is the GPU is too slow.

Any ideas?

Tahurn
04-20-2010, 03:39 PM
Please help me!
I'm running Windows 7 64x on a Intel I5 2.67ghz quad core, 8gb ddr3, and an Nvidia Geforce 210. I know the processor is only being pushed to about 25%, and the ram about 40%, so the only thing I can think of is the GPU is too slow.
Any ideas?

I see it has been awhile since you posted this, but since there are no replies I figure I could toss in my two cents.

The system I'm running on is Win7 x64, AMD Dual Core 3.2GHz w/ 8GB RAM and a nvidia 8800 GT; so basically a step down from your system in every measurable way, however, the game runs very smooth with "high" detail and 1680x1050 res and most of the time my system temp doesn't bump above 45C, which is pretty low compared to most of my new games.

I am running the latest beta drivers for both audio and video which was required to fix issues I was having with an unrelated game. On the off chance you haven't resolved this issue yet I would start by trying new drivers.