PDA

View Full Version : Graphics Problem...


IFragAll
05-09-2010, 03:03 AM
the graphics are in blocks and dont line up and i cant see anything :/

heres the report

[SWKotOR]
ReportDateTime=5/8/2010 11:02:00 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
C:\pagefile.sys=2046

[CPU]
CPUCount=2
CPUSpeed=2812
CPUFamily=15
CPUModel=6
CPUStepping=2
CPUVendor=AMD
CPUName=AMD Athlon(tm) II X2 240 Processor 2812MHz
Status=Pass

[Memory]
RAM=2048
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=239.55GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\
Drives=ASUS DRW-24B1ST

[Video]
Video Card Name=ATI Radeon HD 5700 Series
Video Memory=1024
Desktop Resolution=1440x900x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.9017
OpenGL Vendor=ATI Technologies Inc.
OpenGL Renderer=ATI Radeon HD 5700 Series
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Realtek HD Audio output
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=30
Number 2D Voices=64
2D3D Bias=1.50
EAX=2
Sound Init=0
Disable Sound=0
Force Software=0

[Graphics Options]
Grass=1
Shadows=1
EnableHardwareMouse=1
FullScreen=1
AllowSoftShadows=1
RefreshRate=60
Width=800
Height=600
Emitters=1
Anisotropy=1
Frame Buffer=1
Soft Shadows=0
Brightness=57
V-Sync=0
Texture Quality=1
Anti Aliasing=0

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
UnlockedPlanetSongs=1
TooltipDelay Sec=1
Disable Movies=0

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=4

any help will do thanks

Q
05-09-2010, 09:53 PM
You are using XP, right? The reason that I'm asking is that the game can't properly ID any OS later than XP.

First, you should try the Dantooine lag fix:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.
Second, here are a couple of ATI-specific fixes that you can try:
Hello,

first some facts about the setup:

o Win7 x64
o KoToR via steam (so the installation guide is useless)
o HD5770
o Catalyst 10.2

It's rather simple, really. The game had trouble locating the OpenGL driver and I got a atioglxx.dll exception.

I found the workaround at guru3d and the AMD forums: Put the atioglxx.dll from Catalyst 9.12 in the game folder. So far it works in windowed mode only, but I am glad it works at all.

Source: http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067&enterthread=y
Thread at guru3d: http://forums.guru3d.com/showthread.php?t=315893

Maybe you can work this into one of the guides.

Thanks,
Christian
I downloaded ATI System Tools, created a game profile where I set Direct3d and OpenGL settings to Auto Balanced and it worked like a charm!
Lastly, if you're using XP or Vista you'll need to set CPU affinity every time you launch the game:
After starting the game, press Ctrl-Shift-Esc to bring up the task manager. Right-click "Knights of the Old Republic" under the applications list and select "Go to process." Right click on the highlighted process (probably something like kotor.exe) and select "Set Affinity..." In the dialog box that comes up, deselect all but one core. Then return to the game and see what happens ^/_\^

Just remember that you'll need to do this every time you start the game.