PDA

View Full Version : Gmax head model mistake


VarsityPuppet
05-19-2010, 12:48 AM
I made a terrible gmax mistake while head modeling.

I was modeling my new Maynard head, and updating the skin, when I accidentally hit "Import", which imported a whole new array of bones, meshes and trimeshes. etc.

Now, being a noob, I just deleted all the ones that I "thought" I had just imported.. that didn't work so well. Apparently, I got rid of some of the wrong ones, so some were left without parents. I didn't think anything of it at the time.

I continued vert editing until I was ready to export: nothing. I figured it had something to do with the unlinked sections - so I went and looked up how to link stuff, and I relinked those.

Now, when I try to export it says- Runtime error-bone index out of range: 1.

Is there something I am missing here? Do I need to attach the skin head_geo to some bones? Do I have to start all over?

Edit: Well, no worries. I just redid the head (didn't take as much time as I had anticipated).

Still no real solution to the problem, but oh well.

miro42
06-04-2010, 07:15 PM
Just a thought but after deleting all the bones and stuff that you don't need, import the base file again, connect the new mesh to the base mesh, so the weights are there, then select the base mesh (by element, otherwise you'll be selecting faces forever), delete it.
In theory, that should work...
So if you come across this problem again try this and then you can yell at me when it doesn't work! ;)