PDA

View Full Version : Kotor crash problem in xp


dewayne26
06-04-2010, 10:00 PM
on the endar spire i crash right in the area before run into the jedi. i can save before hand oad and make it off then i crash couple hours on taris. i tried going ddown to one quad that doesn't help. i had same this on ual prosessor before i had to upgrade my computer.

this report: 6/4/2010, 18:41:04
Machine name: PHIL
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.100216-1514)
Language: English (Regional Setting: English)
System Manufacturer: MSI
System Model: MS-7578
BIOS: Default System BIOS
Processor: AMD Athlon(tm) II X4 630 Processor, MMX, 3DNow (4 CPUs), ~2.8GHz
Memory: 2048MB RAM
Page File: 474MB used, 3466MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode

Qui-Gon Glenn
06-05-2010, 10:47 AM
The critical item missing from your system, or at least your system specs breakdown, is your GPU... do you have a graphics card, or are you using the chipset gpu?

Evil Q would prefer you posted your specs taken from your swkotor.ini file. It shows all of the info you gave us, plus GPU information and a few other handy tidbits.

dewayne26
06-05-2010, 01:41 PM
i have a nvidia 7900 GS

Q
06-08-2010, 03:12 AM
Are you setting CPU affinity to a single core in Windows' Task Manager each time you launch the game?

dewayne26
06-12-2010, 12:56 PM
yes and still crashing. someone told me it was a problem with switching control from computer to pc after cut scenes

Q
06-12-2010, 08:43 PM
Let's see what swconfig says and we'll go from there:
Post your system specs
Sometimes we're just not going to be able to help you if we don't know what kind of hardware you have on your machine. If you don't know what you have on your machine, then follow these steps below:
Bring up the launcher menu for Kotor 1 or 2.
Click on "Configure".
Click the "Scan Hardware" button on the lower center of the window.
Click "Yes" to continue.
Click "Details" to view your system specs.
Click "Save Report" and save the file to your desktop.
Whenever you post your problem, open the file you just saved and copy and paste the contents to your post.
I need this report because it can tell me whether or not your game is playing nice with your computer. Post the whole thing, please.

dewayne26
06-12-2010, 10:26 PM
[SWKotOR]
ReportDateTime=6/12/2010 8:16:14 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
C:\pagefile.sys=0

[CPU]
CPUCount=4
CPUSpeed=2800
CPUFamily=15
CPUModel=5
CPUStepping=2
CPUVendor=AMD
CPUName=AMD Athlon(tm) II X4 630 Processor 2800MHz
Status=Pass

[Memory]
RAM=2048
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=24.75GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\
Drives=ATAPI DVD A DH20A4P,ATAPI DVD A DH20A4P,ATAPI DVD A DH20A4P,ATAPI DVD A DH20A4P,FD-16 DVD-ROM16X,LITE-ON CD-RW SOHR-5239V

[Video]
Video Card Name=NVIDIA GeForce 7900 GS
Video Memory=256
Desktop Resolution=1024x768x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=2.1.2
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce 7900 GS/PCI/SSE2/3DNOW!
NVidia Driver=6.14.11.9745
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Realtek AC'97 Audio
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=0
Voiceover Volume=100
Sound Effects Volume=85
Movie Volume=100
Force Software=0
EAX=2
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1
Environment Effects Nonstreaming=1
Environment Effects Streaming=1

[Game Options]
GUIsInScreenShot=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=0
Subtitles=1
Mini Map=1
Floating Numbers=0
Status Summary=0
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=0
Difficulty Level=0
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1
Disable Movies=0
Disable Vertex Buffer Objects=1

[Movies Shown]
Movie 0=112
Movie 1=0
Movie 2=0
Movie 3=0
Movie 4=0
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
RefreshRate=60
Width=800
Height=600

[Autopause Options]
Mine Sighted=0
End Of Combat Round=0
Enemy Sighted=1
Party Killed=0
Action Menu=0
New Target Selected=1

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action265=52
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=62
Action213=60
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

Q
06-13-2010, 01:09 AM
Give the Dantooine lag fix a try:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.

dewayne26
06-13-2010, 04:32 AM
thank you that seems to of fixed it ran character thru the endar spire with no problem. loaded up a character further along and play for 4hrs straight so i hope that fixed it

Q
06-13-2010, 04:41 PM
Great. Glad you got it working. :)

Looks like the Dantooine lag fix is now required for Nvidia DX9 hardware as well. That means that it's necessary across the board, and that every installation of the game will need it.