PDA

View Full Version : Windows 7 Intel Video Driver Conflict


Draeon
06-10-2010, 02:00 PM
1: I am running an Intel 45 Chipset Family on a Dell Inspiron laptop
Except for the video card being in the yellow on the diagnostics, the only issue I have is with the opengl drivers bullcrap
This is for KoTOR I

I've gone all over the place, searched high and low on both the internet and my computer and I can find no way to change the blit settings or whatever to get my game to play.

There seem to be no suggestions for W7 Ultimate fixes to play KoTOR.
I already have it running in compatability mode so it opens up and plays the music and runs fine, I just need it to get with the graphics

Any and all help that leads to the proper function of the game is needed and greatly appreciated
And thank you in advanced

Q
06-10-2010, 10:13 PM
It's called the flipping policy. My laptop has an older chipset so I can't check it out personally, but from what I've read on the web this setting is still adjustable in the driver control panel for the newer GMA 4500M. You're just going to have to dig for it.

What version of Windows are you using?

Draeon
06-10-2010, 10:19 PM
I'm running Windows 7 Ultimate so the navigation to the drivers is different that XP and Vista
I can get into the display settings but I can't seem to find where I'm suppposed to change the settings to make the game playable

Q
06-10-2010, 10:33 PM
How to open the graphics properties window (http://www.intel.com/support/graphics/sb/CS-022130.htm)

OpenGL settings guide (http://www.intel.com/support/graphics/sb/CS-030506.htm)

Draeon
06-10-2010, 10:43 PM
I can't do any of that
My f12 key depends on the FN key on my laptop and it won't activate with Ctrl+alt at the same time
And I can't switch my control panel to classic view
Intel directions are fail :(

Q
06-10-2010, 10:50 PM
Start/Control Panel/Appearance and Personalization/Adjust Screen Resolution (under "Display")/Advanced Settings

There should be an Intel tab there to select and then you can open the control panel from there.

Draeon
06-10-2010, 10:54 PM
That's the menu I scoured earlier, there's no Intel tab
I have:
Adapter
Monitor
Troubleshoot
Color Management

I've clicked every button in there trying to find this and it doesn't seem to be anywhere
Am I missing something?
If so what is it and where can I find it?

Q
06-10-2010, 10:56 PM
I think that I know the solution to this. Go to the Intel website, download the newest drivers for your chipset, and install them. The options that are missing should then become available.

Draeon
06-10-2010, 10:58 PM
I've already checked updating my drivers
I have the most recent ones :/
That was the first thing I did
:(

Q
06-10-2010, 11:00 PM
Do it anyway. I suspect that the drivers that are on your laptop shipped with it and are missing those options. You may have to uninstall the old ones first.

Draeon
06-10-2010, 11:03 PM
Ahhhh!
A valid suspicion I'm sure...
Trying this now
Thanks for all the help by the way

Edit: Ok, I have the intel tab now and I opened the preferences, but I'm still not seeing the option to change the blit thing.
:/

Edit 2: Nevermind, updating the drivers in this fashion has solved the problem.
Evidently the newest drivers installed this way autdetect and run the game properly

Thank you so much for your assistance, now I can enjoy my game once more

:)

Q
06-10-2010, 11:52 PM
Are you getting the driver control panel to come up?

EDIT: Great! Glad you got it working. You're welcome, and enjoy your game. :)