PDA

View Full Version : TSL Install Failure?


TriggerGod
06-13-2010, 11:59 PM
Ok, I don't get this, but I'm sure it has something to do with my system specs. The other day I tried to reinstall TSL, but it failed somehow, despite finishing the installation successfully, or so I thought. My installation would go seamlessly until I have to insert Disk 2. When I do, and I click the OK button, my Logitech G-Series Key Profiler (a program that came with my keyboard I got for Christmas) comes up with an error that tells me to insert my disk one, and when I did, it came up with another error (either from the Profiler or the actual installation software, can't remember) saying that without the proper disk, the installation would fail. So I had to uninstall the components that had been installed, and I reinstalled it yet again, this time ignoring my Profiler. The little status bar at the bottom gets to the end and I believe my installation has finished, and I decide to play a different game for the rest of the night. The next day (which happens to be today) I decide to see how badly the GUI looks without the widescreen hack (as I have a great 16:9 aspect ratio now), and it turns out that my installation didn't work correctly.

Now, like I said, it may be a cause of my specs, or it may be caused by my Key Profiler somehow. Just in case, here is my system specs, as narrated by Steam.

Processor Information:
Vendor: GenuineIntel
Speed: 2731 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Windows 7 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 323 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 260
DirectX Driver Name: nvd3dum.dll
Driver Version: 8.17.11.9745
DirectX Driver Version: 8.17.11.9745
Driver Date: 3 Apr 2010
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: NVIDIA GeForce GTX 260
VendorID: 0x10de
DeviceID: 0x5e2
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 26.65" x 15.00" (30.55" diag)
67.7cm x 38.1cm (77.6cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 896 MB
Supported MSAA Modes: 2x 4x 8x


Sound card:
Audio device: Speakers (High Definition Audio

Memory:
RAM: 4086 Mb

Miscellaneous:
UI Language: English
Microphone: Not set
Media Type: DVD
Total Hard Disk Space Available: 953762 Mb
Largest Free Hard Disk Block: 178605 Mb
Steam Hard Disk Usage: 53491 Mb
OS Install Date: Oct 21 2009
Game Controller: None detected
Installed Packages: Firefox,Windows Firewall

Q
06-14-2010, 02:50 AM
Let's see how the game itself is reacting to your particular setup:
Post your system specs
Sometimes we're just not going to be able to help you if we don't know what kind of hardware you have on your machine. If you don't know what you have on your machine, then follow these steps below:
Bring up the launcher menu for Kotor 1 or 2.
Click on "Configure".
Click the "Scan Hardware" button on the lower center of the window.
Click "Yes" to continue.
Click "Details" to view your system specs.
Click "Save Report" and save the file to your desktop.
Whenever you post your problem, open the file you just saved and copy and paste the contents to your post.
I suspect that the Logitech software is interfering with the game's installation. You might have to temporarily uninstall it in order for game to install correctly.

TriggerGod
06-14-2010, 12:23 PM
Let's see how the game itself is reacting to your particular setup:

I suspect that the Logitech software is interfering with the game's installation. You might have to temporarily uninstall it in order for game to install correctly.

I just attempted to scan my hardware (the launcher wouldn't launch, so I just used the swconfig.exe file and clicked the scan hardware) and apparently, my video card doesn't meet the requirements and that I need to download a driver. I'll attempt to install it later on, but I'm certain that is not whats causing my install failure.

Yeah, thats what I assumed. I'll try to install it later without the profiler.

EDIT: Here is what SWConfig said about my system:
[SWKotOR]
ReportDateTime=6/14/2010 11:35:08 AM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=D:\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=4
CPUSpeed=2731
CPUFamily=6
CPUModel=14
CPUStepping=5
CPUVendor=Intel
CPUName=Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz
Status=Pass

[Memory]
RAM=4088
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=42.36GB
D: (NTFS), UNICODE=46.82GB
E: (NTFS), UNICODE=97.46GB
G: (NTFS), UNICODE=95.75GB
H: (NTFS), UNICODE=174.42GB
I: (NTFS), UNICODE=137.14GB
Status=Pass

[CD-ROMs]
DriveLetters=F:\
Drives=ATAPI iHAS324 A ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=4096
Desktop Resolution=0x0x0
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.2.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce GTX 260/PCI/SSE2
NVidia Driver=(null)
Vid Card Status=Warning
Vid Card Driver Status=Fail
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (High Definition Audio Device)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0

[Game Options]

[config]
firstrun=0

EDIT 2: Well, it appears its just my launcher doing that. I decided to try to load it again (I hadn't uninstalled it or anything) by using the launcher executable (failed), but when I tried launching the game directly, it works. Wunderbar.

Q
06-14-2010, 11:17 PM
It says that your video card doesn't meet the requirements because TSL is so old that it has no clue what a GTX 260 is. Your video card is fine, but if your drivers aren't up to date you can go ahead and update them. I would temporarily uninstall that Logitech software, and then uninstall TSL. Delete any leftover files and folders, run CCleaner's registry cleaner, empty the recycle bin and reboot. Then reinstall TSL according to the large-print instructions at the top of the second post of this thread (http://www.lucasforums.com/showthread.php?t=194324). Follow those instructions to the letter and you should be OK.