PDA

View Full Version : Game Breaking Problem!


Illy-chan
06-20-2010, 03:06 AM
Yeah, I'm not sure if it's a mod that's doing this or not but it wasn't an issue before. I've added a few mods since the last time I did this fight.

In the final fight against Bastila on the Star Forge, instead of ending when her HP gets low, it looks like she just stays at 1 HP or whatever and the fight goes on indefinitely.

I don't know what on earth I could have done to cause this but maybe it sounds familiar to someone out there.

Rtas Vadum
06-20-2010, 03:15 AM
So you mean that, rather than the fight ending when you either persuade her to help you, or when your forced to kill her, all of your attacks hit, but her hp count never drops below 1, right?

It likely is that way because of a script, at least until the situation demands that you kill her. I'd check over your override, to see if you have any utc files that specifically mention Bastila. You might also want to try loading a save from before the fight, and try it again.

Illy-chan
06-20-2010, 03:50 AM
I tried going to private saves but yeah, still didn't work. I don't suppose the restored dialogue pack has ever caused something like this?

UPDATE: I just tried deleting files that mentioned her but we're still locked in infinite combat. :(

Illy-chan
06-20-2010, 09:25 AM
Another note: Through further testing, I found it is actually impossible for me to pick the dark side ending in the game. I can't initiate the fight between Juhani or Jolee which means I can't turn off that field so I can't leave the temple.

Yeah, I don't know what I did but, whatever it was, I really broke the game...

Seikan
06-20-2010, 11:37 AM
Well, delete your override, and that sould be fine, just remember that once you enter on a module any file put or delete on the override won't change anything, so for the modifications having any effect in the game you have to load a savegame before entering to the module where you did any change for the first time.

Illy-chan
06-20-2010, 11:46 AM
Oh yeah, forgot about that. I'm so used to other games where mod content essentially disappears if you remove the mod. :(

What a time for me to learn my game is broken. I wouldn't be so annoyed if I knew hat exactly did this. The only thing I could think of that could possibly do this is Allronix's Dialogue mod but, since I've never seen an issue with it before, I'm fairly skeptical of even that theory.

Maybe I mucked with something and forgot. Guess there's not much else to do but get rid of everything in my override... :(

Seikan
06-20-2010, 12:57 PM
get rid of the dialog pack fisrt, and then look if it works, the item files, models etc, cant't be responsible. the possible problems might be from or dlg files, or utc files

Qui-Gon Glenn
06-21-2010, 01:01 AM
^^^ Yes

There are many issues on the Star Forge when it comes to mods balking. Specifically issues with Bastila's .dlg tree.

Look for any files in your override that have p_bast or bast or bastila... both with the .dlg and .utc file suffix. Create a new folder on your desktop and name it Bugger (sounds innocent enough ;) ) and drag all those bast files to the the Bugger.

Load your save and tell us what happens!

Illy-chan
06-21-2010, 01:51 PM
lol, I will when I get that far. I've had the dialogue pack since I started that particular game so yeah...

I'll try removing her dialogue, which is a shame because the extra stuff is interesting.

KOTOR is fun but it's one of the touchiest games I've ever played (except for maybe Fable II which was a nightmare for me).

Seikan
06-21-2010, 01:56 PM
well the game is already fine without mods, the biggest problem with a raw kotor are the weapons, masks, armors, which are really a shame, but for the dialogs, plot, etc, it's not a huge problem (unlike TSL and his cut content almost as big as the rest of the game)

Illy-chan
06-21-2010, 08:03 PM
I guess, I suppose my curiosity got the best of me. They could have paid more attention to other aspects though. Like that piece of fiberglass Revan wears that they call a cape.

Rtas Vadum
06-21-2010, 08:54 PM
I guess, I suppose my curiosity got the best of me. They could have paid more attention to other aspects though. Like that piece of fiberglass Revan wears that they call a cape.

Well, the reason the cape isn't animated isn't an oversight, or a sign that BioWare was rushed. It's because they never intended the player to wear the armor in combat, much less use it at all. It was only meant to be worn by the player character during the "Revalation" sequence, and thus it wasn't given any animations that it didn't need. And when they chose to let the player use the armor, they stripped it of the belt, cape, and hood, making it so they didn't need to animate them. Even Obsidian didn't need to animate the cape, as the masked model is only used in the vanilla game, and that one doesn't clip as much as the Male or Female Revan model.

Illy-chan
06-22-2010, 12:50 PM
Ah, I always wondered about that. Still, if it were me, I would have done it. Of course, I'm decidedly strange and (if it wasn't obvious) extremely pro-modding. ^_^;;

Anyway, I'll update next when I find out if that dialogue thing was, indeed, the source of my problems.

Seikan
06-22-2010, 01:20 PM
Well there is a mod for a revan's flowing cape, for both, TSL and K1 :o