PDA

View Full Version : Telos Polar Academy Problem


bemtoto
06-21-2010, 01:09 AM
I cleaned out some things from my override folder that I thought were added in by a mod I installed and was removing and when I went to play the game afterwords the Handmaiden Sisters in the academy no longer had a graphic at all but could be targeted via the next target keys. If I talked to them it would crash the game and send me to my desktop, next trying to fix this doing some diagnostics to see if it was one of my mods, I emptied my override folder completely to make it back to the default game, game worked normally except that the Handmaiden Sisters still had no graphic and could no longer be targeted.

I was wondering if anyone could search through their override folders and see if there are any files related to the sisters and if so could be zipped up possibly for uploading to download to fix this issue?

Qui-Gon Glenn
06-21-2010, 01:26 AM
This probably belongs in Georg Nihilus' TUCE thread... unless you are not talking about his mod!?!

Do you have an earlier save? Your savegame is confusing your game engine because it expects things to be in your override that are no longer there. If you have a save from before entering the Academy, you should be able to use that and see the sisters. If not, give us more information if you can about exactly what mods you had installed besides the Telos Polar Academy mod (if that one is one you had installed). Also, which files did you delete? Look in the old recycle bin, unless you are an electro-neatfreak :p

bemtoto
06-21-2010, 01:42 AM
No idea what that mod is, from further testing the only thing that seems to be affecting this issue is the appearance.2da file, invisible targetable sisters while its in folder, and completely gone when its not in folder.

Only mods I am using are the T.W.O Weapons overhaul mods for blasters/rifles/heavy rifles, shem's realistic visuals, TSL Restored Content 1.5 and had used various character model reskins on top of Xarwarz's area reskins (though not using any of his polar academy graphics)

And yes I've tried an earlier save reached up to the same point and its the same issue. Unfortunately I had already emptied my recycle bin :(

Qui-Gon Glenn
06-21-2010, 01:54 AM
Ok... well, you have helped me with that info!

I think you are on the right track with app.2da.... which may be a difficult file to "restore" properly for you.

Search through the TSLPatchdata folders of T.W.O. and Shem's/Xarwarz' mods, and compare their appearance.2da files...

My gut tells me that it was something from TSLRCM that you deleted that is causing your issue, but I could not tell you what file as that mod uses its own installer and not the TSLPatcher - therefore, no patchdata folder to look through.

You could contact DStoney and he would probably send you the appearance.2da from the mod, which may be what you need.

bemtoto
06-21-2010, 02:22 AM
Also unfortunately hadn't used any patchers just manual installations. Been looking through the forums here and on kotorfiles having some difficulty finding a tool to be able to edit a .2da file so i could try to fix the issue without having to redownload/install everything (already got rid of the downloaded compressed files; and the xarwarz one in particular had to get via bittorrent since links were dead)

It had all worked properly though until today, only mod i installed today was shem's realistic visual effects mod but i was able to drag and drop the visualeffects.2da file from the download straight into the override folder without being prompted about overriding a file that already exists so that leaves me to believe i indeed did delete some file from my override folder that was needed. I remember seeing something about handmaiden sisters in there that i removed thinking it was a reskin of those models

*edit* having since found a tool for reading the .2da files, the only thing in the appearance.2da that i see referencing to the sisters are lines 672 and 673 for normal and corrupted sisters and it seems to be pointing to model P_HandsisterBB and P_HandsisterBD which i do not have in my override folder also seems to point at a N_CommM which i do have .mdl and .mdx of in my override folder already. Also seems kinda odd to me that in the texbevil column for Handmaiden_Sister it points at P_HandmaidenAD but i really dont want to touch any of that as of yet as don't know what i'm doing if i were to modify a 2da file atm

*edit again* no luck getting it to work changing the sisters models to be exactly like handmaiden since she shows up in the academy, i do find this very very odd as they do show up prior to entering the academy after you've dispatched the 3 HK driods and Bao-Dur is knocked out near the shuttle crash, that little cut scene they show up fine in its just inside the academy itself that they are invisible and are causing game crashes should you try to talk to them

Seikan
06-21-2010, 01:23 PM
Well, any bug caused by a mod, can be solve deleting everything you have added, so if after deleting ANY file of your override it still don't work, then it's your game that have a problem, and not the mods. (it's true as long as your savegame is before entering the module with the files.)

Qui-Gon Glenn
06-21-2010, 09:23 PM
Simply editing the .2da's by merging them is not going to be sufficient to guarantee compatibility. Mod scripts can sometimes call on specific rows in a .2da and expect that row to be x. If you manually merge the .2da's, that will ensure that all the .2da data is there, but not that the mod will actually be able to find it!

Yeah, I know, yuck.

That's why stoffe came to the rescue with the patcher. I have given this advice several times before on these forums, and I still think it is good advice...

10 STEPS TO BEST INSTALL MODS FOR KOTOR AND TSL
-------------------------------------------------
1. Start FRESH! New install, no old problems.

2. Make a folder for archiving all the mods that you might want to play.

3. Read the ReadMe's. They will often warn you of mod conflicts. It says ReadMe. :rolleyes:

4. Consider which mods will work together... Don't choose to try and play two storyline mods at the same time, as the scripting will conflict all over the place, which the patcher or home modder cannot fix without great DIY pains. IE: Don't expect Trex' TJM to work with TSLCRM.

5. After getting the storyline mod you want, and all the special trinkets (skins, weapons, armors, gui stuff, ya know - Eye candy :) ) separate the lot into mods that use the patcher, and mods that don't.

6. You must install your non-patcher mods first, and you must compare the contents of those old school mods first to find file conflicts prior to installation. Look for conflicting .2da's and scripts that use the same name.

7. If you have conflictions between the non-patcher mods, you must either make the tough decision to cut one of them from this round of play, or take the time to merge them, carefully. K-Tool is all you need for .2da editing/merging.

8. Now begin to install the TSLPatcher enabled mods, after reading the ReadMe. Start with the largest mod first (a storyline mod, usually).

9. Repeat #8 until all the patcher mods you want are in there.

10. Play, and hopefully everything will work!

This is not a guaranteed solution to mod compatibility. I have found, over time, that it is not only the most logical way to go about it, but also the most successful. The worst thing that will happen to my games, occasionally, is a PC/NPC appearing to wear their base clothing when they are actually clad in modded armor.

I hope this is helpful!

SkyWoulf
01-16-2011, 02:57 PM
i have also found that : appearence.d2a, heads.d2a, and portraits.d2a need to be only one instance in your override folder. if you have two appearence.d2a's, game/mods will not know which one to use.

personally i look at any d2a that comes with a mod and compare it to the one in my override with the kotor tool (you can open multiple d2a files for comparison) then make any changes by hand (copy & paste) to the one in my override.

if your mod comes with an installer instead of just files, cut the contents of your override to a "over ride" folder in the games backup folder. install mod (auto to override) then copy that to a working folder (on desktop perhaps) re cut & paste from "over ride" to override (restore content). open your working folder, compare files, edit override's d2a, and dump any new files d2a's tga's dlg's etc into override. do not over write any d2a's you already have in there!

Davlen
07-31-2011, 12:18 AM
I enter the Polar Academy the Handmaidens come to see me, they take my weapons, it fades to black and then just sits there... I am running a few mods, but nothing that should affect that place at all....

Q
07-31-2011, 04:44 AM
Which dialog option are you choosing when the Handmaiden tells you to surrender your weapons?

Davlen
07-31-2011, 10:45 AM
I have tried every combination possible...

VeganHipster
07-31-2011, 03:14 PM
I enter the Polar Academy the Handmaidens come to see me, they take my weapons, it fades to black and then just sits there... I am running a few mods, but nothing that should affect that place at all....

What mods do you have installed right now? Have you installed these mods on a fresh install of KOTOR II or did you just delete your override folder from your last play through?

Davlen
07-31-2011, 06:58 PM
It was a fresh playthrough...

Feats every lvl
90s mod
Ebon Hawk Cargo Mod
rebuild jedi
Dantooine Restoration project
and one for racing..

Q
08-04-2011, 09:04 PM
OK, at first this appeared to be the bug that is caused by the patch, but that is limited to the first dialog choice, and you said that you tried them all, which is why I'm stumped.

Sgt. Strike
08-07-2011, 01:17 AM
What I have done, personally, after I installed the game. I then patched it. I have one launcher skin I like. I then copy the whole game directory to another place on my hard drive. Well, now that I have an external 1 terabyte drive, I copied it there. This way, nothing is totally gone when I screw up on adding a mod, or something doesn't work right, and I need to start from scratch, and it does save time in reinstalling the game, and adding the patch, etc.

Q
08-07-2011, 02:02 AM
^I do very much the same thing, only I then delete the game folders of the games that I'm not presently playing to conserve space on my SSD. When I want to play a particular game, I just copy its folder back to the SSD.