View Full Version : Need Help With Installing/Running Star Wars Rogue Squadron 3D On Windows 7-64-Bit

06-23-2010, 10:28 PM
Hello, everyone. I know this game is RRREEEAAALLLYYY old, but I can remember playing it way back in the late 1990s on my Nintendo 64, and I just wanted to bring back some of the nostalgia.

I downloaded the game and a Nintendo 64 emulator, but for some reason or another, the graphics are totally screwed and completely unplayable. So I obtained the PC version of the game from a friend, and installed it on my Windows 7-32-bit netbook, which has a 10 inch screen. On that machine, the game runs perfectly, except the display is tiny and the keyboard is small, so it's kind of hard to control the aircrafts and see what I'm doing. I have tried connecting the netbook to my TV, which helps make the display bigger, but I would much rather be able to play it on my ASUS gaming laptop, because I'm always on the go and want to take my games with me.

The primary problem is that when I run setup.exe, it displays an error saying that the setup file is incompatible with 64-bit operating systems. I have also tried installing the game to my netbook and then copying the files and Registry entries to my ASUS laptop, but it always gives me an error saying that I need to reinstall the game, or CD not found. The install directory I'm using is the default C:\Program Files\LucasArts\ROGUE\. And I have also tried creating a disc image and mounting it in programs such as DAEMON Tools and MagicDisc, but it always gives me the same errors. At one point in time I actually had the game running on the ASUS, but the primary problems I had were that the camera would always get too far away from my craft, which would result in me being unable to control the craft. Switching camera modes would solve the problem momentarily, but then it would go right back to me being unable to see anything but a tiny aircraft. On the netbook, I dont have any of these problems.

So I searched these forums and found a post stating that I should try using a program called D3D Windower, which in essence forces the game to run in a window. That fixed the camera problem, but just when I thought I had everything working properly, I noticed that when running the game in windowed mode with this program, I was unable to create new pilots or enter cheat codes because it wouldn't allow me to type text into the appropriate areas.

Another problem I had is that when running the game under this program, it also wouldn't allow me to use my Logitech gamepad to control the game or configure the joypad settings. But then again, it wouldnt let me do that when running the game on the ASUS even when running in fullscreen mode without D3D Windower. I am able to use the controller with the game on my netbook, but not on the ASUS. And another thing is that when I run Rogue.exe on the netbook, a "Play" button appears, along with buttons that let me configure the graphics settings and joypad settings. But when I run Rogue.exe on the ASUS it instead says "Install" and doesnt display anything that will let me configure the graphics or joypad settings.

So what do I have to alter on the ASUS so that the menu says "Play" rather than "Install" on the Rogue.exe menu? I also need a no-cd crack for this game, because of the errors listed above, which also doesnt disable the Naboo Starfighter patch. It seems that I cant get the game to run on the ASUS with either the real disc in the drive or with a mounted disc image, hence the reason why I need a no-cd crack. I have tried several, and one worked. Another problem I am having right now is that my screen goes black after the intros, and I have tried copying the bundle.000 and bundle.001 files into the Data directory. This worked on the netbook, and at one time on the ASUS, but not now.

So if anyone here has successfully installed the game on Windows 64 bit, I would really appreciate your help. I have been trying to get this game to run on my ASUS for like 8 months now with little progress, so please help a guy out! As it turns out though, the real problem for me is not being able to INSTALL the game on my ASUS,I can run it OK, except with graphical glitches. But now I just cant seem to get the game to install/run on this machine. One moment it works and , and the next day it refuses to work after placing it back on the machine, primarily because something on my system gets screwed up, and I cant figure out what the problem is.

And by the way, my system specs are Windows 7 Ultimate 64 bit, Intel Core 2 Duo processor, 6 gigabytes of RAM/memory and a NVIDIA GeForce GTX 260M CUDA graphics card with 1 gigabyte of dedicated graphics RAM/memory.


06-24-2010, 06:17 PM
ok i posted this up yesterday and noticed that there are like 50something views but no replies, so either noone knows how to help or they dont want to help. I've given all the details I can so that's the best I can do. If anyone can help me in any way at all or think they might know something which can solve my problems, then PLEASE reply. Even if your advice doesnt work, it's still worth a try. It would be much appreciated....................................... ...

07-22-2010, 11:59 AM
I have the same problem with my logitech control, appears in the configuration of control devices to run the game but I can not configure it if someone can help me and they would appreciate.

in response to your comment I recommend you use a program called 3D analyzer q, helps with the graphics and sound configuration. q I hope is helpful.

01-06-2011, 07:41 PM
I've been looking for quite some time to find a bypass for that 16-bit installer, because I just got a new laptop running Win7 64-bit, and I really want to play Rogue Squadron on it after ordering the game from Amazon. At first I tried just using a virtual machine like VirtualBox to install Windows XP on, but then I found out that they can't emulate video cards. VirtualBox does have an option to route through your graphics card, but I couldn't get it to work after spending a few hours on it. Same with the Windows 7 XP mode. It is meant more for business applications as opposed to gaming. Another option was to dual boot windows 98 or XP, but I haven't tried that yet. Anyways, I finally found someone who did a workaround to the installer, and I am in the process of trying it. I just found the site, so I don't know if its legit or if it works (though it certainly looks good). I'm going to work through it and then let you all know the outcome. Here's the URL:
By the way, this is my first post here, but I've been perusing the site for awhile, and definitely like the concept =)

12-31-2014, 10:17 AM
Try this link here http://pcgamingwiki.com/wiki/Star_Wars:_Rogue_Squadron_3D it worked for my Windows 7 and windows 8.1 64 bit laptops using Deamon tools. Just edit the registry entry for whatever drive Deamon tools uses. On my laptops its drive G, also run the game in 98 Windows me compatibility mode so you can create a pilot and for the controller to work, while your in the main menu it will run slowly but the actual game runs smooth.