PDA

View Full Version : Game temporarily freezes repeatedly after a few minutes of play


PugPug
07-06-2010, 11:56 PM
I'm playing KOTOR 1. After a few minutes of play, the game will freeze. I can input actions on the mouse and keyboard and nothing will happen, then about 30 seconds later it will respond. Then it will freeze again, and the cycle continues.

Interestingly the system requirements tool that came with KOTOR flags my video card as yellow -- not quite fast enough. Which is of course absurd. Everything else is green.

The game is patched and all of my drivers are up to date. I checked. Even my BIOS.

I tried setting affinity so the game was only running on 1 core. It didn't solve the problem. I also set the refresh rate in the .ini file to match my refresh rate in windows settings, since I heard that can be a problem with LCD monitors in this game.

Special thanks to PC Wizard so I didn't have to type out the specs:

Operating System: Microsoft Windows XP Home Edition 5.01.2600 Service Pack 3
<<< System Summary >>>
> Mainboard : Asus P5NSLI
> Chipset : nVidia nForce4 SLI Intel Edition
> Processor : Intel Core 2 Duo E8500 @ 3166 MHz
> Physical Memory : 4096 MB (4 x 1024 DDR2-SDRAM )
> Video Card : NVIDIA GeForce GTS 250
> Hard Disk : ST3200820AS (200 GB)
> DVD-Rom Drive : LITE-ON DVDRW LH-18A1P
> Monitor Type : Samsung SyncMaster - 17 inches
> Network Card : MV88SE614x PCIe to SATA2 controller Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller (Copper)
> Operating System : Microsoft Windows XP Home Edition 5.01.2600 Service Pack 3
> DirectX : Version 9.0c (May 2010)

Q
07-07-2010, 08:06 AM
There are two things that you're going to need to do. First, there's the Dantooine lag fix:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.
Second, you're going to need to set CPU affinity to a single core every time you launch the game. Before launching the game, open Task Manager and select the "Processes" tab. Launch the game, wait for the main menu to come up, then hit the Windows key. Look for "swkotor.exe" in the Task Manager, right-click on it, select "Set Affinity...", deselect every core but CPU 0 and hit "OK". Then hit the game's icon in the taskbar and play as normal. I'll repeat that you'll have to set CPU affinity like this every time you launch the game.

PugPug
07-07-2010, 10:21 AM
I'm sorry, I forgot to mention it's the Steam version, which has the Dantooine fix enabled by default.

And yeah, I know about the affinity every time thing. I've been doing it every time I try a new fix. I've heard there are programs that do it automatically for you with a specific game, but I haven't downloaded one.

Thanks though!

Q
07-07-2010, 11:19 AM
Wait a minute:

You set the refresh rate manually in the .ini file? What did you set it to?

PugPug
07-07-2010, 12:30 PM
Well, the problem appeared before I did that. Some fixit guide suggested I do it. I checked in windows, and my desktop is set at 60 hertz. 1280 x 1024 is even my monitor's native resolution.

I have tried running the game with everything off, but still have the same problem.

[Graphics Options]
RefreshRate=60
Height=1024
Width=1280
V-Sync=0
Anisotropy=16
Frame Buffer=1
Anti Aliasing=8
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
Disable Vertex Buffer Objects=1