PDA

View Full Version : Nar Shaddaa Custom Skybox Problem


e-varmint
08-12-2010, 02:42 PM
OK, I opened up the skybox model for the Docks, and re-mapped it so that it would accept another texture without ugly seams. I've been able to alter, and even switch, skyboxes for other modules without issue, but this one has me stumped. No matter what I do, I get nothing but a gray background. I turned off the SunFog in the .are file and repacked the module as a .mod. No success. I also tried substituting another 4-segment skybox. Didn't work.

Does anyone know how to fix this?

newbiemodder
08-12-2010, 03:57 PM
Quesiton: Did you hex edit the model and put your new sky tetures in or did you open it in gmax/3ds and apply new textures to model?

Also what is the specific .mdl file for the skybox?

e-varmint
08-12-2010, 04:03 PM
I had to open it in GMAX and re-map the actual skybox. The original mapping leaves seams when you use another texture (Telos plateau, for example). I selected the skybox, then clicked on the "Editable Mesh" and added a UVMAP modifier. I then had to select the "Y" axis and "Fit". I did not add the unwrap UVW modifier.

newbiemodder
08-12-2010, 04:10 PM
That's it then. Whenever I've tried to change an existing room model with gmax and put it in override that is what usually happens. The area will be gray or invisible until I walk into it. Don't think you can do that.

Someone might know more, but I think your best bet would to hex edit the mdl and put it into override.

e-varmint
08-12-2010, 08:35 PM
HAH! I figured it out!

*dramatic pause*

The secret is Taina's Replacer:

http://www.lucasforums.com/showpost.php?p=2656073&postcount=22

Screenie of 303nar:
http://i714.photobucket.com/albums/ww150/ajkfjaioIIl9Wkk/303nar.jpg

Procedure:

1) Followed Taina's instructions

2) When I had the model (303narb) open in GMAX, I converted the "sky" object to editable mesh/re-applied the Aurora Trimesh modifier AFTER I uvmapped. It had no texture when I imported it, so I had to create a new one.

I don't really know how critical the trimesh modifier is, but I decided to be safe and put it back EXACTLY the way I found it after re-mapping.

It reverted back to the original texture, so I had to replace nar_sky1.tga with the texture I wanted from Telos. The mapping seems to have transferred, though.