PDA

View Full Version : .uti Error


_Starfall_
08-23-2010, 02:33 AM
Well, I have a Kotor Tool but it has 2 problems. One is it cannot read the .bif files and gives an unhandled exception error but I use the KotOR Resource Extractor instead. But the other problem is really annoying. It does not open .uti files and gives an error: 'Index was outside of the bounds of array' or something like that. It opens some .uti files and in them it does not allow me to add most of the properties and pops up an error: Property cannot be null. I also get this kind of error when starting Kotor Tool: Path cannot be null. So I think that the problem is caused by properties. I can edit them with K-GFF however that takes a long time because I need to look up every property 2da.

Anyone has a fix? Thanks by now.

reivzje
09-04-2010, 08:16 AM
What are you using XP, Vista, Win 7 ? If Vista or Win 7 try to run Kotor Toll as a administrator.

R2-X2
10-27-2010, 11:52 AM
I'm getting the same error since yesterday afternoon. Is there a way to get KT back working?

Qui-Gon Glenn
10-27-2010, 06:17 PM
Yes, try uninstalling and reinstalling KT. Many times, KT gets lost in paths, or perhaps you move something... long story short, uninstalling, reinstalling and repathing occasionally helps KT keep chugging along. If you installed your game in a compatibility mode, you should install your KT the same way. You should also make sure that you have all of the OLD .NET frameworks installed, all the way back from 1.0. KT depends on those libraries, without them it is a broken tool. Simply installing the most recent .NET framework will not accomplish this for you.

_Starfall_
10-29-2010, 06:10 AM
I will try to Install KT as administrator. Maybe It ll work.

Edit: No, it still gives the same error. Its something about Microsoft .NET Framework maybe, but I have all versions thats required to work the tool.

I have 1.055, 1.0.3705, 1.1.4322, 2.0.50727, 3.0 and 3.5 versions of .NET Framework installed.

So, what should I do?