PDA

View Full Version : kotor2 troubles


Navrez
09-29-2010, 05:55 PM
hey all i bought KOTOR 2 yesterday and i installed this game and can not play it , i get an error that the game needs to be closed i patched the game with te latest patches i also have the latest drivers installed of my video card . im using xp 32 with a ati radeon hd 4870 graphics card. i didnt had any troubles with KOTOR 1
pls help thx in advance

Qui-Gon Glenn
09-29-2010, 05:59 PM
There is only one latest patch (and it is old now), the official one from Lucasarts/Obsidian, which you can download from KotorFiles.

Did you use the Dantooine Lag Fix? Disable Vertex Buf.......

Navrez
09-29-2010, 06:06 PM
cant find the swkotor2.ini file where is it

Qui-Gon Glenn
09-29-2010, 07:28 PM
cant find the swkotor2.ini file where is it
It should be in your game directory... the default is c:\<yourname>\Program Files\Lucasarts\SWKOTOR2.

You can also try to search for the file directly... use the windows search and enter swkotor2.ini and see what comes up. If it is not there, and you really are using windows xp, then I would say your computer has issues.

Hope this helps!

Navrez
09-30-2010, 11:08 AM
yup i found it and changed it and still the game doesnt work any other ideas

Q
09-30-2010, 08:12 PM
Here's the instructions for the fix, just to make sure that you did it properly:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.

Navrez
09-30-2010, 11:50 PM
nope still wont work

Q
10-01-2010, 12:13 AM
If you have a multi-core CPU, you're going to have set affinity to a single CPU core every time you launch the game. How I do it is to open Task Manager (right-click on the Taskbar at the bottom of Windows' desktop and select "Task Manager") and click on the "Processes" tab. Check the "Show processes for all users" box if it isn't already and then launch the game. Once you get to the game's main menu, hit the Windows key to get back to the desktop and look for the game's executable (swkotor2.exe) in the Task Manager under the "Processes" tab. When you find it, right click on it, select "set affinity" and uncheck every box but "CPU 0". In your case that would mean unchecking "CPU1", but for a multicore CPU, there would be more cores to deselect. Once you've done that, just hit the game's icon in the Taskbar and you should be good to go. Remember that you'll have to set CPU affinity like this every time you launch the game.

Beyond that, it's probably an ATI problem.

Navrez
10-05-2010, 03:57 PM
If you have a multi-core CPU, you're going to have set affinity to a single CPU core every time you launch the game. How I do it is to open Task Manager (right-click on the Taskbar at the bottom of Windows' desktop and select "Task Manager") and click on the "Processes" tab. Check the "Show processes for all users" box if it isn't already and then launch the game. Once you get to the game's main menu, hit the Windows key to get back to the desktop and look for the game's executable (swkotor2.exe) in the Task Manager under the "Processes" tab. When you find it, right click on it, select "set affinity" and uncheck every box but "CPU 0". In your case that would mean unchecking "CPU1", but for a multicore CPU, there would be more cores to deselect. Once you've done that, just hit the game's icon in the Taskbar and you should be good to go. Remember that you'll have to set CPU affinity like this every time you launch the game.

Beyond that, it's probably an ATI problem.

that all doesnt work it must be an ATI driver problem who can help me with this

Navrez
10-08-2010, 10:00 AM
any help im dying to play this game , what boggles me is that i didnt had troubles with KOTOR 1