PDA

View Full Version : I'm sea sick! ( TSL,camera issues)


Kas_Lasak
09-29-2010, 08:01 PM
Hello folks.
I very recently installed Kotor II alongside with a small number of mods that looked " must have" to me. Everything seems to be working fine, with one notable exception.

I intend to use minimal amount of WASD when moving my char around and handle all the basics with mouse instead. For some strange reason, every single time I use mouse to steer my character, the camera does this brief, automatic, completely unavoidable tiny back and forth tilt upwards. I'd love to get rid of it. This feels so nauseating that I'm sure it isn't a stock function, but rather some odd bug, mod not working properly or whatnot. Is this a common problem? Any suggestions how to fix it?

I hope I was able to explain my issue properly:p I'd like to underline this has nothing to do with the "y-axis" of my mouse, mouse sensitivity or some such, the back and forth tilt is always the same, regardless of how much or little actual y-axis mouse movement happens.

My setup
(This is also the order of installation I used)

Kotor II
Official patchA
Latest official patch
Vista fix
The sith lords restored content mod
Prolog, Peragus, and Harbinger Issue Correction Mod

Qui-Gon Glenn
09-29-2010, 08:13 PM
I intend to use minimal amount of WASD when moving my char around and handle all the basics with mouse instead. For some strange reason, every single time I use mouse to steer my character, the camera does this brief, automatic, completely unavoidable tiny back and forth tilt upwards. I'd love to get rid of it. This feels so nauseating that I'm sure it isn't a stock function, but rather some odd bug, mod not working properly or whatnot. Is this a common problem? Any suggestions how to fix it?

I hope I was able to explain my issue properly:p I'd like to underline this has nothing to do with the "y-axis" of my mouse, mouse sensitivity or some such, the back and forth tilt is always the same, regardless of how much or little actual y-axis mouse movement happens.I think I know what you are talking about, I think you explained it quite well, yet I don't know that anything can be done about it.

In K1, you had to do caps-lock to do Free Look, aka y-axis looking. In TSL they did away with that, and so I think there is little you can do about your nauseating situation... I might be wrong though, and if so hopefully someone else will speak up!
My setup
(This is also the order I installed the mods in)

Kotor II
Official patchA
Latest official patch
Vista fix
The sith lords restored content mod
Prolog, Peragus, and Harbinger Issue Correction Mod

This could be your problem. I would argue that you need to follow Evil Q's installation instructions for Vista, found here (http://lucasforums.com/showthread.php?t=194324). Pay attention to post #2, it tells you everything you need to know.

Install properly, according to those instructions, the game and the only official patch that exists. There is no "latest" official patch, the "patch" that claims to be latest is a bunch of stolen mods that don't work that well together. Install only the official patch, and then if you want the HQ Movies and Sound patches (not at all game-play related). Then, install your mods, which are patcher friendly and actually designed to work well together. If you want to add other mods, I recommend reading readme's thoroughly, and install any mods that do not use the TSLPatcher first.

Kas_Lasak
09-29-2010, 09:07 PM
Thanks for a quick reply! The post you mentioned presents quite a pile of steps! God I hate Vistsa. It looks like a very good guide though; I'll reinstall the entire thing come tomorrow. Gonna see if the issue exists with unmodded version of the game or if it appears only after installing the mods.