View Full Version : Crash after intro...Same story, different issue

10-11-2010, 12:36 AM
Alright, every time I've installed this game there have always been issues, but with googling I'd be able to find the fix

without having to make my own post.

It's the same problem people have been posting about for years...Crash after character creation.

Here's the error details, but I'm only posting it to prove that it's the same old story, and we can skip past all the "did

you do this or that" stuff:

Problem Event Name: APPCRASH
Application Name: swkotor2.exe
Application Version:
Application Timestamp: 00000000
Fault Module Name: StackHash_93e0
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 00000000
OS Version: 6.0.6001.
Locale ID: 1033
Additional Information 1: 93e0
Additional Information 2: ee1f593d2537e95d8b0381229af2787b
Additional Information 3: d78a
Additional Information 4: 1c8b277f1c8f60c6740cbcf29899c050

Here's my chipset details:


Detected Chipset:
Mobile Intel® GM45 Express Chipset

Chipset Components

Memory Controller:
Mobile Intel® 82GM45 Graphics and Memory Controller Hub (GMCH)

I/O Controller:
Intel(R) 82801IMB Intel(R) I/O Controller Hub (ICH9M-B) SATA Controller found in AHCI mode

Integrated Graphics:
This chipset supports integrated graphics.

Now then, here's where I'm looking for help:

I strongly believe the problem lies behind being unable to change the flipping policy to "blit", seeing that this option no

longer exists in this new 3d menu. This was always the fix that did the trick before...and yes, on this very machine. No

idea why this new graphics control panel no longer gives me that option (as well as omits other options)

If I can just find out how to get back the window that the intel site itself is saying I'd get if I follow its instructions

(or better yet just find another way to change the flipping policy) I'm 99 percent sure I'd be all set.

Here's what the intel site is showing me I'd see (and indeed what I'm used to seeing)


...and here's what I'm seeing


It's always something with this game...it's like even as there are no new updates to it, it just has this knack at evolving problems anyway.

Now please note again that this machine is CAPABLE of running this game. It has before.

Anyone willing to spare a friendly stranger patches of baldness?

Edit: Just so any would be helper is aware, I followed the sticky to the letter...except this part.

10-11-2010, 01:42 AM
You're going to have to roll back the graphics drivers to an older version with the old control panel. That's the only way I know how to fix it.

10-11-2010, 01:50 AM
thanks for the quick reply. I kinda had that idea already...guess I'm asking how to go about doing that. That's what I've been trying to find out how to do for the last 5 hours.

Tried downloading and installing previous drivers from the Intel site, but they all give me this fancy thing. Actually, my screenshot shows the earliest version I found.

I realize that this may be more suitable for a different forum altogether, but people have posted similar things in here...and maybe there's a program that I didn't find through googling, that can go in and change what I need manually?

And that 3DAnalyze didn't help. Tried going by the instructions, then tried just checking EVERYTHING off save for disabling textures and rendering obviously. Did that just for the hell of it, and still nothing.

Just FYI, and because perhaps this thread can be useful to the next guy like me who couldn't find one of this like.

10-11-2010, 02:03 AM
You might have to look somewhere besides Intel's site, such as Softpedia, for the older drivers.

10-11-2010, 09:38 AM
Update: found it at softpedia, rollback to correct version successful...changed policy to blit.

and...NO, that was not the issue. After all that work.

However your advice did save me all the trouble of spending more time on finding a fix that was not the issue.

Now I'm stumped. I'm trying a clean reinstall, to the letter. Will let you know the results.

Edit: ...

Uninstalled, reinstalled, did everything precisely as instructed. I'm still getting the same error, in the same spot.

Edit2: Just out of curiosity I ran dxdiag, and it still says I'm using 10. I downloaded and installed the june 2010 9.0c...but it still says 10. Is this normal?

10-22-2010, 04:03 PM
i too have this problem with tsl i can run kotor 1 with no real issues but after the floating space credits in tsl it always tells me swkotor2 has stopped working or something along the line of that i've tried the fix and no results im running windows 7 ultimate 32bit on a toshiba satellite l355-s7915 its making me want to pull my hair out can anyone help??????????????

Qui-Gon Glenn
10-22-2010, 05:51 PM
Have either of the above two posters run the DirectX Runtime? It is a file called dxwebsetup, and it will fill in all of the missing trinkets that your specific installed games are calling for.

Just curious?

10-25-2010, 08:14 PM
well i tried that and it didnt work

11-17-2010, 03:56 AM

Thanks. I got a new computer and it has the same control panel. I've spent about 30 hours trying to figure out how to do the Flipping Policy thing and now I don't have to bother because you showed me it doesn't stop this type of game crashing.

11-22-2010, 12:13 PM
I'm giving this another go after giving up for a month.

I've since done a complete factory format on my machine, and interestingly enough I have the intel window that allows me to change the flipping policy by default.

Big surprise, it's still not working.

edit: sorry about that.

alright, well now i'm willing to bet the problem is with my directx. i tried installing the 9.0c link, but i'm not sure if kotor2 is using this 9.0c by default or the version i currently have.

this could be the problem. is there some control panel for directx besides dxdiag? dxdiag is still saying i'm using version 10.

11-26-2010, 06:50 PM
If you're using Vista or 7, did you install the game according to the large-print instructions at the top of the second post in this thread (http://www.lucasforums.com/showthread.php?t=194324)?

11-29-2010, 09:18 PM
Evil, I appreciate you giving the thread attention, but I think it goes without saying that both I and the others experiencing this same problem with crashing after character creation who have also taken the time to sign up just to find a fix, have already tried all else before signing up as a last resort.

But thanks for caring anyway, and bumping.

BTW, every time I retry this, the "definitive list" that you made a few years back is what I use.

Apparently it doesn't work for everyone, and therefore it's not definitive. No disrespect intended...but I'm just waiting for you to update that list to actually be definitive.

For what it's worth, I had this working with an intel chipset before...maybe a year and a half ago. That's a definite. It was the same machine as I'm using now, and I don't remember how I did it.

There IS a solution.

12-01-2010, 01:20 PM
Apparently it doesn't work for everyone, and therefore it's not definitive. No disrespect intended...but I'm just waiting for you to update that list to actually be definitive.
While the new Intel and ATI drivers are a huge problem, it's come to my attention that several people can't get the games to run because of a persistent failure to follow simple instructions, thinking that they can get away with trying the fixes piecemeal and out of order instead of doing a complete reinstall while closely following the directions. Quite a few more are trying to use a crack and have neglected to tell me about it because they've pirated the game. For some reason, cracks refuse to work with an Intel mobile chipset while working fine on a desktop.

Personally, I've never had a problem getting both games to run on any of my machines, including my laptop with an Intel X3100 GPU. Of course, the drivers for my laptop are the older ones which allow changing the flipping policy. I've always used Nvidia GPUs in my desktops, because ATI's support for older games like KotOR is virtually nonexistent. I update my list whenever I get new information, but none has been forthcoming as of late.
For what it's worth, I had this working with an intel chipset before...maybe a year and a half ago. That's a definite. It was the same machine as I'm using now, and I don't remember how I did it.

There IS a solution.
Wow. Shouldn't this be an indicator that you're doing something wrong? Why don't you try to figure out just what that is instead of bitching about the inadequacy of my instructions? What changes have you made in the meantime? Did you upgrade the OS? Update the drivers? Are you trying to use a crack? :smirk2:

It's pretty obvious to me that the solution you're looking for is on YOUR end; not mine.

12-01-2010, 04:36 PM
Whoa there, no need for lashing out. I've given you no indication that I was being in any way disrespectful for you to react in such a way. Rather, I was being very careful to express my opinion in a constructive, civil manner.

And yes, as I said, every time I try, I follow your instructions to the letter. This last time, as I believe I said, was after a clean factory image reformat, before any modifications were made.

And no, it's not a pirated version, but yes, I have tried using a crack just to rule that out, however only AFTER doing as you said. If that doesn't work, I uninstall completely to be sure that it didn't cause any further problems than what's already there.

To say it's obvious that the problem is specific with me (and I'm taking this liberty only because you did), seems like a cop out.

I'm trying to be helpful, and I know you are as well, but making assumptions like that isn't very constructive.

I'll stop posting in this thread because it's no longer necessary, as I've moved my say to the more suitable one.

12-01-2010, 05:47 PM
As I said before, it's patently obvious that, if you got it to run before, something has changed on your end in the meantime. Different OS? Updated drivers? You're doing something different, and I'm not clairvoyant enough to divine what it is.

This is the second time that I've told you the answer. If you insist on getting defensive, ignoring it and blaming me for the outcome, that's your problem.