PDA

View Full Version : Crash at launch


Kazer Tazer
12-21-2010, 12:09 PM
Hello.

I bought Republic Commando yesterday during the Steam sale, but every time I launch it, it crashes.

I've already tried reinstalling it a few times, but it didn't do anything.

Here are my specs:
Windows 7 64-bit
Intel Core i5 CPU M 450 @
2.40GHz
6.00 GB of RAM

Anyone have any ideas?

HockeyGoalie35
12-21-2010, 10:42 PM
try running as Admin.
(rightclick, run as admin)

or go to the .exe and right click it, go to properties.
then to compatability, and have it compatible for windows xp SP3

Kazer Tazer
12-22-2010, 12:28 PM
Already tried both of those suggestions to no avail.

N-5/Prudii
12-22-2010, 01:58 PM
Did you try re-downloading the game from steam? You could have gotten a corrupt download.

RC-3556
12-23-2010, 05:49 AM
Mines dloaing at the moment, and ive got almost the same specs as you, so if mine works then it must be the download.

HockeyGoalie35
12-23-2010, 07:26 AM
Yeah, every once and a while i get a corrupt dload.

RC-3556
12-23-2010, 11:45 AM
nope, mines fine. A-okay

Kazer Tazer
12-23-2010, 01:13 PM
Nope.
Not the download.

HockeyGoalie35
12-24-2010, 01:46 PM
hmm whats your graphics card?

Kazer Tazer
12-25-2010, 02:05 AM
hmm whats your graphics card?

ATI Mobility Radeon HD 5470

RC-3556
12-25-2010, 06:58 AM
Have you installed this patch? http://www.fileplanet.com/152051/150000/fileinfo/Star-Wars-Republic-Commando-Patch-v1.00 Well I know RC wont run on the low end ATi's but it should work on 4xxx and 5xxx