PDA

View Full Version : KOTOR 2 Windows 7 problem


Chevron 7 locke
01-02-2011, 10:45 PM
Hey everyone. :)

I recently got picked up a new Asus desktop with windows 7 on it and I seem to be having a few issues. KOTOR 1 works like a dream on it but I am having a very annoying problem with KOTOR 2.

The game refuses to start. At all. I click the launcher and I get a spinning cd and then nothing. I followed the directions to get it running on windows 7 and it still refuses to work.

I hope I'm doing this right as this is the first time I've had to post the specs for my game. Also, the specs are of an unmodified game that was freshly installed.

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=1
AllowSoftShadows=1
RefreshRate=60
Width=800
Height=600
V-Sync=0
Texture Quality=2
Anti Aliasing=0
Emitters=1
Anisotropy=1
Frame Buffer=1
Soft Shadows=0
Brightness=57
Disable Vertex Buffer Objects=1

[Game Options]
TooltipDelay Sec=
Disable Movies=0

[config]
firstrun=0


If I need to post anything else please let me know. :)

Q
01-03-2011, 04:57 PM
First, try posting more of the report so that it includes your hardware, like this:
[SWKotOR]
ReportDateTime=12/2/2010 5:34:44 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.10.427
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=8
CPUSpeed=2833
CPUFamily=6
CPUModel=10
CPUStepping=5
CPUVendor=Intel
CPUName=Intel(R) Core(TM) i7 CPU 930 @ 2.80GHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=247.79GB
M: (NTFS), UNICODE=434.12GB
N: (NTFS), UNICODE=133.70GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\,L:\
Drives=Optiarc DVD RW AD-7260S,Optiarc DVD RW AD-7260S,Optiarc DVD RW AD-7260S ATA Device,TSSTcorp CDDVDW SH-S223B,TSSTcorp CDDVDW SH-S223B,TSSTcorp CDDVDW SH-S223B ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=4096
Desktop Resolution=0x0x0
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.3.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce 9600 GSO/PCI/SSE2
NVidia Driver=(null)
Vid Card Status=Warning
Vid Card Driver Status=Fail
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=@oem27.inf,%xfi.devicedesc%;Creative X-Fi Audio Processor (WDM)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=1680
Height=1050
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=8
Voiceover Volume=14
Sound Effects Volume=8
Movie Volume=14
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=3
Sound Init=0
Disable Sound=0

[Graphics Options]
V-Sync=1
Anisotropy=16
Frame Buffer=1
Anti Aliasing=4
Texture Quality=2
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
RefreshRate=60
Height=1050
Width=1680
EnableHardwareMouse=1
FullScreen=1
Disable Vertex Buffer Objects=1

[Game Options]
UnlockedPlanetSongs=863
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=51
BodyVariation=9
AppearanceType=679
PCGender=0
GameCompleted=0
CurSithLord=2
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=0
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=4
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1
EnableCheats=1

Chevron 7 locke
01-03-2011, 05:10 PM
Alright. Thanks EvilQ :)

[SWKotOR]
ReportDateTime=1/3/2011 4:07:34 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=6
CPUSpeed=2611
CPUFamily=15
CPUModel=10
CPUStepping=0
CPUVendor=AMD
CPUName=AMD Phenom(tm) II X6 1035T Processor 2611MHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=271.63GB
D: (NTFS), UNICODE=544.62GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\
Drives=HL-DT-ST DVDRAM GH40N ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=4096
Desktop Resolution=1600x900x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.2.9606 Compatibility Profile Context
OpenGL Vendor=ATI Technologies Inc.
OpenGL Renderer=ATI Radeon HD 5700 Series
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Headphone (VIA High Definition Audio)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0
AllowSoftShadows=1

[Game Options]

[config]
firstrun=0

Q
01-03-2011, 05:36 PM
1) Make sure that you actually replaced the mss32.dll and the swkotor2.exe files with the new ones. Sometimes they either don't overwrite or something else screws up and it keeps the game from running.

2) Go into swkotor2.ini, set Width=1280, Height=768 and Fullscreen=1 under both "Display Options" and "Graphics Options". Make sure to also put the Dantooine lag fix (Disable Vertex Buffer Objects=1) under "Graphics Options", then save and exit.

3) You have an ATI card, and these are notoriously fussy with the KotOR games. Try downloading and installing the latest version of ATI Tray Tools and create a game profile for KotOR 2 with the Direct3d and OpenGL settings set to Auto Balanced.

4) If that doesn't work, try it in conjunction with the suggestion made here:
Hello,

first some facts about the setup:

o Win7 x64
o KoToR via steam (so the installation guide is useless)
o HD5770
o Catalyst 10.2

It's rather simple, really. The game had trouble locating the OpenGL driver and I got a atioglxx.dll exception.

I found the workaround at guru3d and the AMD forums: Put the atioglxx.dll from Catalyst 9.12 in the game folder. So far it works in windowed mode only, but I am glad it works at all.

Source: http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067&enterthread=y
Thread at guru3d: http://forums.guru3d.com/showthread.php?t=315893

Maybe you can work this into one of the guides.

Thanks,
Christian
Good luck. :)