PDA

View Full Version : [K1] HELP! Always Crash at the same Place! (XP and VISTA!!!)


mensch8maschine
01-26-2011, 07:45 PM
Hi guys!

I'm at my wits end...

to finally play thru Kotor I actually reinstalled XP (double-boot-system with Vista) because under Vista, no matter what i did, i'd always crash at the Korriban port.

To be precise, its the cutscene at the beginning, three sith hopefuls are being dressed down by some higher sith (whom i cant see), and after he speaks his first sentence - probably to force-lightning-fry them - BOOM!, the image freezes, Kotor crashes.

I thought it might be vista, hence the xp install, but I have the SAME PROBLEM in XP!!!

My Rig:
AMD Phenom 9850 Quadcore
nVidia 7900 GTX, 500 MB
6 GB RAM
XP Home Edition SP3
DirectX 9.0c

What i tried:
- all the nice "make KOTOR work under vista" stuff proposed in this forum
- newest drivers
- nHancer Kotor profile
- minimum graphics setting
- deactivated soundcard

i've reached this point for the 4th time now, with various mods, in Vista and XP. (and i really dont want to try in vanilla, to time-consuming, and i love using mods...!)

HELP. Pleez!!


PS: maybe i can simply warp somewhere else on Korriban and track back? never tried that... would it break my game???

Q
01-26-2011, 08:01 PM
If you're dual-booting, I'd stick to XP. It's definitely simpler that way.

Since you have a multi-core CPU, you're going to have set affinity to a single CPU core every time you launch the game. How I do it is to open Task Manager (right-click on the Taskbar at the bottom of Windows' desktop and select "Task Manager") and click on the "Processes" tab. Check the "Show processes for all users" box if it isn't already and then launch the game. Once you get to the game's main menu, hit the Windows key to get back to the desktop and look for the game's executable (swkotor2.exe) in the Task Manager under the "Processes" tab. When you find it, right click on it, select "set affinity" and uncheck every box but "CPU 0" and hit "OK". Once you've done that, just hit the game's icon in the Taskbar and you should be good to go. Remember that you'll have to set CPU affinity like this every time you launch the game.

Next, even though you have a DX9 video card, you should also try the Dantooine lag fix:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini"), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.

mensch8maschine
01-29-2011, 11:46 PM
did all that, no cigar. this is soooo frustrating!!!

I also downgraded my graphics adapter driver, didnt do it either. and I used nHancer (that software for nvidia cards that pre-configures your card for specific games).

1) since i'm having the exact same crash in both vista and xp i guess it must be a hardware thing?

2) or maybe my original installation files are broken?

3) anybody think i can just warp to the next map and track back? would that break my game?