PDA

View Full Version : Kotor II Crashes after the Character Creation


initmanjak
03-05-2011, 02:05 PM
When I go through the character creation and the intro movie/cutscene, I am notified that the game has crashed and needs to close everytime. I have followed the vista fix thread to the word and I'm not sure what else to do.

Here is the report I see most people use:


[SWKotOR]
ReportDateTime=3/5/2011 7:00:04 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=1795
CPUFamily=6
CPUModel=7
CPUStepping=10
CPUVendor=Intel
CPUName=Celeron(R) Dual-Core CPU T3000 @ 1.80GHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=58.33GB
D: (NTFS), UNICODE=32.73GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\,F:\
Drives=TSSTcorp CDDVDW TS-L633C

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=2048
Desktop Resolution=1366x768x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.1883
OpenGL Vendor=Intel
OpenGL Renderer=Mobile Intel(R) 4 Series Express Chipset Family
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (Realtek High Definition Audio)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=39
Voiceover Volume=28
Sound Effects Volume=20
Movie Volume=31
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
RefreshRate=60
Height=768
Width=1024
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=1
Grass=0
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=0

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=0
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
UnlockedPlanetSongs=1
TooltipDelay Sec=1

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=4

[config]
firstrun=0


Any help is highly appreciated.

Q
03-05-2011, 02:41 PM
Vista or 7?

initmanjak
03-05-2011, 03:09 PM
Vista or 7?

Windows 7

Q
03-05-2011, 03:50 PM
I have followed the vista fix thread to the word and I'm not sure what else to do.
There are a few things that have not been done. In the swkotor2.ini file, the resolutions and fullscreen settings should match under both [Display Options] and [Graphics Options], and the Dantooine Lag fix should be put under [Graphics Options], like this:
[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=1024
Height=768
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=39
Voiceover Volume=28
Sound Effects Volume=20
Movie Volume=31
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
RefreshRate=60
Height=768
Width=1024
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=1
Grass=0
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
Disable Vertex Buffer Objects=1
If it still doesn't work, try using the old swkotor2.exe file that you renamed and replaced with the newer version by SecuROM. You did rename it and didn't just overwrite it, right?

initmanjak
03-05-2011, 06:11 PM
Never mind, I fixed it by right clicking the desktop and selecting graphics properties. Your help was highly appreciated though! :D

Qui-Gon Glenn
03-07-2011, 03:26 AM
Never mind, I fixed it by right clicking the desktop and selecting graphics properties. Your help was highly appreciated though! :D
Mind sharing exactly what you did? Might be helpful for others suffering your same issue.

initmanjak
03-07-2011, 04:31 PM
Mind sharing exactly what you did? Might be helpful for others suffering your same issue.

Believe it or not, it worked. But about 2 hours in my save game became corrupt and I could play the game at all. I re-installed it and did everything the same, and it doesn't work.. :'(

But the graphics options, I right clicked the desktop screen and went;

Graphics properties > 3D settings > (Change flipping policy to) Blit

initmanjak
03-08-2011, 02:24 PM
So it worked but I can't get it to work again. What have I missed?

[SWKotOR]
ReportDateTime=3/8/2011 7:22:52 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=1795
CPUFamily=6
CPUModel=7
CPUStepping=10
CPUVendor=Intel
CPUName=Celeron(R) Dual-Core CPU T3000 @ 1.80GHz
Status=Pass

[Memory]
RAM=3936
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=61.81GB
D: (NTFS), UNICODE=29.69GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\,F:\
Drives=TSSTcorp CDDVDW TS-L633C

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=2048
Desktop Resolution=1366x768x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.1883
OpenGL Vendor=Intel
OpenGL Renderer=Mobile Intel(R) 4 Series Express Chipset Family
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (Realtek High Definition Audio)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=1
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
V-Sync=0
Anisotropy=2
Frame Buffer=0
Anti Aliasing=0
Texture Quality=0
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
RefreshRate=60
Height=768
Width=1024
EnableHardwareMouse=1
FullScreen=0

[Game Options]
UnlockedPlanetSongs=1
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=0
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1
Disable Movies=0

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=4

Q
03-08-2011, 02:38 PM
There are a few things that have not been done. In the swkotor2.ini file, the resolutions and fullscreen settings should match under both [Display Options] and [Graphics Options], and the Dantooine Lag fix should be put under [Graphics Options], like this:
[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=1024
Height=768
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=39
Voiceover Volume=28
Sound Effects Volume=20
Movie Volume=31
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
RefreshRate=60
Height=768
Width=1024
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=1
Grass=0
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
Disable Vertex Buffer Objects=1
If it still doesn't work, try using the old swkotor2.exe file that you renamed and replaced with the newer version by SecuROM. You did rename it and didn't just overwrite it, right?
:xp:

initmanjak
03-08-2011, 02:45 PM
Still nothing :(
Should I try restarting my pc?

Edit: Nevermind, restart did nothing.

initmanjak
03-08-2011, 07:26 PM
Okay, after fiddling around with the settings but following the tutorial at the same time, this is how I fixed MY Kotor 2. This may not work with other player's versions.

Follow the tutorial in these forums as close as you can, if it doesn't work try not using the new exe's, launch the normal exe in compatibility service pack 2 and administration access, then when the game launches, turn all SOUND control bars down to the minimum and start your game. Once it starts you can turn the sound back up.

That's how I fixed mine.. <3

Q
03-08-2011, 10:36 PM
Did you replace the old mss32.dll file with the new one?

initmanjak
03-09-2011, 10:00 AM
Yes, I did everything that was said in the tutorial on these forums, apart from using the old exe and turning the sound down. :D

Q
03-09-2011, 10:36 AM
Odd, but at least you got it to run.

Another success with a Mobile Intel 4 Series chipset. Good.

Theylas
03-10-2011, 10:32 PM
Hmm, well, I'm having the same problems with the chipset series, but turning the sound down has not helped me whatsoever.

: /

Durn it