PDA

View Full Version : Kotor II Start-up Crash Help appreciated


Darth_Nul
03-23-2011, 04:15 PM
ďStar Wars: Knights of the Old Republic II: The Sith Lor(d?) has encountered a problem and needs to close. We are sorry for the inconvience.Ē Words I am beginning to despise


I received the game last week added several Mods such as TSLRP, 90sk content pack and the Ultimate Saber Mod. After playing the game a few days I discovered that I could patch my game because somehow received the UK version. To make sure I didnít screw anything up I uninstalled all the Mods and the main game. Then I reinstalled the game patched it and it now immediately crashes on start up. I un/reinstalled the game and tried to play it without the patch but that doesnít work either now.

The launcher comes up but the game crashes the instant I attempt to run the program. I have reinstalled about 3 times now but to no avail, used cleaning utilities to fix my registry, did a manual uninstillation through the remove program tool in the control panel. I am just beginning to lose my cool over this error. I also updated my driver although I didnít really expect that to help.

I am currently trying to run the game with the first two UK patches and with no mods on windows XP but it doesnít seem to make any difference at this point.

I have searched on the forum for other people with this problem and this thread describes my situation the closest from what I have seen.
http://64.20.36.211/showthread.php?t=202051

I would appreciate any help you guys could offer as this one has me completely stumped.

[SWKotOR]
ReportDateTime=3/23/2011 2:26:35 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.01.420
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
C:\pagefile.sys=1440

[CPU]
CPUCount=1
CPUSpeed=2004
CPUFamily=15
CPUModel=15
CPUStepping=2
CPUVendor=AMD
CPUName=AMD Athlon(tm) 64 Processor 3200+
Status=Pass

[Memory]
RAM=960
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=10.90GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\
Drives=HL-DT-ST CDRW/DVD GCCH10N

[Video]
Video Card Name=NVIDIA GeForce 6150 LE
Video Memory=256
Desktop Resolution=1280x1024x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=2.1.2
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce 6150 LE/PCI/SSE2/3DNOW!
NVidia Driver=6.14.12.6658
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=SigmaTel Audio
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Sound Init=1
Disable Sound=0
Force Software=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=1
RefreshRate=60
Width=1024
Height=768
V-Sync=0
Texture Quality=2
Anti Aliasing=0
Emitters=1
Anisotropy=1
Frame Buffer=1
Soft Shadows=0
Brightness=57

[Game Options]
Disable Movies=0

[config]
firstrun=0

Q
03-23-2011, 09:15 PM
Thanks for taking the time to post your specs using the game's config utility. It helps a lot.

Just a couple for starters. First, go ahead and do the Dantooine lag fix to eliminate its absence as a potential problem:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini"), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.
Second, if you've recently updated your graphics card drivers, make sure that 640x480 is among the supported resolutions, and if it isn't, make a custom resolution for it.

If neither of those work we'll move on to the .exe.

Darth_Nul
03-23-2011, 10:47 PM
I added the line in the swkotor(2).ini file and created and changed my screen resolution to 640x480, unfortunately neither seemed to affect the games startup error.

Q
03-23-2011, 11:15 PM
You didn't need to change your resolution; you just needed to make sure that your driver supported it for the in-game movies.

PM sent.

SITH LORD 872
03-24-2011, 03:34 PM
I had the same prob with mine, Once i updated all drivers and video card it worked fine. Sometimes it's good to update your pc!!