PDA

View Full Version : [KotOR 1]CTD in XP; help?


Aotrs Commander
05-01-2011, 07:21 PM
Having problems running Kotor 1. I'm having problems with graphics flicker (that I appear to have solved by Tabbing out and using Task Manager to set the affinity to one core, which I learned about from this site), but it's still crashed out a couple of times (on the select portait part of the character generation screen, specifically).

I'm running XP SP3, with an AMD dual core and NVIDIA Geforce 9800GT (all drivers are reasonably recent, as updated when Dragon Age II came out; certainly in terms of Kotor!)

Any ideas?


[SWKotOR]
ReportDateTime=01/05/2011 23:03:46
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
C:\pagefile.sys=2046

[CPU]
CPUCount=2
CPUSpeed=3013
CPUFamily=15
CPUModel=3
CPUStepping=3
CPUVendor=AMD
CPUName=AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
Status=Pass

[Memory]
RAM=2048
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=106.13GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\
Drives=ATAPI DVD A DH20A1P,ATAPI DVD D DH16D2P

[Video]
Video Card Name=NVIDIA GeForce 9800 GT
Video Memory=1024
Desktop Resolution=1280x1024x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=3.3.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce 9800 GT/PCI/SSE2/3DNOW!
NVidia Driver=6.14.12.6658
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Sound Blaster X-Fi Xtreme Audio
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=100
Force Software=0
EAX=3
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1
Environment Effects Nonstreaming=1
Environment Effects Streaming=1

[Game Options]
GUIsInScreenShot=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=1
Difficulty Level=1
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1
Disable Movies=0

[Movies Shown]
Movie 0=0
Movie 1=0
Movie 2=0
Movie 3=0
Movie 4=0
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=77
EnableHardwareMouse=1
FullScreen=1
RefreshRate=60
Width=800
Height=600
Disable Vertex Buffer Objects=1

[Autopause Options]
Mine Sighted=1
End Of Combat Round=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action265=52
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=62
Action213=60
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

Q
05-03-2011, 10:12 AM
Original disks or download like D2D or Steam?

Aotrs Commander
05-03-2011, 11:31 AM
Original disks or download like D2D or Steam?

Four CD disk release.

Don't know how old, though, as I bought 'em as a replacement for my original copy that I somehow managed to lose.

Q
05-03-2011, 12:05 PM
I see that you've done the Dantooine lag fix, which is good, because it's necessary.

Make sure that you set CPU affinity to a single core every time you launch the game. Use the Windows key instead of alt-tabbing.

Since you have an Nvidia card, there is no reason why the game shouldn't be running great at 1280x1024 with all of the eye-candy turned on.

Aotrs Commander
05-03-2011, 03:07 PM
I see that you've done the Dantooine lag fix, which is good, because it's necessary.

I have? What is that, specifically? (A link would do!)

(I mean, I saw one for ATI cards, adding a line in the .ini to disable the vertex buffering or something, and tried that, but it didn't work (not to my great surprise, having an Nvidia card...!), so I took it out again.) Didn't think I'd done anything else apart from doing the affinity thing (might be something already in the discs, since it might be a more recent release.)

Make sure that you set CPU affinity to a single core every time you launch the game. Use the Windows key instead of alt-tabbing.


Will try that next time; I forget that sometimes these older games aren't as forgiving of alt-tab as some of the newer (or much older!) games are.

Since you have an Nvidia card, there is no reason why the game shouldn't be running great at 1280x1024 with all of the eye-candy turned on.

That's what I was hoping... (Never straight foward installing old Bioware games is it!)

Q
05-03-2011, 04:14 PM
I have? What is that, specifically? (A link would do!)

(I mean, I saw one for ATI cards, adding a line in the .ini to disable the vertex buffering or something, and tried that, but it didn't work (not to my great surprise, having an Nvidia card...!), so I took it out again.) Didn't think I'd done anything else apart from doing the affinity thing (might be something already in the discs, since it might be a more recent release.)
That's what I'm talking about, and it is now necessary for any card that supports DX10 and higher, regardless of the manufacturer. If you took it out you need to put it back in.

Aotrs Commander
05-03-2011, 04:30 PM
That's what I'm talking about, and it is now necessary for any card that supports DX10 and higher, regardless of the manufacturer. If you took it out you need to put it back in.

But I put that in and the graphics didn't display properly (the character models were nearly black and the textures all seemed off), and it seemed to work better when I didn't have it in. Aside from the crashing on the char gen screen.

Weird. Well, I'll put it back and see what happens.

(I'm only DX9 anyway, does that make a difference?)

Edit: Well, I put that line back in and it didn't seem to be texturally odd this time. *shrugs* Go figure. When I actually get down to having a proper crack at it again, I'll see if that's fixed any/everything.

Q
05-03-2011, 09:03 PM
It has to do with the GPU and the drivers; not the OS and DX9.