PDA

View Full Version : KOTOR movies problem


Tonotza
05-31-2011, 04:11 AM
I have a problem with kotor movies. Some movies work fine but very often they don't. The problem is that the game jumps to windows when movie starts and can't go back to game anymore, so I have to shutdown the game.

The game works fine when movies are disabled.

My details when swconfig.exe and swkotor.exe ran with SP2:

[SWKotOR]
ReportDateTime=31.5.2011 10:09:22
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=D:\KOTOR\peli\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=4
CPUSpeed=3214
CPUFamily=15
CPUModel=4
CPUStepping=2
CPUVendor=AMD
CPUName=AMD Phenom(tm) II X4 955 Processor 3214MHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=47.22GB
D: (NTFS), UNICODE=38.61GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\,F:\,K:\
Drives=HL-DT-ST DVDRAM GSA-H42N ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=4096
Desktop Resolution=1280x1024x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=3.3.10362 Compatibility Profile Context
OpenGL Vendor=ATI Technologies Inc.
OpenGL Renderer=ATI Radeon HD 4800 Series
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=@oem9.inf,%xfi.devicedesc%;Creative X-Fi Audio Processor (WDM)
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=49
Voiceover Volume=100
Sound Effects Volume=100
Movie Volume=100
Force Software=0
EAX=0
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1
Environment Effects Nonstreaming=1
Environment Effects Streaming=1

[Game Options]
GUIsInScreenShot=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=1
Difficulty Level=1
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1
Disable Movies=0

[Movies Shown]
Movie 0=115
Movie 1=239
Movie 2=9
Movie 3=136
Movie 4=7
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=0
Anisotropy=16
Frame Buffer=1
Anti Aliasing=8
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
AllowSoftShadows=1
RefreshRate=60
Width=1280
Height=1024
Disable Vertex Buffer Objects=1

[Autopause Options]
Mine Sighted=1
End Of Combat Round=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action265=52
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=62
Action213=60
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

Q
06-01-2011, 09:21 AM
1) What version of Windows are you using?

2) Is 640x480 among the resolutions supported by your graphics driver? If not, you'll need to make a custom resolution.

Tonotza
06-01-2011, 09:32 AM
1) I'm using Windows 7 Ultimate x64

2) My graphic card is Radeon HD 4870. When I go to choose the resolution of my desktop, the smallest available resolution is 800x600. So maybe it doesn't support 640x480?

3) How do I create a custom resolution and for what?

EDIT: from catalyst control center I can choose 640x480

Q
06-03-2011, 09:48 PM
Yeah, that's right.

I'm assuming that solved the problem?

Tonotza
06-04-2011, 04:23 AM
No, I didn't change anything. Please help that I can continue gaming : /

Q
06-04-2011, 03:20 PM
Did you install the game according to the large-print instructions at the top of the second post in this thread (http://www.lucasforums.com/showthread.php?t=194324)?

Tonotza
06-06-2011, 04:19 PM
Yes. But maybe I can manage with my problem and try to continue playing. Thanks for the help anyways Q. I appreciate.

Markstopher
06-21-2011, 04:09 PM
Yes. But maybe I can manage with my problem and try to continue playing. Thanks for the help anyways Q. I appreciate.

You might try taking some of the .bik files out of the movies folder. I had a problem with the game bugging out after movies too, so I removed the two logo movies from the movies folder and it at least prevented me from having to restart the game multiple times before finally getting lucky and making it past the intros. I would have taken out more of them, such as the interstitial movies where the Ebon Hawk takes off/lands/jumps to hyperspace, but I couldn't figure out which movies those were, as most of the files are identified only by numbers. Maybe someone else knows which ones are which?