PDA

View Full Version : Kotor 2 graphics lag


Pockey
06-16-2011, 12:25 PM
After waiting for swtor to come out I wanted to play kotor again. The first one worked fine, but kotor2 isn't. I got the game to launch and even started a new game, but the graphics lag is horrible. I'm on peragus and it's unbearable. Any recommendations on how to fix this issue?

Q
06-16-2011, 06:47 PM
And now for the obligatory canned response.
Try using the game's configuration utility to post your system specs:
Post your system specs
Sometimes we're just not going to be able to help you if we don't know what kind of hardware you have on your machine. If you don't know what you have on your machine, then follow these steps below:
Bring up the launcher menu for Kotor 1 or 2.
Click on "Configure".
Click the "Scan Hardware" button on the lower center of the window.
Click "Yes" to continue.
Click "Details" to view your system specs.
Click "Save Report" and save the file to your desktop.
Whenever you post your problem, open the file you just saved and copy and paste the contents to your post.
You can leave out the keymapping.
And please specify which version of Windows you are using because the game can't ID anything newer than XP.

Pockey
06-16-2011, 10:35 PM
[SWKotOR]
ReportDateTime=6/16/2011 9:34:01 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=2405
CPUFamily=6
CPUModel=15
CPUStepping=11
CPUVendor=Intel
CPUName=Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Status=Pass

[Memory]
RAM=4096
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=136.32GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\,F:\
Drives=PLEXTOR DVDR PX-740A ATA Device,SONY DVD-ROM DDU1615 ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=4096
Desktop Resolution=0x0x0
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.2.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce GTX 280/PCI/SSE2
NVidia Driver=(null)
Vid Card Status=Warning
Vid Card Driver Status=Fail
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=@wdma_usb.inf,%usb\class_01.devicedesc%;USB Audio Device
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0


And I am running Windows 7 64 bit

Pockey
06-16-2011, 10:47 PM
And to add also I have no frame rate what so ever, its like a flip book

Q
06-17-2011, 02:47 AM
You'll need to reinstall the game according to the insructions in the second post of this thread (http://www.lucasforums.com/showthread.php?t=194324).

Pockey
06-17-2011, 09:52 AM
That is how I installed it from the start, but to no avail

Q
06-17-2011, 04:45 PM
I see no Dantooine lag fix in your .ini file.

Pockey
06-17-2011, 04:52 PM
I see no Dantooine lag fix in your .ini file.

Thats odd, because when I go inside the kotor2 folder I did the Dantoonie fix and when I go and open it I have Disable Vertex Buffer Objects=1 there already.

Q
06-17-2011, 05:14 PM
Are you using an administrator account?

Pockey
06-17-2011, 05:37 PM
Yes sir

Q
06-20-2011, 09:24 PM
Okay, you're not the first person to experience this problem. I think that it might have to do with Windows permissions, but I have never experienced it personally and I can't duplicate it, which makes finding a solution on my end unlikely. :(

You have an Nvidia graphics card, so the game would run fine if it would just recognize the changes to the .ini file.