PDA

View Full Version : Fixing Lighting on Custom Models


Qui-Gon Glenn
07-16-2011, 04:30 PM
Originally posted here: http://www.lucasforums.com/showthread.php?t=207922, by Dak Drexl (http://www.lucasforums.com/member.php?u=165075).

So have you ever made a custom weapon or headgear and noticed that once you get it in-game, it looks fine in the sunlight, but the second you take it into a darker room or face it away from the sun it gets almost too dark to see? Well there is one very simple fix that you can use to make the lighting on the new model work just like the vanilla models. In other words, this fix will make your new model not be so dark.

This does NOT teach you how to model or rig. It's meant for people who know how to do these things to overcome the annoying lighting problem.
===============================================

Let's get to it. Export and follow all the regular steps to get your model in-game. When you get it in, it'll probably look like this:

http://i852.photobucket.com/albums/ab88/dak_drexl/tutpicbefore.jpg

Now, onto fixing. Make a new folder. Mine is called "MDLOps Use Folder" since I do this so often. In this folder you need your new .mdl and .mdx files from the model you just made. The other thing you need is very important! In addition to the 2 files you just added, you need the -ascii file of whatever you linked your new model to to export it. So in my case I linked with a rifle, so I have the vanilla rifle -ascii file. If you made a pistol, use the pistol file. A sword, the sword file and so on.

Now this is the important part. Compile your .mdl and open up the -ascii file that is produced. Then open up the original file. You should see something like this:

http://i852.photobucket.com/albums/ab88/dak_drexl/tutpic1.jpg

These are the fields you need to fix: Diffuse, Ambient, Render, and Shadow. All you need to do is look at the values of your new file and cross-reference them to the original file. Then replace the values in your file with those in the original:

http://i852.photobucket.com/albums/ab88/dak_drexl/tutpic2.jpg

Now, save that as "yourfile-ascii_new.mdl. Next, compile this file that you just saved in MDLOps. Get rid of the extension and throw the files into your override to see your result (note that I did not change the texture at all):

http://i852.photobucket.com/albums/ab88/dak_drexl/tutpicafter.jpg

See the difference? Hope that helps anyone who finds this problem as annoying as I do :p

Qui-Gon Glenn
09-07-2011, 09:03 PM
Originally posted in the same thread as above post, by Darth DeadMan -QGG

There is another way to do it.
Before you export your model, add an "Aurora trimesh" modifier to your new meshes. In this modifier, check the "Override material values" checkbox. Under this checkbox you will see 3 lines with color selection. Ambient and Diffuse must be set to white, specular to black. All you have to do now is export your model and compile it with MDLOps.
BTW, this method also works with character models, just be sure that "Aurora trimesh" modifier is UNDER "Skin" in modifiers tab.