PDA

View Full Version : Is there a fix to consitent crashes that will preserve saves?


Scootac
09-03-2011, 06:41 AM
I have recently run into the post-Leviathan crashing while playing Kotor 1 and have seen some suggestions that involve compatibility with Windows 7. However, I have been unable to find an option that runs the program in compatibility mode; is there something I am missing and will a fix result in the loss of my current save files?

Q
09-03-2011, 09:33 PM
Please reinstall the game according to the large-print instructions at the top of the second post in this thread (http://www.lucasforums.com/showthread.php?t=194324).

You can definitely try your old saves after reinstalling, but there's no guarantee that they'll work.

Scootac
09-03-2011, 10:29 PM
I have followed the instructions up to the service pack 2 compatibility prompt but when I run setup.exe all it does is repeatedly uninstall the program. Am I supposed to run the autorun afterward?

Q
09-03-2011, 11:56 PM
I would let setup.exe uninstall the game, download and install CCleaner and run its registry cleaner, then reboot and run setup.exe again to reinstall the game.

Scootac
09-04-2011, 01:29 AM
CCleaner didn't find any registry issues when I ran it and after rebooting it is still not installing the game. Is there anything else I can try?

Q
09-04-2011, 03:24 AM
You're not able to completely uninstall the game?

Can you run the uninstaller from the Start Menu (Start>All Programs>LucasArts>Star Wars Knights of the Old Republic>Uninstall Star Wars Knights of the Old Republic)?

Scootac
09-04-2011, 03:48 AM
I can run it through the start menu, it appears to prompt the same uninstall process. Upon completion, the program is still installed but a new window is opened, Program Compatibility Assistant. According to the help section, I cannot manually adjust the compatibility settings, all I can do is tell it that either: it should run it with recommended settings or that the program is installed correctly.

I attempted to run it with recommended settings and it simply attempted to (unsuccessfully) uninstall the program again. Also, the Assistant is not appearing anymore.

Q
09-04-2011, 05:02 AM
Looks like you're going to have to uninstall it manually.

First, go to where your game folder is (default location is C:\Program Files\LucasArts for 32-bit Windows or C:\Program Files (x86)\Lucasarts for 64-bit), delete it and empty the recycle bin.

You're going to have to edit the registry next, so run CCleaner's registry cleaner and backup the registry when it asks you to. If you goof up this next step, all you'll have to do is double-click the backup file to restore the registry back to the way it was.

To get into the registry, go to the Start menu, type "regedit" and click on "regedit.exe" when it appears in the window above. This will open the registry. Navigate to HKEY_LOCAL_MACHINE>SOFTWARE>BioWare (HKEY_LOCAL_MACHINE>SOFTWARE>Wow6432Node>BioWare for 64-bit Windows), right-click on "SW", select "Delete", hit "OK", then close everything up and reboot.

You should then be able to reinstall the game according to the instructions in the second post of the thread that I linked to above.

Scootac
09-04-2011, 05:37 AM
I followed the steps above and rebooted and the problem still persists, I checked the BioWare Corp folder in the registry and the SW folder is back again but is empty. Should I revert to the registry back up and try again or is there something else to try?

P.S. I hadn't mentioned it before but thanks for bearing with me, I truly appreciate your patience, help, and prompt replies

Q
09-04-2011, 05:38 AM
Do you have any other BioWare Games installed?

If not, you can delete the entire BioWare registry key. Remember that any changes that you make to the registry won't take effect until you reboot.

Scootac
09-04-2011, 06:22 AM
Ok, I have deleted every mention of LucasArts and SW, deleted the BioWare registry key and rebooted and the setup is still stuck trying to uninstall the program.

I also noticed that when I ran the setup.exe, a new BioWare folder appeared in the registry, this folder contains a SW subfolder that contains a folder named 0.00.002, does this mean anything?

Q
09-04-2011, 06:47 AM
This is ridiculous. It should be completely gone.

Try using Revo Uninstaller (http://www.revouninstaller.com/revo_uninstaller_free_download.html).

Other than that, the only thing I can think of is doing a system restore using a restore point from before you tried reinstalling the game.

Scootac
09-04-2011, 07:24 PM
Huzzah, Revo has succeeded, setup.exe is finally installing the game! I still have one question though, setup is defaulting to an installation location in C:\Program Files and not C:\Program Files (x86), is this ok or should I put it in x86?

Q
09-04-2011, 07:32 PM
If you're using 64-bit Windows it needs to be installed in Program Files (x86).


GREAT! I'm so glad that something finally got rid of it! :)

Scootac
09-04-2011, 08:34 PM
Ok it seems to be running at the very least, no luck on the saved games so I suppose I'll just have to play back to the Leviathan to find out if all is well. Thanks again for the help!

Q
09-04-2011, 08:56 PM
I was afraid that your savegames might not be compatible, but I'm glad you got it properly installed. It should run better now.