PDA

View Full Version : no Game start menu screen on kotor XP


Adzy
09-03-2011, 11:48 AM
hi there, usually play this on the xbox but thought i would try it on the pc for modding,

my problem is i load the cd, press play game, and it goes through the bioware advert etc, has the load screen but when it should have the menu i only have a black screen with the cursor, and when i move it about i can hear it on the menu options. just no visual i suppose!
i ran the configuration, all requirments met except a warning on RAM(old pc).
i tried a search on the forum but seemed rather fruitless. help will be massively appreciated, really want to play this bad boy!

Q
09-03-2011, 09:25 PM
Try using the game's configuration utility to post your system specs:
Post your system specs
Sometimes we're just not going to be able to help you if we don't know what kind of hardware you have on your machine. If you don't know what you have on your machine, then follow these steps below:
If you're using Vista or Windows 7, go into your game folder, find "launcher.exe" and right-click on it. Select "properties", then "compatibility" and check the box beside "Run this program in compatibility mode for:" and select "Windows XP (Service Pack 2)". Then check the box next to "Run this program administrator" and hit "OK". (EDIT by Q)
Bring up the launcher menu for Kotor 1 or 2 (by running "launcher.exe").
Click on "Configure".
Click the "Scan Hardware" button on the lower center of the window.
Click "Yes" to continue.
Click "Details" to view your system specs.
Click "Save Report" and save the file to your desktop.
Whenever you post your problem, open the file you just saved and copy and paste the contents to your post.
You can leave out the keymapping and everything after that. Also, please specify which version of Windows you are using because the game can't ID anything newer than XP.

Adzy
09-04-2011, 05:14 AM
hey man, i think this is what you mean, bit computer illiterate to be honest.

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
C:\pagefile.sys=576

[CPU]
CPUCount=1
CPUSpeed=1997
CPUFamily=6
CPUModel=8
CPUStepping=1
CPUVendor=AMD
CPUName=AMD Athlon(tm) XP 2400+
Status=Pass

[Memory]
RAM=384
Status=Warning

[Disk Free Space]
C: (NTFS), UNICODE=107.20GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\
Drives=SONY CD-RW CRX320E

[Video]
Video Card Name=NVIDIA GeForce4 MX Integrated GPU
Video Memory=128
Desktop Resolution=1024x768x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=1.5.7
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce4 MX Integrated GPU/PCI/SSE/3DNOW!
NVidia Driver=6.14.10.9371
Vid Card Status=Pass
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=NVIDIA(R) nForce(TM) Audio Codec Interface
Status=Pass

and thank you :)

Q
09-04-2011, 05:36 AM
That's good, though I really need to see all of it up to keymapping like this:
[SWKotOR]
ReportDateTime=8/30/2011 6:10:50 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
c:\pagefile.sys=3072

[CPU]
CPUCount=8
CPUSpeed=3927
CPUFamily=6
CPUModel=10
CPUStepping=5
CPUVendor=Intel
CPUName=Intel(R) Core(TM) i7 CPU 930 @ 2.80GHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=33.21GB
D: (NTFS), UNICODE=391.05GB
E: (NTFS), UNICODE=187.57GB
Status=Pass

[CD-ROMs]
DriveLetters=F:\,G:\,H:\
Drives=Optiarc DVD RW AD-7260S,Optiarc DVD RW AD-7260S ATA Device,Optiarc DVD RW AD-7260S ATA Device,TSSTcorp CDDVDW SH-S223B,TSSTcorp CDDVDW SH-S223B ATA Device,TSSTcorp CDDVDW SH-S223B ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=4096
Desktop Resolution=0x0x0
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=4.1.0
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce GTX 460/PCI/SSE2
NVidia Driver=(null)
Vid Card Status=Warning
Vid Card Driver Status=Fail
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=@oem13.inf,%xfi.devicedesc%;Creative X-Fi Audio Processor (WDM)
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=21
Voiceover Volume=21
Sound Effects Volume=21
Movie Volume=21
Force Software=0
EAX=3
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1
Environment Effects Nonstreaming=1
Environment Effects Streaming=1

[Game Options]
GUIsInScreenShot=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=1
Difficulty Level=2
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1
Disable Movies=0

[Movies Shown]
Movie 0=16
Movie 1=0
Movie 2=0
Movie 3=0
Movie 4=0
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=1
Anisotropy=16
Frame Buffer=1
Anti Aliasing=4
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
RefreshRate=60
Width=1680
Height=1050
Disable Vertex Buffer Objects=1

[Autopause Options]
Mine Sighted=1
End Of Combat Round=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[config]
firstrun=0

Adzy
09-04-2011, 10:55 AM
Ok I will get it sorted, also if it helps I tried running it through 98 and 2000 from the shortcut properties but that didn't do anything.

Adzy
09-04-2011, 11:00 AM
[SWKotOR]
ReportDateTime=04/09/2011 09:13:36
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v1.03.514077
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 3
Service Pack=Service Pack 3
Status=Pass

[SwapFiles]
C:\pagefile.sys=576

[CPU]
CPUCount=1
CPUSpeed=1997
CPUFamily=6
CPUModel=8
CPUStepping=1
CPUVendor=AMD
CPUName=AMD Athlon(tm) XP 2400+
Status=Pass

[Memory]
RAM=384
Status=Warning

[Disk Free Space]
C: (NTFS), UNICODE=107.20GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\
Drives=SONY CD-RW CRX320E

[Video]
Video Card Name=NVIDIA GeForce4 MX Integrated GPU
Video Memory=128
Desktop Resolution=1024x768x32 @ 60Hz
DirectX=DirectX (9.0+) (4.09.00.0904)
OpenGL Version=1.5.7
OpenGL Vendor=NVIDIA Corporation
OpenGL Renderer=GeForce4 MX Integrated GPU/PCI/SSE/3DNOW!
NVidia Driver=6.14.10.9371
Vid Card Status=Pass
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=NVIDIA(R) nForce(TM) Audio Codec Interface
Status=Pass


;Game Options from swkotor.ini

[Sound Options]
Sound Init=0
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=100
Force Software=0
EAX=0
Disable Sound=0
Number 3D Voices=16
Number 2D Voices=24
Environment Effects Level=0.60
2D3D Bias=1.50
Environment Effects=1
Environment Effects Nonstreaming=1
Environment Effects Streaming=1

[Game Options]
EnableScreenShot=0
Reverse Mouse Buttons=0
Hide InGame GUI=0
Use Small Fonts=0
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=33
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
Reverse Minigame YAxis=0
Combat Movement=1
Enable Tooltips=1
Difficulty Level=1
TooltipDelay Sec=1.000000
Memory Access=1
Memory Level=1
Disable Movies=0

[Movies Shown]
Movie 0=0
Movie 1=0
Movie 2=0
Movie 3=0
Movie 4=0
Movie 5=0
Movie 6=0
Movie 7=0
Movie 8=0
Movie 9=0
Movie10=0

[Alias]
HD0=.\
OVERRIDE=.\Override
TEMP=.\Temp
MODULES=.\Modules
LOGS=.\Logs
LOCALVAULT=.\LocalVault
DMVAULT=.\DMVault
SERVERVAULT=.\ServerVault
STREAMMUSIC=.\StreamMusic
TEMPCLIENT=.\Tempclient
SAVES=.\saves
CURRENTGAME=.\currentgame
TEXTUREPACKS=.\texturepacks
STREAMWAVES=.\StreamWaves

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=1
RefreshRate=60
Width=800
Height=600

[Autopause Options]
Mine Sighted=1
End Of Combat Round=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[config]
firstrun=0

[Keymapping]
Action265=52
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=62
Action213=60
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

Q
09-04-2011, 03:44 PM
OK, try this first:
First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor(2)\swkotor(2).ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
When you find it, just double-click on the file to open it in Notepad.
Scroll down the file until you find the Graphics Options
Under the last line ("last line" as in the last line of the list of entries under "Graphics Options", NOT the last line of "swkotor(2).ini"), add "Disable Vertex Buffer Objects=1", without the quotes.
Goto File, then Save.

Adzy
09-04-2011, 04:17 PM
ok man tried that, but still the same, game menu is a black screen with the cursor and music. can still hear it when the cursor is over the menu options as well. i tried clicking them and i think it went to the next menu but still the black screen.

thanks for the help with this btw Q!

Q
09-04-2011, 04:21 PM
Bring up the launcher and hit "configure" again. Set the resolution to 1024x768, and hit "apply" then "exit" and see if that works.

Adzy
09-04-2011, 04:32 PM
No still no luck :(

Q
09-04-2011, 04:45 PM
The only other thing that I can think of is updating your graphics drivers.

Adzy
09-04-2011, 04:56 PM
did that already when i initially installed it as they were out of date. think i may just buy the xbox version till i get a new computer.

thanks anyway though mate, i appreciate the help!

Q
09-04-2011, 05:04 PM
Are you using the disk version?

If so, try renaming the swkotor.exe (don't overwrite it) and use this (http://download.securom.com/support/000056/swkotor.zip) instead.

Adzy
09-05-2011, 01:27 PM
no that didnt work either im afraid :( came up with an error report

Appname: swkotor.exe
Appver: 1.0.3.0
ModName: swkotor.exe
ModVer: 1.0.3.0
Offset: 0005a321

tried it in 98/2000 compatability mode as well