PDA

View Full Version : Shader complicates amazing .efx file - help!


FarbrorGnur
09-13-2011, 11:27 AM
Hey!

Ok, what I have done is that I've created a very nice .efx file, it looks just right in EffectsEd. It's small floating glowing white balls of light (SPRITES), and very many of them.

I have a .tga file with an alpha channel, and a shader that makes the black part get cut away.

Shader:

textures/kokiri/kokirisprite1
{
q3map_nolightmap
cull disable
{
map textures/kokiri/kokirisprite1
blendFunc GL_ONE GL_ONE_MINUS_SRC_ALPHA
rgbGen lightingDiffuse
}
}

NOTE: I don't truly, really know what cull disable and rgbGen lightingDiffuse does. BUT, I'm almost entirely sure the blendfunc is the problem.

THE PROBLEM:

The balls of light are black. They behave like they should, but they're black instead of white.
I tried some different blendfuncs, and many of them seems to remove all of the white floating balls except ONE. This one makes it the right color (white) and it floats alone, and disappears when I open my saber (reappears when I close it), juxtaposed to the black ones.

The shader above is the one generating black instead of white colors. If I change blendfunc to GL_ONE GL_ONE or any other I've tried, it takes away all but one and makes it the right color and buggy.


Any ideas, fellow shaders and.. and mapppers?

Correct but black orbs (http://img51.imageshack.us/img51/3921/floatingblackorbs.jpg)
Buggy orbs (http://img825.imageshack.us/img825/6130/buggyorb.jpg)

ds615
02-07-2012, 12:46 PM
Cull Disable makes it 2 sided, as in you can see it from either side.

Change your rbGen to rbgen vertex or rbgen identity, that should fix it for you.