PDA

View Full Version : Really strange graphics/shader problem


FarbrorGnur
06-22-2012, 12:28 PM
Hey.

I have a map with a light emitting shader:

textures/SP/woodenfloor1
{
q3map_surfacelight 400
q3map_nolightmap
{
map textures/SP/woodenfloor1
rgbGen identity
}
}

It looks bright and horrible like this:

https://dl.dropbox.com/u/58757568/shot0005.jpg

It does on my laptop ATI card, and on a 100% fresh install on a different stationary pc, Nvidia 8800 GTX.

On my friend's PC, however, it looks as it's supposed to do:

https://dl.dropbox.com/u/58757568/sdsagg.jpg

His graphics card is Nvidia Geforce GTX 580.

Compiled with (single test) -light -fast.

Whyyyyy etc. PCs were worse than this when this game was made, so I don't know what the problem is really... any ideas?

MAP: Can you test on your pc? https://dl.dropbox.com/u/58757568/SP.pk3

FarbrorGnur
06-23-2012, 02:58 AM
First problem detected... uhum..! Turns out the difference between fullscreen and windowed mode is huge. Still, fullscreen mode is what makes it look the most ugly, and the game is supposed to be made for fullscreen, so until I can get rid of the insane brightness, the problem is still there.

FarbrorGnur
06-23-2012, 10:05 AM
Partially or completely resolved!

r_overbrightbits is on default 1, it should be 0 when testing these maps in fullscreen. That fixes it. The last thing I must find out now is if it behaves the same way in "final" compiles, because maybe the reason why it became so bright was that it was only (single test) compiles.

ds615
06-27-2012, 02:57 AM
Add rgbgen const (0.5 0.5 0.5) to the shader.
That will keep the look consistent whether overbrightbits is on or off.

FarbrorGnur
06-27-2012, 04:26 AM
WOW thanks :D

:D

Fixed it completely!

Note for coming googlers: Your shader will error unless you write it like rgbGen const ( 0.5 0.5 0.5 )

Thanks again, big breakthrough :)