View Full Version : X-Wing Collector's Series on Modern Systems

12-31-2012, 07:08 PM
You can run the X-Wing Collector's Series (X-Wing, TIE Fighter, X-Wing vs TIE Fighter Flight School) plus the game X-Wing vs TIE Fighter on modern systems by using 3rd party patch utilities called the X-Wing and TIE Fighter 95 Compatability Fix available on lucasfiles (which is down at present), and then the XWAHacker using only the fix for the game in question (use Google to find a suitable download site). Using both patch utilities will allow 3D graphics to function, making these games much more enjoyable. This cannot be done using only one of the two patch utilities. You must use both, and my recommendation is to use them in the above specified order. These games can be played in resolutions above 640x480 without losing visual quality.

These games run in VMWARE Workstation 7/8 in a Windows XP virtual machine for those who cannot get them running well in vista/7. The same method above can be used to activate 3D graphics. A problem exists however as the games will not render in full screen, but will be locked at 640x480. A bug in the CMD was also observed. If you have targeted a cruiser or other large space object the display of the target in the CMD will go blank if it is in front of the target or other large space object. These problems were not observed on the computer itself, just the virtual machine.

A modern USB joystick was used throughout these tests with no problems.

I provide this knowledge in the hope that it will be helpful for people wanting to play these old games.

Happy New Year!

Jurgen Krace
12-25-2013, 12:35 AM

I wanted to play this game, but it's really difficult to make it work.

First of all, I'm using Win 7 64x bit, and a laptop, and i dont have a joystic. I heard, that with the laptop is even more difficult, mostly because of some drivers issues with a joystic emulator.

Ok, some details...

Mouting the 1st disc - The X-wing

1. Run the "setup.exe".... nothing happens

2. Run the "xwingtie.exe", autorun pop-up, i click to Install, it says i have problems with the disc in the device... It cant recognise it, or simply see it.

"The X-wing setup program was unable to launch. Please make sure the CD is in the CD-ROM drive or try running SETUP.EXE directly from the InstX95 folder on the CD-ROM"

I have nothing to do, i try the last one

3. Run the "Z_XVT_.EXE", first i watch the cutscenes, space battle. Next, i see the window which says, that my jostic is not attached. True. I dont have the jostic at the moment.

Ok, i download the joystic emulator. Very wierd one, i must say, it forced me somehow to restart the system in the "test mode".

I tried the "Z_XVT_.EXE", once more - and it's working. But... i had some serious graphic issues. Everything was glimmered [sorry for the language, i'm not the native speaker], i guess, i had some video driver problems. Since i couldnt see anything positively, i "blindly" type-in my name, create an entry, then i tried to launch a game, but i never managed to. I simply couldnt find the proper button...

But, I believe there must be more civilized approach...

I'm not really experienced in these virtual pc things, and i do believe, this is the only way to launch this game. Afterall, i remember, it was working fine in these days, back in the 1990s.

Anyway, is that possibly? I mean, with my configuration (win7 64x bit, laptop, no joystic) to run this game? If yes, i would be glad to hear any instructions.

12-25-2013, 03:41 PM
Jurgen, if you had to boot in Safe Mode, that means you only have generic graphics support, not the drivers needed for 3D games. I'd just get a stick...USB sticks, which should work on your laptop's USB ports, should be supported.

Jurgen Krace
12-26-2013, 10:02 AM
Yeah, I have one of those. But not here with me at the moment. I left it in my parents home. And I dont want to buy another one.

But still, I do believe that the jostic issue is just a minor part of the problem.

I simply couldnt install the game...

12-26-2013, 10:28 PM
Ah, I didn't see that you were using 64-bit Windows. There's an MSI installer package that can be used to install the older games on 64-bit Windows at http://www.markusegger.at

Jurgen Krace
12-27-2013, 08:28 AM
Yeah, that awesome.

I've installed that ****. Now, about joystic emulator. Can you suggest something?

12-27-2013, 01:52 PM
Which one did you try, PPJoy?

Jurgen Krace
12-27-2013, 08:58 PM
To be honest... I dont remember.

I've already deleted that software. Should I try PPJoy?! Or... which one is considered to be the most suitable for this certain game?

12-28-2013, 01:22 PM
PPJoy should allow you to emulate a joystick w/ either the keyboard or a mouse, so if you can get that working on your system, post back.

Jurgen Krace
12-28-2013, 07:06 PM
There are a lot of various versions. My friend, could you, please, provide me a link. It would be really nice; or at least, say which one should I look for. I mean the version of the software.

Jurgen Krace
12-28-2013, 07:14 PM
I mean... i'm not lazy, there a lot of versions with four set of numbers, like 0-8-4-6. And according to the messages on another forum, some of them, are compatible with a certain set of the games.

Jurgen Krace
12-29-2013, 01:07 AM
negative, negative, it just impacted on the surface

I tried both versions which I could find. The 0-8-4-6, and 0-8-4-5 (which was for the XP).


1. Run > bcdedit.exe -set TESTSIGNING ON
2. Restart OS
3. Setup (i tried both versions; of course not at the same time, the one after another)
4. Then (!) I run the software's options. Since I dunno what to set up, i skipped it first.
5. Try to run the game - it doesnt worked out. The Game never saw the joysic.
6. I tried to "play with switching" the levers in the options (debug stuff, mapping). Same result.

But I've got feeling, that something is wrong.


Maybe, something is wrong, no?

P.S. I hope for quick response, I cant wait to play it...

12-29-2013, 01:03 PM
Found this:


Apparently, you need to force driver signing off, as well, in order to install it on Win7.

Jurgen Krace
12-29-2013, 02:15 PM
I did everything... still it doesnt working.

1. Type in cmd - bcdedit -set testsigning on. After I reboot my PC, I can see the watermarks.

2. Notification in the uac, i make sure, that the lever is pulled down to the bottom. (btw, it like this before).

3. I Downloaded and Installed the "Disable Win7 driver signing enforcer" software.
Run it. I did select the "enable test mode", then click to the next.
Then, i selected "exit" and clicked the next.

That's it.

Then I tried the same operations, but with the another version of a PPjoy 0846.

Same results.

On the screenshots i put the configurations of the program settings.


P.S. I'm sure, there is something went wrong, because, I do remember, i was looking in the Mapping settings, previous time, before I found this Forum. If you remember, I wrote it above.

So, It was working fine that time, and by the matter of fact, I already ran this game, but with the graphic issues.

I dont know what to think. Maybe you guys, could point me my mistakes.

Jurgen Krace
12-29-2013, 03:14 PM
I think I've found the reason.

I start to chaotically add new diveces on the "PPjoy Joystic and Gamepad configuration utiluty".

Then, suddenly, in the left bottom corner, transperent widow appears. It says there, that new device is found, and drivers are installing at the moment. So I clicked to that window, to see the details.

I was watching how the Windows is trying to install the drivers, but then it was rejected. Something is DEFENITELY wrong.

Jurgen Krace
12-29-2013, 07:59 PM
Also, it happens during the installation on PPjoy.

I wathed this just now. I tried once more,

1. cmd set on
2. disable softare thing
3. ppjoy thing

during the installation of ppjoy, that transparent window appeared again. windows was searching for the drivers, later on - it was rejected. it makes nosense, since i switched it off

12-30-2013, 01:03 PM
Well, I can't really help you further, as I've always had a stick and no use for PPJoy (which is actually supposed to be a driver for old parallel port sticks).

Jurgen Krace
12-30-2013, 03:38 PM
Anyway, I'm not giving up