View Full Version : Limit framerate in original JK

01-25-2002, 01:07 AM
Does anyone know of a way to limit the framerate in the original JK. It ran fine way back when I got it but now my computer is too fast. Its too fast in software or 3d accelerated and I don't really want to run in software mode anyway.

01-25-2002, 02:26 AM
Welcome to the forums :)

well, what you could try, is fiddle with the advanced 3d settings that you normally cant access in JediKnight

Instead of just shortcutting to JK.exe, make your shortcut path look like this

"C:\JediKnightDirectory\jk.exe -displayconfig"

then in your settings you should have an Advanced Display menu. Try fiddling with some things in there. I'm not sure if it will help, but it's worth a shot.

I've never incountered that problem. What's your system like?

Millions o' Monkeys
01-25-2002, 02:31 AM
unless your system is running at over 1.6 ghz i cant possibly think of why its doing what its doing

01-26-2002, 02:36 AM
the -displayconfig wont work 4 me :S
keeps sayin its not a valid path
been doin this with q3 too

my cutscenes r runnin way 2 fast :S must be fixed
kyle+maras little scene @ the start of mots is approximately 3seconds long

01-26-2002, 05:38 AM
a friend of mine played through my MotS, and he had the same prob, he was running a PIII 1 ghz, and a crappy intel onboard video... we never did figure it out, so i had to give him the jist of the cutscenes...

01-26-2002, 07:06 AM
I have this problem with my PC.....but I have an external program slowing all my old games down. GTA with the frame limiter off is funny though :)

01-26-2002, 03:01 PM

01-26-2002, 04:50 PM
Sorry, in the excitement I forgot to say


01-27-2002, 02:37 PM
Aren't all the cutscenes done in software anyway?

01-27-2002, 06:57 PM
ummm.. speedy cutscenes?? this sounds all too weird for me.
me=1.4 GHz AMD Athlon, 768MB RAM, GF2 MX400 64MB.

no problems with the game being too fast.

And by the way: JK has a 75 frames per second limit when u run it with 3d mode on. Soo I don't understand this..

u can get faster framerates when u turn 3d off:

set it to 3d mode X, turn on backbuffer in system memory, et voila: no more 75fps limit.