PDA

View Full Version : Radiant Problems


Singularity
01-27-2002, 11:02 AM
Radiant won't compile my levels. The DOS console gives me this: "ERROR - setQdirfrompath: no 'STARTR~1' in [my Elite Force directory]"

Anybody know how to fix this?

wolf359
01-27-2002, 01:18 PM
there are a couple of ways to fix this.
1. you can edit the .qe4 file (it's just a text file) and change every instance of -qdir 'STARTR~1' to something that is in the path to where you have EF installed. eg if you have Ef installed in to c:\games\raven\ef you could change if from -qdir'STARTR~1' to -qdir raven

2. add a folder with the name 'STARTR~1' into the path to where you have ef installed


basically all it's doing is looking for star trek in the path and it can't find it. q3radiant does something similar but looks for quake instead.

UniKorn
01-27-2002, 04:54 PM
The same goes for gtkradiant. It even looks for a baseq3 directory, but with a little trick you can change that ;)

Singularity
01-28-2002, 03:09 AM
I've modified EF.qe4 in the way you suggested, but it still isn't working. The Elite Force executable is in this directory: "C:\program files\raven\Star Trek Voyager Elite Force"

I've changed the -qdir to \raven, \baseEF and \Star Trek Voyager Elite Force, and it still isn't working. It says "No file to process" and lists my raven\tools and ravenbaseEF directories.

wolf359
01-28-2002, 03:22 AM
you should change the -qdir to raven and not \raven.

but that's besides the point. it's got past the -qdir stage or you would still be getting the same error message.
try doing a novis nolight compile and post the full error message. it sounds as though your project settings aren't set up properly and that it can't find the .map you want to compile.

unikorn: nice to see you m8. i didn't know you were coming here. or is this part of the new project you were telling me about on #ravenmapping.

Singularity
01-28-2002, 04:33 AM
That's probably right. Before I post the error, note that rshcmd is blank (I didn't know what to put there) and that basepath & remotebasepath are both set to raven\baseEF. I know that mapspath and texturepath are properly set.

A novis nolight compile generates the following error:

"No file to process. Run with -? for help"

A fullvis compile says "No file to process. Run with -? for help" twice, both times pointing to raven\baseEF\maps/firstlevel.map, as well as "SetQdirFromPath: no 'Raven-extra' in c:\program files\raven\baseEF/maps/firstlevel.map (use qDir X to change).

raven\baseEF\maps\firstlevel.map exists.

Thanks for helping me out, wolf.

UniKorn
01-28-2002, 04:35 AM
;) Have fun mapping!

wolf359
01-28-2002, 04:50 AM
nice one UniKorn

OK the project settings should be setup like this.

BasePath - this needs to point at your baseef folder eg
C:\program files\raven\Star Trek Voyager Elite Force\baseef

MapsPath - this needs to point at the folder where your maps are this should be C:\program files\raven\Star Trek Voyager Elite Force\baseef\maps

RshCmd this can be left blank

RemoteBasePath - this should be set to the same as your basepath eg C:\program files\raven\Star Trek Voyager Elite Force\baseef

Texturepath this needs to point towards your textures eg C:\program files\raven\Star Trek Voyager Elite Force\baseef\textures.


you may find if you haven't extracted the pk3 that you don't have a maps folder in the baseef folder (wouldn't be the first time i've seen it happen) in which case make one and make sure your .maps are in there.

the last part of your fullvis error message is telling you that you've made a mistake in editing the .qe4 file for fullvis. you didn't leave a space between the -qdir raven and the -extra

UniKorn
01-28-2002, 04:57 AM
Whoops read it real quickly, saw thx Wolf so I thought everything was ok ;)

Singularity
01-28-2002, 05:31 AM
It kind of works now. Here's what the console outputs:

Extra detail tracing
entering C:/progra~1/raven/stvef/scripts/shaderlist.txt
entering C:/progra~2/raven/stvef/scripts/common.shader
[does this for all of the .shader files]

*Here's where things screw up*

reading C:\progra~1\raven\stvef\baseef/maps/firstlevel.bsp
ERROR
Error opening C:\progra~1\raven\stvef\baseef/maps/firstlevel.bsp: no such file of directory

I thought compiling made the bsp file...
Out of curiousity, why do the path name slashes alternate between / and \?

Edit - That was a fullvis compile, by the way.

wolf359
01-28-2002, 05:39 AM
now you're getting somewhere. really you are.

what's happening now is that it's trying to compile at the later stages but because something has gone awry in the first stage there is no .bsp to process.

basically a fullvis has 3 stages

1. converts the .map into a .bsp
2. does the vis stage and basically makes a workable map.
3. lights the map to make it look nice.

what you need to do now is to only do a novis nolight compile which will only do the very forst stage and show you an error message as to what's wrong. once you fix this you can then go onto a fullvis and take it from there.

EDIT i'm not sure why the \ and / alternate like that but i think it's to do with part of it coming from the .qe4 file and part being parsed by radiant

Singularity
01-28-2002, 06:27 AM
I ran a novis compile, and it seems I'm back to the old "No file to process" error.

Here's the full thing:

"C:\program files\Raven\STVEF\BaseEF\maps>C:\WINDOWS\TEMP\qe3bsp.bat > C:\WINDOWS\TEMP\junk.txt

C:\program files\raven\STVEF\BaseEF\maps> C:\progra~1\raven\tools\\q3map -qdir RavenC:\progra~1\raven\stvef\baseef/maps/firstlevel.map
[version info]
--- map---

ERROR
No file to process"

I thought that the problem was in the -qdir RavenC:\ part ("thought maybe Radiant was looking for the RavenC drive), but it seems to parse that way weather there's a space in EF.qe4 or not. I've got two EF.qe4 files in my raven\scripts directory (though they both contain different information); might this be the problem?

I'm using a few entities. Currently, Radiant looks for \raven\stvef\baseef\*.def for entities. I tried changing that to the specific .def file (SP_ENTITIES.def), but it had no effect.
I'm stumped.

wolf359
01-28-2002, 07:22 AM
are you absolutley certain that
C:\progra~1\raven\stvef\baseef/maps/firstlevel.map exists.
make sure that your .map is in that location. also it's best to stick to the dos standard of 8 letters and no spaces for your mapnames. try calling it level1.map and then retrying.

Singularity
01-28-2002, 09:06 AM
I think what's wrecking things is the EF.qe4 file. Here it is. I've been messing with it, trying to get the directories and such properly set, but I may have inadvertantly entered something I shouldn't have. Could you take a look?

{
"basepath" "C:\PROGRA~1\RAVEN\STVEF\BASEEF"

"rshcmd" ""

"remotebasepath" "C:\PROGRA~1\RAVEN\STVEF\BASEEF"

"entitypath" "C:\PROGRA~1\RAVEN\TOOLS\*.def"

"texturepath" "C:\PROGRA~1\RAVEN\STVEF\BASEEF\textures"

"autosave" "C:\PROGRA~1\RAVEN\BASEEF\\maps\autosave.map"

"bsp Relight" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven -onlyents $ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -light -qdir Raven$"

"bsp Relight (extra)" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven -onlyents $ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -light -qdir Raven -extra $"

"bsp Novis (nolight)" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven$"

"bsp_Entities" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven -onlyents $"

"bsp FullVis" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven$ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -vis -qdir Raven$ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -light -qdir Raven -extra $"

"bsp FullVis (nolight)" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Star Trek Voyager Elite Force$ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -vis -qdir Star Trek Voyager Elite Force$"

"bsp FullVis (lowmem)" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir BaseEF$ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -vis -qdir Raven -nopassage $ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -light -qdir Raven$"

"bsp FastVis" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven$ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -vis -qdir Raven-fast $ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -light -qdir Raven$"

"bsp FastVis (nolight)" "! C:\PROGRA~1\RAVEN\TOOLS\\q3map -qdir Raven$ && ! C:\PROGRA~1\RAVEN\TOOLS\\q3map -vis -qdir Raven -fast $"

"mapspath" "C:\PROGRA~1\RAVEN\STVEF\BASEEF\maps"
}

test.map (my current map file) does exist.

wolf359
01-28-2002, 10:45 AM
i've made a .qe4 file that i think will fit your installation but have no way of testing it. you can get it <a href="http://www.challenge.freeserve.co.uk/single.qe4">here</a>

good luck

Singularity
01-28-2002, 11:11 AM
No good, I still get the error.

I'm going to reinstall Elite Force later on (haven't got time now). If that doesn't work, I'll just buy Quake 3 or something. Thanks for all the effort you've put towards helping me.

Edit - Actually, I just thought of one more thing. If someone who's got EFRadiant to work could post their EF directory structure, I could copy it on my machine. Maybe I've put some files where they don't belong.

UniKorn
01-28-2002, 04:10 PM
text.txt is just a textfile with my dirstructure in it, you don't need it ;)

Het volume in station G heeft geen naam.
Het volumenummer is 1A00-0E36

Map van G:\Program Files\quake\Star Trek Voyager Elite Force\Tools.

. <DIR> 26/11/01 22:28 .
.. <DIR> 26/11/01 22:28 ..
SP_ENT~1 AAA 206.396 22/09/00 16:16 SP_entities.def.aaa
BEHAVED EXE 372.736 29/09/00 22:09 BehavEd.exe
EFTOOL~1 DOC 34.304 22/09/00 19:26 EF Tools EULA.doc
EFRADI~1 EXE 839.680 02/10/00 14:57 efRadiant.exe
HM_ENT~1 DEF 20.750 22/09/00 16:16 HM_entities.def
IBIZE EXE 98.304 16/06/00 20:38 IBIze.exe
ICARUS~1 DOC 158.208 19/02/00 23:25 ICARUS Manual.doc
MD3VIEW EXE 192.582 28/06/00 23:50 MD3View.exe
Q3DATA EXE 167.998 20/09/00 20:30 q3data.exe
REAL_S~1 ZIP 959.391 23/09/00 0:07 real_scripts.zip
SHADERED EXE 876.614 03/10/00 22:01 ShaderEd.exe
BEHAVED BHC 10.046 29/07/00 19:35 BehavEd.bhc
SOURCE~1 <DIR> 26/11/01 22:28 SourceForBehavEd
REAL_S~1 <DIR> 26/11/01 22:28 real_scripts
BSPC LOG 87.178 07/01/02 11:55 BSPC.LOG
Q3MAP_~1 <DIR> 03/01/02 22:26 q3map_ydnar
Q3MAP EXE 368.700 18/09/00 17:44 q3map.exe
Q3MAP2 EXE 606.279 02/01/02 12:20 Q3MAP2.EXE
LIBXML2 DLL 217.088 03/10/01 14:50 LIBXML2.DLL
GDK-13~1 DLL 372.788 26/09/01 15:03 gdk-1.3.dll
GLIB-1~1 DLL 266.240 26/09/01 15:02 glib-1.3.dll
GMODUL~1 DLL 24.576 26/09/01 15:02 gmodule-1.3.dll
GTK-13~1 DLL 991.232 26/09/01 15:04 gtk-1.3.dll
ICONV DLL 606.208 26/09/01 15:02 ICONV.DLL
EGYPTS~1 TXT 1.801 04/09/01 21:16 egyptsoc_readme.txt
TEXTURES <DIR> 04/01/02 20:11 TEXTURES
HM_ENT~1 TXT 20.750 22/09/00 17:16 HM_entities-def.txt
BSPC EXE 323.584 18/07/00 0:27 bspc.exe
SP_ENT~1 DEF 206.396 22/09/00 17:16 SP_entities.def
TEXT TXT 0 29/01/02 5:14 text.txt
26 bestand(en) 8.029.829 bytes.

Map van G:\Program Files\quake\Star Trek Voyager Elite Force\Tools\q3map_ydnar.

. <DIR> 03/01/02 22:26 .
.. <DIR> 03/01/02 22:26 ..
0 bestand(en) 0 bytes.

Map van G:\Program Files\quake\Star Trek Voyager Elite Force\Tools\real_scripts.

. <DIR> 26/11/01 22:28 .
.. <DIR> 26/11/01 22:28 ..
_BRIG <DIR> 26/11/01 22:28 _BRIG
0 bestand(en) 0 bytes.

Map van G:\Program Files\quake\Star Trek Voyager Elite Force\Tools\real_scripts\_BRIG.

. <DIR> 26/11/01 22:28 .
.. <DIR> 26/11/01 22:28 ..
REMOVE TXT 2.126 03/08/00 21:42 remove.txt
PICKAN~1 TXT 797 21/07/00 16:12 pickanumber.txt
POORMU~1 TXT 1.863 28/07/00 21:08 poormunro.txt
3 bestand(en) 4.786 bytes.

Map van G:\Program Files\quake\Star Trek Voyager Elite Force\Tools\SourceForBehavEd.

. <DIR> 26/11/01 22:28 .
.. <DIR> 26/11/01 22:28 ..
ANIMS H 50.669 02/08/00 20:09 anims.h
B_PUBLIC H 11.410 09/02/00 1:30 b_public.h
BG_PUB~1 H 17.824 01/06/00 21:43 bg_public.h
BOLTONS H 528 18/11/99 18:19 boltons.h
BSTATE H 3.234 30/06/00 8:56 bstate.h
EVENTS H 264 30/06/00 8:56 events.h
G_FUNC~1 H 20.326 04/02/00 20:13 g_functions.h
G_ITEMS H 954 30/06/00 3:05 g_items.h
G_NAV H 323 02/02/00 23:15 g_nav.h
G_PUBLIC H 10.725 02/02/00 17:23 g_public.h
G_SQUAD H 3.881 02/02/00 23:10 g_squad.h
OBJECT~1 H 12.009 26/07/00 19:08 objectives.h
Q_SHARED H 31.557 07/02/00 19:42 q_shared.h
Q3_INT~1 H 15.889 08/08/00 23:57 Q3_Interface.h
Q3_REG~1 H 1.010 10/12/99 15:47 Q3_Registers.h
SAY H 473 31/08/99 18:24 say.h
STATIN~1 H 629 30/11/99 22:59 statindex.h
SURFAC~1 H 2.525 25/01/00 23:52 surfaceflags.h
WEAPONS H 3.602 02/08/00 22:30 weapons.h
AI H 951 09/02/00 1:30 AI.h
B_LOCAL H 10.756 04/02/00 18:49 b_local.h
BG_LOCAL H 1.348 11/11/99 1:16 bg_local.h
BSET H 1.215 30/06/00 8:56 bset.h
CHANNELS H 1.100 30/06/00 8:56 channels.h
FIELDS H 1.806 26/01/00 23:32 fields.h
G_LOCAL H 15.005 06/02/00 2:12 g_local.h
G_NAV2 H 3.837 04/02/00 20:13 g_nav2.h
G_SHARED H 27.869 09/02/00 1:30 g_shared.h
G_TEAM H 2.219 09/08/99 17:54 g_team.h
Q3_ANIMS H 1.857 20/03/00 23:23 q3_anims.h
TEAMS H 426 16/08/00 1:43 teams.h
31 bestand(en) 256.221 bytes.