PDA

View Full Version : Dual Cpu???


SYNERGiST
03-27-2002, 07:04 PM
How do i enable dual cpu?
Quake III engine supports dual... does tihs also?

Thx, SYNERGiST

Demons
03-27-2002, 08:30 PM
I emailed Lucasarts about enabling dual cpu in the game and they responded informing me that "Jedi Knight 2 does not have any special code to use Dual processors". Now I know that SMP is built into the quake 3 engine and I wouldn't be surprised if someone comes up with a way to enable it with a simple hack but it seems that Lucasarts has not included dual processing as a standard feature. Currently I am running a Dual AMD 1800+ system on a Tyan Tiger MPX with WinXP and I can't get Multiplayer to load. It gives me an error every time. Singleplayer works great and I have love it! But so far I've had no luck with MP. Let me know if anyone has a similar problem or a similar setup with no problems! :)

JonRicoPa
03-27-2002, 09:06 PM
Yep same problem here.

I have an ASUS AM7266-D and a pair of 1700xp chips.
Run WinXP with a GF3.

I have also spoken to another person with a similar setup that has the same issue. It may be a problem with the MPX chipset.

Its not a dual CPU issue as it (the multiplayer) runs fine on another box I have which is a Tyan Tiger 133 based system with dual P3-800s and a GF2.

I have all the latest drivers etc etc, and can play every other Q3 engine game on the dual AMD Rig - ie Wolf sp and mp, MOHAA, Q3 etc.

Anyone any ideas?

Demons
03-27-2002, 10:04 PM
Well, I'm glad it's not just my board. I am also running a GF3 but I know that it's not the video card because I swapped it out with an old Geforce2 MX and it still comes up with the error. I'll give Lucasarts a call tomorrow and see if they are aware of the problem. The only XP drivers for the MPX chipset is the IDE busmaster one and I have the latest version installed. I guess all of the other chipset drivers are built in. It really doen't seem like an AMD problem though, since the other Q3 engine games work just fine in multiplayer. Hopefully Lucasarts will release a patch soon. I'm going to also try and install Win98 or Win2000 on another hard drive that I have to see if the problem is only in XP. I'll post my results later! :)

khankinsjr
03-28-2002, 12:14 AM
Well, glad to see I am not the only one.

A7M266-D
2xAthlon MP 1600+
Leadtek Geforce 3
SBLIVE!
3COM 3C990-TX97 Network
768MB PC2100 RAM

Whoever contacts lucasarts, let them know that people with dual athlon systems seem to all be having this multiplayer issue. Hopefully they will fix the problem right away; I want to play multiplayer damnit!...:)

en4cr
03-28-2002, 10:30 AM
Just thought I'd add to this thread. Having the same problem running multiplayer. Single player boots fine.

Tyan Tiger MP Dual AMD 1700Xp's
Geforce 3 TI 200
SB Audigy
512 DDR ram

etc


I have a Dual P3 rig I should try it out on to see if it's a dual AMD problem. Perhaps with the 760MP chipset. I'm very interested to see if someone finds a solution.

Cheers

En4cr

JonRicoPa
03-28-2002, 02:10 PM
Its just dual Athlon. Works on my dual P3 rig.

Demons
03-28-2002, 02:25 PM
Well I guess we know now that it's a problem with both the MP chipset and the MPX chipset. I have also tested it on my system in Win2000 and WinXP. Neither one worked. Single player works fine. Multi-player will not load. I couldn't get Win98 or WinME to work properly to test it which doesn't really surprise me. You don't usually make Win98 drivers for a dual CPU chipset. Anywho, I hope LA comes out with a patch soon!

Tyan Tiger MPX
Dual XP 1800+
1GB registered DDR RAM
Geforce 3
SB Audigy
3com intigrated 3c905C-TX
WinXP

emorog
03-28-2002, 02:57 PM
you've said the MP doesn't load and gives an error, but have neglected to state what the error message is.

how do you expect them to patch "it doesn't load"? ;)

Demons
03-28-2002, 03:12 PM
As for the error message. It doesn't really tell you much. The JK2 screen comes up and initializes everything, it then sits there for a few seconds doing nothing and then you get a message from the OS that says "JK2MP.exe has caused an error and needs to be shut down." Then it asks you if you want to send the info to M$, in WinXP of course. I've looked through the details of the error message and I can't make out any other files or DLLs that is causing the error. It only makes reference to JK2MP. I'll try and screen copy it in here when I get home from work tonight. I think the best thing all of us with Dual AMD boards is to CALL LUCASARTS!!! The more people that call about it, the quicker they will come out with a patch to fix it. Here is the number to call:

LA Technical Support Hotline
Voice: (415) 507-4545

Hopefully they will resolve this soon! :)

MoopMeep
03-28-2002, 03:18 PM
I have the same crash too. Single Player works fine but in Multiplayer it crashes after it says "detecting CPU, Pentium III detected". I am running an Intel OR840 mainboard with dual PIII 866 and an ATI AIW Radeon video card with the latest drivers.

Demons
03-28-2002, 03:23 PM
When you post, be sure to list your system specs and what version of Windows you are running so that we can localize this problem. And don't forget to call Lucasarts and tell them we have a problem!!! Thanks! :D

MoopMeep
03-28-2002, 03:50 PM
here are my specs

Windows XP
Intel OR840 mainboard with onboard LAN
Dual PIII 866
384 megs RDRAM
ATI AIW Radeon with latest drivers (lucas arts tested with older drivers)
Creative Labs SB Live 5.1 XGamer
2 20 Gig drives
Yamaha cd rom burner.

JonRicoPa
03-28-2002, 04:53 PM
OK Then

I have two systems. This one fails with the mp error on startup.

Dual Athlon XP 1700+
ASUS AM7266-D
Hercules 3D Prophet III GF3 AGP Card 23.11, 28.32 drivers
SB Live
Intel 100 nic
Realtek 100 nic
Windows XP

This one works perfectly

Dual P3-800EB
Tyan Tiger 133
Hecules 3D Prophet II GF2 AGP Card 28.32 drivers
SB 1024
Realtek 100 nic
Windows XP

Both systems successfully play MOHAA, Q3 and Wolf in both single and multiplayer modes.

KandyFLip
03-28-2002, 06:51 PM
well aint this a biatch.

Same problem:

W2k Pro, all patches
Dual Athlon MP 1900+
Tyan Tiger MPX
1GB DDR
PNY GeForce4 TI 4600
SB Audigy

here's a shot of the error happening:
http://mywebpages.comcast.net/rbeem289869mi/jkerr.jpg

zorrax
03-28-2002, 07:19 PM
Thanks for the screen shot, that is EXACTLY what I am getting.


Tiger 2640
Dual Athlon MP 1500
512 MB Corsiar Ram
Raedeon 8500
Win 2k

Demons
03-28-2002, 08:28 PM
Does anyone have a screenshot of the WinXP error message? It gives a little bit more detail of the error. I can do it when I get home but I was just wondering if someone already had one or can make one.

khankinsjr
03-29-2002, 02:49 AM
Here is the XP error; I am also going to send the dump file created when the error occured to Lucasarts.

http://www.csionline.net/~khankins/jkmp.JPG
My Specs:
ASUS A7M266-D Rev. 1.03
2XAMD Athlon MP 1600+
Leadtek Geforce 3 64MB
Sound Blaster Live
768MB PC2100 Crucial Memory
NEC PCI USB 2.0 Card
3COM 3C990-TX97 NIC
PIONEER DVD-114 10X DVD DRIVE
HP 8100+ Writer
60GB Seagate Barracuda IV
40GB Seagate Barracuda IV

KandyFLip
03-29-2002, 01:28 PM
Well, I filled out a help request through Lucasart's support site. Hopefully they'll answer soon. I'm bummed :(

KandyFLip
03-29-2002, 04:03 PM
Response from LEC:

Hi,
Thank you for your message.
We are becomming aware of this particular problem. I have passed this along
to our compatibility staff for review. Keep checking our website for updates
on this issue. We hope to have an answer soon.

emorog
03-29-2002, 07:24 PM
after it crashes, can you hit the "details" or "click here" button.
i'm looking for the address of the exception so i can track down what's causing it.

(right after the cpu detect print, it gets your username, then cpuspeed, then physicalRAM. i'd bet it's the cpuspeed detect that's going wrong.)

thanks,

James Monroe

Ambience
03-30-2002, 12:52 AM
Who hoo! I'm glad I'm not the only one, I was getting ready to throw my computer out the damn window!!

I'm running:

Tyan Thunder K7 UNG
2x Athlon MP 1900 + processors
1 gig of ram
GeForce 4 Ti 4600
2x Ultra SCSI 160 drives

I get the exact same error on XP that was posted above.

As for the error report, there is a ton of information in it, but here's what's at the top.

Exception information
Code: 0xc0000094 Flags: 0x00000000
Record: 0x0000000000000000 Address: 0x0000000000444c2e

raiden
03-30-2002, 07:35 PM
well i have made a small modification to the jk2mp.exe so that the game is able to start on my tiger mp & win2k system.
unfortunatly now i have the "CL_ParsePacketEnties" problem, which comes short after opening a game.
however everyone who wants to give it a try can download the modified file from here:
http://www.htwm.de/~sdoempke/jk2mp.rar

JonRicoPa
03-31-2002, 02:06 AM
Thanks for the exe.

I now too can the start multiplayer but also get the entities error shortly after starting a game.

Thats with an A7M266-D (MPX), WinXP and a GF3.

Can I ask you what you did you fix it? And indeed how you knew how to go about fixing it?

Is the entities error anything to do with your patch? (I dont think so)

WildManPiet
03-31-2002, 03:18 AM
Thank goodness I found you folks!

Before I list my rig, I must say that when I run Q3 with the SMP flag set to 1 it locks up, so I run with ony 1 cpu in quake3.

I have the same problem as kandyFlip at the same place.

rig:
Winderz 2000 (all the freaking online updates)
Tyan S2466 Tiger MPX mobo
Dual AMD 1800MP
2- 512Mb PC2100 ECC Registered pc2100 sticks
Radeon 8500 (NON OEM)

the rest doesnt matter I guess

raiden
03-31-2002, 06:19 AM
@JonRicoPa
well i just looked what causes the problem and found out that the games is killed because it trys to make a division by an divisior of zero ... so i disassabled the code and looked for a possibility to fix it -> which mean i replaced the division with a "nop" (no operation ... the cpu do nothing and continues with the next code).
thanks to the force the game runs after that little modification ... even if this is far away from any good solution.

and since other people have the entities error too i dont believe that it is caused directly by this modification.

cowwithoutbrain
04-01-2002, 01:18 AM
could this be possibly set as a sticky so that people may post if they have info on it?
also, i didnt bother checking but was that executable cracked (no-cd)? it works for a bit with bots, but as expected, i got the parse packet error.

dlsutton
04-01-2002, 02:31 AM
FWIW,

Same issues here.

Win2k SP2
512MB RAM
GF3-ti500

Tyan MPX Dual 1900MP

This SUCKS.

Need a fix.

Hope that they get this working soon.

-Dave

raiden
04-01-2002, 07:08 AM
@cowwithoutbrain

nope the exe is without no-cd crack.

Atomicone
04-01-2002, 08:52 AM
The error is obviously only for Athlons! no matter what other spec you're gonna have, it is just the athlons!

I get the same error with my Athlon 1600XP and Windows XP.

How stupid could Lucasarts/Raven could have been not to test this game with the world's most superior CPU chipset!?

randomNull
04-01-2002, 09:52 AM
Man I went over to a LAN party tonight and was gonna fire the game up for the first time on a LAN since my purchase and it drops to desktop after opening!!!! I am glad I am not the only one...please fix!!!
specs: Tyan Tiger MP 2460 | 2x1700+ XPs | 40gb and 20gb WD 7200s | 768MB Registered ECC 2100 DDR | GF3 Ti200 | 24x10x40 QPS | 16x AOpen DVD | SB Live 5.1 | Lian-Li 62USB 400w | 19' monitor | Dual booting XP Pro and FreeBSD.

raiden
04-01-2002, 01:06 PM
well it seems that the entities error is caused by modifying the jk2mp.exe ... so we can not play without the fix and we can not play for long with the fix ... and the best of all ... as a copy protection this feature has failed since there are no cd cracks which work without any modification of the exe ...

SYNERGiST
04-01-2002, 08:55 PM
Ok...

CPU: Dual Pentium III 1.4Ghz Tualatin 512Kb Cache
Mother Board: MSI Pro266TD Master LR
Ram: 512Mb
Graphic Card: Creative Geforce 2 GTS
Sound Card: Sound Blaster Live!
HD: Maxtor 60Gb

Running Windows XP

Before when i didn't have MS Visual Studio installed I didnt get an error just see the console detecting cpu... BANG back to windows
Now when i have MS Visual studio installed i get a error box:

The exception Integer division by zero.
(0xc0000094) occured in the application at location 0x00444c2e.

Hope they fix this error soon...

dijitel
04-01-2002, 09:03 PM
Tyan Tiger MP S2460
dual 1600 XP
512 registered crucial ram
leadtek geforce 3
windows xp

dijitel
04-02-2002, 12:24 AM
*bump*

WildManPiet
04-02-2002, 12:50 AM
Welp, nothing on the lucasarts site yet under support.

I find it funny that someone who ddint write the program and doesnt have the source code (Im assuming) got something to kinda work fairly fast and there is no fix yet from lucasarts.

GJ raiden! Maybe Lucasarts would like to hire you?

raiden
04-02-2002, 06:10 AM
@WildManPiet
nope i dont have the source code (unfortunatly).

so lucasarts/raven will have to get the hardware to find and fix the problem ... and of course many hours of testing :-).
but one problem remains ... everyone will have to use this update or else the only servers on which we can play are with "pure=no" and our own because even if the internal filecheck of the game is ok (the problem of my fix) we still have other versions than the rest of the world.
as a result of that they have to test it on every other hardware config ... not that this time the mighty amd760mp users are the only one who can play :D.

and when they make a update for everyone its possible that they take the chance and try to fix some other problemes ...

Atomicone
04-02-2002, 03:54 PM
bump.....oooo....excuse me post, sorry about that!

hey, if any of you guys find a patch or any more info, please post it here!

Cheers

Atomicone
04-02-2002, 04:02 PM
erm, for your information dudes, I get the EXACT same error, the weird thing is, I do not have dual CPU!

Athlon 1600XP
256 MEG DDR
Geforce GTS 2
k7t266 Pro 2 MSI Motherboard
Windows XP

And I get the exact same error as that windows XP screenshot above

raiden
04-02-2002, 06:10 PM
hmm it lookes like the cpu dectection code is really messed up ... so far we have the problem on dual amd/intel systems as well as on single amds ... well a little beta testing befor releasing a game shouldnt be that problem :-(

spoonwzd
04-02-2002, 09:40 PM
Yep same problem here too. Looks like an Athlon issue.

Win2k
2x AMD Athlon 1800+ MP
Tyan Tiger MP 2460
1Gb Registered DDR RAM
GeForce3

emorog
04-02-2002, 10:36 PM
Raiden, what's the address of the div 0 you found?
i'm guessing it's in the cpu speed calculation. (or possibly the cpu detect, but it's pretty much the same as Q3's, plus p4 code.) there is a divide in the cpu speed code, but it's dividing down the QueryPerformanceFrequency result. if that's failing, then the OS doesn't support the cpu.

was the div 0 here:
0044C2AB add dword ptr [esp+18h],esi
0044C2AF mov eax,esi
0044C2B1 div eax,ecx <----???

or here:

0044C2B9 inc esi
0044C2BA mov eax,edi
0044C2BC xor edx,edx
0044C2BE div eax,esi <---???

thanks,
with all of your input, we'll hopefully be able to fix this.

browneye
04-02-2002, 10:45 PM
I have the exact same problem as khankinsjr.

Single Athlon XP 1600
512MB Ram
GF3Ti200
Winderz XP Pro.

intoxxxicated
04-02-2002, 11:06 PM
I don't have the problem but a friend of mine does with his dual amd system.

2 Athlon XP's 1800+
Asus dual board (don't know the model #) 760MPX
512 MB RAM
Geforce 3 ti200
Also running WinXP Pro.

-XxX

intoxxxicated
04-03-2002, 03:16 AM
This one NEEDS a *BUMP*

-XxX

raiden
04-03-2002, 04:30 AM
@emorog

the first div by zero is at "00444C2E ... F7F6 ... div esi "
-> after relacing this one with 2 nop's i found 3 (all following in the same function) more:
"444CA0 ... F7F7 ... div edi"
"444CAC ... F7F7 ... div edi"
"444CBF ... F7F7 ... div edi"

hope this will help you guys to fix it :-)

@spoonwzd

SYNERGiST does have a dual intel system ... so its not an athlon issue.

spoonwzd
04-03-2002, 09:43 AM
@raiden

Yeah I saw that too, but he's the only one - possible pebkac issue with him maybe?

Atomicone
04-03-2002, 12:14 PM
SUPER BUMB!

Atomicone
04-03-2002, 12:16 PM
Originally posted by raiden
SYNERGiST does have a dual intel system ... so its not an athlon issue. [/B]

Maybe so, so why is affecting my single Athlon 1600XP?

raiden
04-03-2002, 12:36 PM
@Atomicone

well i have a tyan tiger mp board but i still using only one cpu (when time comes this will change and i will buy a 2nd xp) ... so maybe it is a problem of the chipset and not the cpu.
or maybe (i wouldnt be the first time) the os is causing the trouble by giving the game a wrong information about the system ...

Atomicone
04-03-2002, 05:15 PM
what ever the problem is, they should get it sorted, I am not changing my superior hardware just for them!

(a bumb in disguise)

raiden
04-03-2002, 06:00 PM
well everyone with an smp system should be able to fix this problem by changing the smp kernel to a uni processor kernel ... it helped me ... until the patch is out ...

ttungul
04-03-2002, 06:57 PM
Had to register and lost all the info I was looking into . But I copied and pasted the post that fits me the best:

erm, for your information dudes, I get the EXACT same error, the weird thing is, I do not have dual CPU!

Athlon 1600XP
256 MEG DDR
Geforce GTS 2
k7t266 Pro 2 MSI Motherboard
Windows XP

And I get the exact same error as that windows XP screenshot above

-----------------
I have 512 ddr ram myself, same mb, asus v7700 64mb gts pro. I have also examined the problem in several different ways, and i believe the person who disected the issues of subdivision, as the error details point to this conclusion.

Hope somoene posts the fix for this whoever get's it first. I played the SP game till I was done, no food, no sleep, total addiction, now it's time to conquer multiplayer hehe =)

ttungul
04-03-2002, 11:32 PM
Athlon 1600XP
512 MEG DDR
Geforce GTS/Pro 2 64mb
k7t266 Pro 2 MSI Motherboard
Windows XP

And I get the exact same error as that windows XP screenshot above.

blueicee
04-04-2002, 02:34 AM
i'm having the same problem too.

here is my setup:

Dual P4 Xeon 1.8 ghz procs
1 gig pc800 RDRAM
SuperMicro P4DCE+ mb with intel 860 chipset
Adaptec IDE RAID 2x80 gig hd's
Visiontek ti4600 geforce4

locks up when trying to run multiplayer at the detecting processors...

the patch seems to work fine, i wonder when lucas arts will release an official patch?

ciao.

pyroclasmx
04-04-2002, 04:43 AM
I posted this on another thread but figured i should put it here as well, as this was where i originally saw the problem I was having too ;)

Temporary Solution for MultiProcessor Users
Here is a temporary fix for anyone using dual processor systems which crash when loading the multiplayer game

Steps for Win2k / WinXP


1) Right Click on My Computer , click on Manage
2) Click on Device Manager in left side window
3) On right side click on plus sign next to Computer
4) You should see ACPI Multiprocessor System ( OR something similiar)
5) Double click on the ACPI Multiprocessor
6) Click on the Driver Tab and click on Update Driver
7) Click Next -> Click on dot next to "display a list of known drivers" -> Click Next Again -> Click on dot next to "show all hardware of this device class" -> Select ACPI Uniprocessor PC and click Next.
8) Before rebooting right click on my comupter again, click on Properties.
9) Click on the Advanced Tab, then click on the Enviormental Variables button.
10) in the bottom box locate NUMBER_OF_PROCESSORS, Double click on it and change Value to 1.

After doing this fix Jedi Knight 2 Multiplayer will run properly.


-(PK)- Chrono
pyroclasmx@pyroclasmx.com

PS - If this fix works for you drop me a hollar and a yay =D

JonRicoPa
04-04-2002, 07:49 AM
Emm, thats a nice idea and I appreciate the suggestion, but it does sorta defeat the purpose of having a dual CPU system. I only play Jedi Knight a little (maybe 10% of the time I am on the PC at the moment, and its that high because its a new game) and the rest of the time I want my two CPUs for the development and graphics work I do.

On top of that in Win2K changing the kernel in the fashion you describe produced many instabilities and problems that were sorta difficult to overcome without the dreaded format. Dont know what the XP situation is, but I am reluctant to try - I only got the dual CPU system a couple of months ago and dont fancy causing problems for a system that has been rock solid stable until now.

What dissapoints me is that no one from Raven has been into this thread and posted something to say that they are working on the problem. Then I would know that the situation is in hand at least.

Just my two cents..... (and a long bump :) )

raiden
04-04-2002, 08:23 AM
@JonRicoPa

emorog (also known as James Monroe) is from raven and they are working on the problem ... so a patch should be out soon.

mickrose
04-04-2002, 08:39 AM
Hello

how did you activate r_smp 1 in the game?

I have notice that there is no r_smp in the cfg file.
Then I tried during game but it tells me: "r_smp is read only".

Then I added +set r_smp 1 to the shortcut but nothing happenend???
How did you do it?

Thanks

Atomicone
04-04-2002, 08:44 AM
Good to hear it, do you know a specific place where we can keep watching for the patch? What URL? The official Jedi Knight II site is never updated.

Oh, I was looking for this topic on activision, it seems they do not have Jedi Knight II listed in their games, but just goto support, select the PC platform, then leave the games field as it is and search "jedi" and all the topics should come up, This one unfortunatly does not.

But if you are having any other problems, I suggest you consult that first. :)

raiden
04-04-2002, 09:02 AM
well you could try to add "seta r_smp 1" in the jk2mpconfig.cfg ... but since this is no official feature i wouldnt be surprised if doesnt work.

JonRicoPa
04-04-2002, 10:06 AM
@raiden and @emorog

Ooops sorry I did not realise that.

What I of course meant to say was that it is really good that Raven people are interested in the contents of this thread and solving our problem!

:)

sponz
04-04-2002, 10:46 AM
Just a morning bump. Can't let this get out of hand by them not doing something about it. We might be in the minority, but our computers define supperiority :D

piperfect
04-04-2002, 11:39 AM
If they are going to use the Quake 3 engine why wouldn't they use it's best feature? I tried editing the jk2config.cfg by adding seta r_smp "1" it still says that it is set to "0" in the game. I tried changing the the seta r_smp "0" to a "1" on the single player file with the same results. So much for for my Pestonias.

pyroclasmx
04-04-2002, 12:26 PM
This temp fix shouldn't corrupt your kernel, basically I only suggest using it to play, I love my dual proc system and running at full potential but i am also a gamer who enjoys playing games, you can always create a sepearte hardware profile for this fix. I'm not patient enough to wait for a patch when i'm going to a lan party this weekend to play this game specificially ;)

-(PK)- Chrono
pyroclasmx@pyroclasmx.com

RageFury
04-04-2002, 04:29 PM
Atomicone, you idiot, it is not AMD-only. Read through the damn posts, somebody had the IDENTICAL message with an Intel-based system. Also, the guy I spoke with at Lucasarts said he has seen this across every configuration you can think of, Intel and AMD. It just seems to happen mostly on AMD's he said, for whatever reason. Also, Raven made the game, they will be releasing the patch, keep an eye on the News on ravensoft.com, they may put an ETA out for a patch, or announce when they have it available, a little before Lucasarts would. Remember people, Lucasarts *PUBLISHED* the game this time, they didn't make it, unlike with previous Dark Forces/Dark Forces 2 games.

Ambience
04-04-2002, 07:09 PM
Umm can you please explain to me why it is beneficial to call anyone on the forums an idiot?

ru486
04-04-2002, 11:37 PM
Just wanted to say that I have two dual amd systems one is the 1.2Ghz and the other is the 1.4Ghz, one of them the 1.2 runs the multiplayer fine but the other one my main PC doesn't?

They are both running the same OS (XP) and have basically the same hardware one has geforce 3 and the other geforce 2.

I really hope they come out with something soon before my intrest moves on to other games.....

sponz
04-05-2002, 01:20 AM
Gotta keep this thread at the top so people don't forget about it. I don't like the fact that im 50 bucks out for a game I can't really use online yet.

Centrfuge
04-05-2002, 06:42 AM
READ THIS :)

aight guys... im no genious but this is what i did .

if you have 2 cd roms burn the cd and put it in both cd roms. then start the game and go to the "help" thingy on the autoexec menu. then choosethe install direct x. if it asks u for the cd then click it again. you may have to remove the cds and put them back in. keep doing until it says "direct x 8 successfully installed". upon seeing this message immediately start the game. go to multiplayer and SHAZAAAM! u got in now didnt u :)

if this solutions doesnt work for u, then go to start>run and type dxdiag which will bring you to the direct x diagnosis program. make sure all of your direct x utils are working properly. i got this to work on my tyan thunder w/ dual 1.2 mps so i hope it works for yall :)

have fun hacking,
the cent man

sponz
04-05-2002, 12:23 PM
Morning bump. Won't be able to test the "latest" fix till I get home. 50 bucks I tell ya...........walmart wouldn't let me return it either :evanpiel: and so I punched them in the eye. (just kidding, i didn't really punch them).

Demons
04-05-2002, 02:31 PM
I just noticed that AMD just released some new chipset drivers for the AGP (V5.33), IDE Busmaster(V1.43s), and Power Management(V1.22s). I know that this is not just an AMD related issue as there are a few people with dual Intel systems that are having the same problem but I thought that perhaps these new drivers (especially the new AGP driver) might make a difference for those of us with a dual AMD board. I'm not at home so I can't try it yet but someone with a dual AMD give it a go and post your results! THANKS! :) You can find the new drivers here...

http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_182_871_2336,00.html

Just look for the ones that say they were released in Mar 2002.

Soldiers Saint
04-05-2002, 04:24 PM
Well would you look at that! i'm not the only one with the problem.. exactly the same prob as everyone else.

Specs:

win2k
asus a7m266-D amd760MPX (dual)
2xAMD athlon MP1600+
512mb DDR ram (registered)

Great job sofar guys! hope you find a way to fix it (both to raven and the fans)

If know this isnt much help just posting my specs, but what else can i do?

---------------------------------
Luke, i am your sisters mothers husband! :rolleyes:

Centrfuge
04-05-2002, 07:15 PM
look at my post above to use dual processors :) ^^^^^^^

Stewart
04-05-2002, 07:24 PM
With all the stuff here we should see a fix soon! I've tried it on 3 different computer. My dual 333 Intel and a 1.13 Intel Laptop work perfectly, yet with a ton of "Connection Interrupted" Messages. The problem system is below.

Only way I get it to work is to set it up as a Standard PC in XP.
Btw, the DirectX trick shouldnt work in XP as XP comes with 8.1 and Direct X wont let you install an older version over a newer version.

Dual AMD Athlon 1800+ MP
Tyan Thunder K7 S2426
1024 Meg DDR Memmory
Geforce 2 MX400
Windows XP Pro

sponz
04-05-2002, 10:42 PM
Trying to run Directx setup on my computer dosen't work. Just locks the thing up for the most part. Causes me to have to reboot.

KandyFLip
04-05-2002, 10:55 PM
Well... I decided to try pyroclasmx's workaround. I changed W2K to the ACPI Uniprocessor kernel <shiver> and rebooted. I checked the task manager, and sure enough I wa only using 1 processor (ewwww). So, I proceded to run JO. Selected Multiplayer. Watched in amazement as it flew past the CPU check. Screen turned black. Screen turned Blue.

*** STOP: 0x0000000BE (0x80420004,0x00420121,0xB5356824,0x0000008B)
An attempt was made to write to read-only memory.

*** Address 80420004 base at 80400000, Datestamp 3ad7ad60 -ntoskrnl.exe

P.S. I'm not ungrateful or anything pyroclasmx. Thanx for the attempt :)

/me goes back to praying for an official patch.

ncaa
04-05-2002, 11:04 PM
We both have dual AMD MP 1800+s and we are having the same problem, but it could be our chipsets cause we are running tyan tiger MP s2460 boards. I am just glad to see that we are not the only ones. I hope this problem gets fixed soon, cause Jedi Knight II SP is awesome ;)

ncaa
04-05-2002, 11:05 PM
We both have dual AMD MP 1800+s and we are having the same problem, but it could be our chipsets cause we are running tyan tiger MP s2460 boards. I am just glad to see that we are not the only ones. I hope this problem gets fixed soon, cause Jedi Knight II SP is awesome ;)






System Specs:
2 AMD Athlon MP 1800+
Tyan Tiger MP
1024 PC2100 DDR RAM
Geforce4 ti 4600
3d Mark 2001: 9750
DVD ROM Drive
CDRW Drive
Firewire DVD-R Drive
20 & 80 GB HD 7200 RPM
Running Windows XP Pro.

sponz
04-06-2002, 02:20 AM
Im gonna be real mad if I beat the game in signle player and i can't play Multiplayer by that point. REAL mad.

HC - Exar Kun
04-06-2002, 02:37 AM
Athons and Windows XP dont seem to like running good together

Due to the fact that Microsucks used mostly
Intel processors to Make and Test XP

Multiplayer doesn't run very good (if at all) in JO for some reason

Especially on Athlon MP Dual CPU systems

I think that this is an Athlon XP issue with Windows XP....

After all they did make the Athlon XP
simply because the Athlons didn't work well on Windows XP

This will most likely be updated by AMD in the short future
( they're pretty good about this kinda stuff )

For now if you are running VIA or AMD Chipsets
Try getting the latest AGP and mainboard drivers
From your mainboard manufacturer....

VIA users will need the latest VIA 4 'n' 1 Drivers to play.....

raiden
04-06-2002, 04:54 AM
@HC - Exar Kun

well it is not a winxp vs athlon xp problem ... since i'm using win2k and get the same problems and we have some intel users also with the same problems.
This is a fine bug of the windows system kernel.

HC - Exar Kun
04-06-2002, 04:59 AM
Have you had this same problem in other games
such as MOH or Q3 at all ?

Centrfuge
04-06-2002, 05:45 AM
all u have to do is install direct x fromt the cd... it works i promise.
i play all the time on mp. u just have to make sure that it says "direct x 8 has successfully been updated on your computer" or something like that. works like a charm. if u cannot figure this out look at my above posts. you usually ahve to do it ever so often. it doesnt keep working. just do it if u fail during the stupid exe error junk. if u need a ss i can take one. :)

peace,
cent man

raiden
04-06-2002, 07:11 AM
@HC - Exar Kun

nope ... i did never had any problems with a game based on the q3 engine ...

Atomicone
04-06-2002, 08:13 AM
@HC - Exar Kun

Maybe you are right, about the Athlon that is!
But the Athlon XP, you are very wrong!
maybe windows XP is not made for it, but the Athlon XP is made for Windows XP, clever bastards they are AMD :D

(Bumb in disguise)

HC - Exar Kun
04-06-2002, 08:20 AM
Could be a great deal of things...

But yeah I beleive it may be an issue with AMD somewhere...

From what I read above you guys have tried just about everything I could think of to get it workin....


GOT ME STUMPED.....



:confused:

sponz
04-06-2002, 01:09 PM
Morning bumpage. Im now on the Docking bay level. Dunno how many more I have to go before someone from Raven/Lucas arts/whoever posts that yes, this IS a problem and they officially acknowledge it as such. Not much to ask for. The thread is burning up in the forum, BOAT loads of views, lots of response. Maybe if we hit the 30k post mark someone will say "hey, I think they have a problem!". Argh. Im frustrated. I WANT to play multiplayer!!!! ARGH!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!

MadMorg
04-06-2002, 10:12 PM
Exar, it's not an AMD issue, look at the posts on here, there have been a lot of people who have been complaining of this trouble on dualie intel rigs...

And it is not an issue with windows XP, because there are as many people that are having this problem on win2k (such as myself). It's an issue with the detection of the dual processors... (except for those problems with the single athlonXP's, I don't know how to explain that...)

But there have been people that have been running the game with uniprocessor ACPI, so it would seem obvious that it's a dualie issue... something that can be worked around since the single player version works with dualies...

just my $0.02

VooDooo
04-06-2002, 10:24 PM
Originally posted by HC - Exar Kun
[B]Athons and Windows XP dont seem to like running good together

Due to the fact that Microsucks used mostly
Intel processors to Make and Test XP


Wrong. AMD's were used extensively and are x86 complient in every way. The code in XP is also optimised for 3Dnow and 3Dnow Pro. Athlons and WinXP work without issues as long as you use te correct drivers. (Which is exactly the same as Intels CPU's) A lot of the systems that MS used were actually Alpha's as the current CPU's were too slow to compile the code. They tested the final code on 1000's of differant platforms. Im not saying XP is perfect but to say XP and Athlons dont work well is Wrong.



I think that this is an Athlon XP issue with Windows XP....

After all they did make the Athlon XP
simply because the Athlons didn't work well on Windows XP

This will most likely be updated by AMD in the short future
( they're pretty good about this kinda stuff )


If your going to offer advise at least get it right. All AMD proceessors work in XP. The new Palomino cores (1600+ and higher) were named XP's for marketing and it has nothing to do with there XP compatability at all. All Athlons actually beat the crap out of intels similar offerings and have ever since the Slot A 500mhz.


For now if you are running VIA or AMD Chipsets
Try getting the latest AGP and mainboard drivers
From your mainboard manufacturer....

VIA users will need the latest VIA 4 'n' 1 Drivers to play.....

Yes here i do agree with you. Updated Drivers for ALL your hardware is always advised. Ive been testing this error in over 12 differance platforms to get it working (i run dedicated servers for an ISP) I can confirm its definatly a Dual CPU issue with both Intel and AMD but the problem does show up on some single CPU AMD systems with XP. The error it seems is due to JK2's detection of the CPU's. Ill be getting a Xeon with hyperthreading soon to see if that has issues as well

blueicee
04-07-2002, 01:04 PM
I have a Prestonia with Hyper-Threading enabled and yes, there is a problem. i posted my system specs above. i tried turning off Hyper-Threading it worked one time. when i exited and went back in, it would no longer run in MP mode. single player mode works well in all cases.

sponz
04-07-2002, 10:54 PM
Sunday night bumpage. How bout a response from our friends at Raven now?:rolleyes:

raiden
04-08-2002, 11:01 AM
well i have made a second fix.
http://www.htwm.de/~sdoempke/loader.rar

my first fix did not work because the filecheck&memory check at the beginning noticed that the file has been changed (-> entities problem).
now i'm using a loader which waits 80ms and then modifies the file ... just in time before the div by 0 comes ...
i havent tried it too long but it seems to work ... but it is possible that the timing isnt perfect.

hope this will help out until the official patch is released.

sponz
04-08-2002, 11:12 AM
Good job Raiden. I will try the fix when I get home from work (shortly). I respect the fact that a consumer is working on a product that other consumers have spent lots of hard earned money on, and the company that created it won't acknowledge the problem. (notice the frustration here)? If your patch dosen't work, im gonna take the game to walmart, then Im going to ask if I can return it. If they will not let me return it, I will then proceed to break it into MANY MANY small pieces and just leave it on their customer service counter. I wasted 50 bucks on a game and I'd get more enjoyment out of breaking the damn thing than I will playing it!:D

I can't seem to download your fix either. U sure you got the link right? *prays that your fix works*

Once again, I applaud the job you have done, and the fact that you have given others a sense of hope that it can be resolved soon.

raiden
04-08-2002, 11:20 AM
@sponz

hmm the link should work ... well he works for me :-| .

and i had worked with emorog (he is from raven) to fix the problem ... dont know why it takes so long to release the fix but i guess they want to make a big patch which solves some other bugs too.

sponz
04-08-2002, 12:38 PM
Raiden, Ok, downloaded it at home (prolly due to some DNS issues that I couldn't download at work). Giving it a try now...we'll see. I will report back with my findings shortly.

sponz
04-08-2002, 01:59 PM
Ok. Couple of things for everyone out there. The loader file worked great on my machien so far. I played from the time of my last post to this post. Quite a while. Not a single problem. Looks like you might have gotten whatever the problem was fixed. Or atleast bandaged up. Good work to you!

below_average
04-08-2002, 06:24 PM
:biggs: :biggs: :biggs: :biggs: :biggs:



It works fine in Single Player mode. If I try to play Multiplayer my system crashes. I get a "Windows XP has encountered an error" message right when the game engine tries to initialize/detect my CPU.

Here is my system config:

Dual Processor AMD Athlon MP 1600+
Tyan Tiger S2640 AMD 760 MP
256MB PC2100 DDR
3.5" HD FDD
30.7 GB ATA-100 IBM 7200rpm HDD
ATI Radeon 8500 64MB DDR
Windows XP Professional
Adaptec 2940UW
Toshiba SCSI CD-ROM
Pioneer SCSI CD-ROM
Creative Labs 2X EIDE DVD-ROM
D-Link DFE-530TX

Any ideas why I can play single player fine but not the multiplayer version?

wth?

ru486
04-08-2002, 07:11 PM
patch didn't work for me I still get ParsePacket error.....

JonRicoPa
04-08-2002, 09:59 PM
Works like a charm for me. I am finally playing multiplayer and I have to say that it looks really good!

Thanks a lot raiden. I really appreciate the effort you must have put into this.

JonRicoPa
04-08-2002, 10:03 PM
to below_average - I take it that you have tried raiden's patch?

to ru486 - You need to make sure that you have restored the mp exe to the same version as came with your original cd. If that fails to work then you probably have a timing issue with raidens patch.

Just some tips and info in case you guys have not tried that yet.

sponz
04-08-2002, 10:56 PM
Ok, just another update. I can't confirm it yet, but something to consider. I did get a packet error (standard message) with raiden's update. It was off of a Linux server. I got the error twice, but I know for sure that only one was a linux server. But, i was able to play for too long (several hours before going to my microsoft active directory class). heh. wonder if something is different between linux/w32 servers...

khankinsjr
04-09-2002, 12:06 AM
Raiden, just wanted to thank you for taking the time to help fix the problem with Multiplayer lauching. It works great! I am greatful...Many frustating crashes later...heheh...Thanks again...

KandyFLip
04-09-2002, 12:18 AM
raiden! I love you man! errr... I think hehe I only played for about an hour.... but I PLAYED FOR AN HOUR!!! You rock. Thanx a lot.

uclajeff
04-09-2002, 03:11 AM
Raiden's patch worked for me too.
You have my thanks Raiden!

jingram
04-09-2002, 03:15 AM
Well I too have been searching for information on this strange crash. I own a duallie 933 P3 system and a slew of other boxes. I use my p4 1.6a for most of my duties. This is what I have come up with. I have yanked sound cards, nics, ram, power supplies, anything and everything that I can think of that might result in an instability. In my case I think that the MP looks for a legitimate processor type. If it detects one then all is golden, if not, then it errors out with the message we have all seen. MP works fine for me when I run my chip at its rated speed. If I bump it 50mhz up however, it dies. This is a chip that previously to this game has been crunching prime for 3 weeks straight and has been through endless loops of 3dmark 2001 SE, sandra burn in, seti, prime, wolfman demo, etc. all at 2.4ghz. The setup is as stable as can be with no quirks and no downtime. Now, it COULD be related to Multiprocessing. I noticed in my bios that I had a MIPS setting, which I found to be quite strange for a single proc board. My only thought was that it must be a setting for use when hyperthreading becomes mainstream. Since I always used 1.1 on my p3 duallies, that is what I set this board to and let it go about its way. Well since then, I have reformated this box twice now because of this game and tested just about every setting, piece of hardware I can think of. New video cards, sound cards, nics, ram, motherboard, have all been through the ringer. Still no dice. Not sure exactly is wrong with the MP implementation compared to the SP implementation, but something is drastically wrong. Oh, one more thing. The parse errors you see are because you have installed on of the no cd cracks. I thought that maybe the CD was screwing things up so I tried cracking mine. Still no dice. At this point, I have given up on MP.

Rgds,
Jack Ingram
Network Manager
PTB Corp.

R5D4
04-09-2002, 07:58 AM
Oke i will give raiden's fix a try on my system:

Tyan Tiger MP
dual Athlon 1600+
256MB
Win2k SP2
40GB Maxtor 7200RPM

Tracker00
04-09-2002, 09:54 PM
I'm not using the no cd crack, but I still get the parse error. Anyone else have this problem?

Originally posted by jingram
The parse errors you see are because you have installed on of the no cd cracks. I thought that maybe the CD was screwing things up so I tried cracking mine. Still no dice. At this point, I have given up on MP.

Rgds,
Jack Ingram
Network Manager
PTB Corp.

Nicao
04-10-2002, 02:13 AM
Hmm interesting, the box that I am sitting at right now (at work) runs jk2 fine. Both Mulitplayer and single player. Here are the system specs.

Tyan Tiger MP
2x 1.2Ghz Athlon MP
Geforce 4 Mx 440
Sb 128
Win 2k SP2

I'm sure you guys have flashed your bios for this board (there have been a few important flashes) and are using the right drivers such as the Amd agp driver and whatnot. I'm not sure what what makes my system different but it works fine here.

raiden
04-10-2002, 04:00 AM
@Nicao
well it looks as if this problem doesnt exist on cpus with an lower frequency even if 1200mhz are not too far away.

@Tracker00

could you give some infos on your system ...

Rend Flesh
04-10-2002, 04:39 AM
Originally posted by raiden
well i have made a second fix.
http://www.htwm.de/~sdoempke/loader.rar

my first fix did not work because the filecheck&memory check at the beginning noticed that the file has been changed (-> entities problem).
now i'm using a loader which waits 80ms and then modifies the file ... just in time before the div by 0 comes ...
i havent tried it too long but it seems to work ... but it is possible that the timing isnt perfect.

hope this will help out until the official patch is released.
First, thanks raiden. I was able to play for about 45 minutes. MP locked up after that. I havn't been able to play MP at all until now. I get the same crash as everyone else does.
my system:

Dual Processor AMD Athlon MP 1900's
Tyan Tiger S2466N AMD 760 MPX
1GB Corsair PC2100 DDR
2x 100 GB ATA-100JB Western Digital HD
GeForce 2 GTS 64MB
Windows XP Professional
Lite-ON 163B DVD
Plextor 12/10/32A CDRW

Rend Flesh

R5D4
04-10-2002, 12:34 PM
Oke i can play, so many THANKS, but after same time i also get those errors :(

what causes those errors??

raiden
04-10-2002, 04:34 PM
@R5D4

well this parse error is caused by a modification of the file ... to make sure nobody is able to cheat by altering the game.
unfortunatly i have to come after the filecheck and before the div by 0 ... the loader try to do this by waiting some time befor he alters the code ... but since every system runs at a different speed this doesnt have to work every time :-(
i will try to find a way to fix it.

Tracker00
04-10-2002, 08:46 PM
Thanks raiden, here are my system specs:

Asus A7M266-D BIOS 1005
512 mb RAM
2x Athlon XP 1700+
WinXP

raiden
04-11-2002, 05:56 AM
okey here is a 2nd loader for everyone who have those parse entities problem with the first one ... since this one dont use a timer (so it should work for everyone at the right moment) and most importent he doesnt even modify the code so there shouldnt be any reasons for the file protection to stop the game (well i hope so).

http://www.htwm.de/~sdoempke/loader2.rar

use this one like the old ... put it in the same directory like the unmodified jk2mp.exe.

JonRicoPa
04-11-2002, 09:42 AM
Thanks again raiden.

If you dont modify the code, how does this new fix work?

raiden
04-11-2002, 10:12 AM
@ JonRicoPa

well the game does have a backup cpudetection (which is very inaccurate but works on the smp kernel) for the case that the os doesnt support features that are needed to run the standart one.
and in the code he jumps to the standart one if everything is ok ... but i dont let him jump (so that the backup is used) by setting the instruction pointer to the next instruction when he reaches the instruction line of the jump (so that the jump instruction will not be executed).
so the code is never touched ... only the execution has changed for one short moment.

R5D4
04-11-2002, 01:04 PM
Oke thanks for ya efforts man !!! could you not go work at lucasarts????m :D

maybe you could also look why Redalert2 and Emperor battle for dune ain't workin on a dual AMD system

Atomicone
04-11-2002, 03:49 PM
Lucasarts? This dude could be doing bigger things than that, infact he probably is!

Cheers dude! The hack works great!

Who's up for some Duelling??? :D

blueicee
04-11-2002, 10:43 PM
well, loader2 let me play for about 1 minute before it kicked me to the desktop. ever since it kicked me out, i get to select the server, it then loads up and immediately exits back to the desktop. have to reboot to be able to play for 1 minute, then repear the above.

my system specs are posted above.

i still cannot believe there hasn't been a patch from ravensoft or lucasarts for this. actually, i cannot believe this made it through QA.

ciao.

Kreidian
04-11-2002, 11:44 PM
Well, I've been having this exact same issue. I'll add my experiences, at the very least it'll help keep this thread up top. :)

My system:
Dual 1.2GHz Athlon MP
512M RAM
GeForce4 Ti 4400
SB Audigy xGamer
WinXP Pro

I did try doing the kernel fix suggested early on this thread, it worked but I didn't like using only a single CPU. When I tried to change it back to the dual CPU setting it screwed up my system really bad. I have it working fine now, but I can't seem to get it back to the dual CPU kernel.

Once I do that I will definately try raiden's loader2 to see if that fixes it.

The few times I got multiplayer working I had a blast! gotta Love that sabre dueling! I hope Raven releases that patch soon.

sponz
04-12-2002, 12:02 AM
The little bit of time I have had spare this week, the game has worked flawlessy with Raiden's patch.

apco25
04-12-2002, 02:45 AM
Hello,

I have been reading about the loader mod. I cannot find in the Forum, how to use it? Maybe I missed it. Could someone post the procedure? I am excited to try it!!

Thanks to all.
apco25

apco25
04-12-2002, 02:56 AM
I had the same Problem in XP. I could not get Dual Processors working again. There are two ways to fix it.

1). (Best) - Click on My Computer and Press F1. Go to system restore. If you are lucky and have a restore point before going to single processor. You can restore it. After getting to Dual, I manually make a restore point. Then I can switch back and forth between Dual and Single processors. Back up your JKII saves and config rules! It will "restore" those as well.

2). If you changed the way your restore points are made or don't have a good restore point. Install windows XP. Then when it asks for SCSI devices (F6) Press F5. If you need SCSI drivers press F6 after F5. You will then be asked for the Hal type. You will need to scroll to the setting (I believe PG up/DN). Select Dual ACPI or whatever works for your system.

Then Click fix installation. I think you will have to re-install the XP web updates but not your programs.

I hope this helps.

apco25@yahoo.com

Kreidian
04-12-2002, 05:25 AM
Actually apco25 I was able to fix it. Just like you suggested. I used system restore and it fixed the problem. :)
(sometimes I just LOVE XP)

I made a manual restore point but I don't plan on using it to go back and forth, I just picked up raiden's loader2 and it works perfectly with that. With both processors enabled. :D

Raiden, you're awesome!!

This is definately something that needs to get fixed in the next patch. BTW, apco, if you're still looking for that loader file, raiden posted a link to in on this very thread. You might need to go through the whole thing to find it though.

raiden
04-12-2002, 08:19 AM
@blueicee

http://www.htwm.de/~sdoempke/loader2e.rar
this one should print the error on the console (of the loader) ... could you try it and post the results please (set the game to 640x480 windowed mode).

blueicee
04-12-2002, 08:06 PM
ExceptionCode:80000003
EAX:77FC6423 ,EBX:7FFDF000 ,ECX:00000002 ,EDX:77F77004
EDI:00141EB4 ,ESI:00141EB4 ,EBP:0231FC2C ,EIP:77F7F571 ,ESP:0231FB38
DR0:00444B07 ,DR1:00442DDE ,DR2:00000000 ,DR3:00000000
DR6:FFFF8FFC ,DR7:00000505
FPU-CONTROL:FFFF027F ,FPU-STATUS:FFFF0000 ,FPU-TAG:FFFFFFFF
FPU-ERROROFFSET:00000000 ,FPU-ERRORSELECTOR: 00000000
FPU-DATAOFFSET:00000000 ,FPU-DATASELECTOR:FFFF0000
FPU-NPXSTATE:00000000
Backup CpuDetection says 1764 MHz (its very inaccurate)
HERE COMES A NONCONTINUABLE EXECEPTION !!!
ExceptionCode:E06D7363,ExceptionType:UNKNOWN EXCEPTION
EAX:0231B6C4 ,EBX:00000000 ,ECX:00000000 ,EDX:00B04F98
EDI:0231B754 ,ESI:0231B754 ,EBP:0231B714 ,EIP:77E6D756 ,ESP:0231B6C0
DR0:00000000 ,DR1:00000000 ,DR2:00000000 ,DR3:00000000
DR6:00008002 ,DR7:00000000
FPU-CONTROL:FFFF027F ,FPU-STATUS:FFFF0020 ,FPU-TAG:FFFFFFFF
FPU-ERROROFFSET:02B7F9C4 ,FPU-ERRORSELECTOR: 00C3001B
FPU-DATAOFFSET:0231A6EC ,FPU-DATASELECTOR:FFFF0023
FPU-NPXSTATE:00000000
Press any Key to exit

raiden
04-13-2002, 06:31 AM
well thats the exception for the parse entities message ( the loader is the reason that the game just goes down instead of showing the message ... will try to fix this) .

damnit ... loader2 doesnt even modify the code he just jumps over one instruction ...

are you sure the you are running the unmodified exe from your jk2 cd ... unfortunately there are some people on the forum who say that they are got the same error without any hack or nocd crack ... so its possible that the loader still causing trouble or it is the game itself :-(

Atomicone
04-13-2002, 08:49 PM
**Everyone waits patiently for Raiden's new loader!

**While at the same time they thank Raiden and praise Raiden!

Astridar
04-14-2002, 12:40 AM
Same problem...

Tyan Thunder 2462MG
2 x Athlon MP 1800+
4 x Crucial PC2100 256MB
Promise Raid & 2 x 60gb HDD
bla bla bla

Loader 2 caused a BSoS in Win2K Server (all patches & sp2)
Loader 2e Works perfectly. Excellent Job Raiden

aicjofs
04-14-2002, 02:06 AM
Thanks Raiden. I appreciate your efforts. It's good work and seems to have helped alot of people.

First loader works fine on my system, I can play for hours without problems. However if I change too many options for the server the game will get packetparse error about 2 min into the game. This is fixed with a reboot(which is acceptable at this point). Haven't tried loader 2 yet.


Probably not needed anymore but:

2 1900+ XP, 256MB
Asus A7m266D BIOS 1.05
Orignal Geforce DDR
2x 1200BB WD Raid 0
Audigy

raiden
04-14-2002, 08:04 AM
ok here is the new loader:

http://www.htwm.de/~sdoempke/loader2f.rar

now everyone should get the correct error message in the game (like no cd found or parse entities ...) instead of just returning to the desktop.

Astridar
04-14-2002, 06:42 PM
Perfect! Before Loder2f I was unable to return to the main menu, if I tried the game would lock up & I had to end task. Now it works perfectly. You have totally eliminated the need for a patch for me. You are the MAN@!@! Lucas need to give you a job for this one Raiden...

warer
04-18-2002, 07:09 AM
Thanks Raiden. Now the game works.
Sent a email to support, they told me that they were working on the problem and that they will soon find a solution for it :)
Who cares, your loader 2f work perfectly + you get to see error msg :)

Heeroyuy
04-18-2002, 07:26 PM
Amd twin 1.2 ghz, tyan thundered k7 with mp760 chipset
prophet 3 - geforce 3
game theater xp - sound
512 mb ram
win xp gold - all updates

my computer will load into single player fine, and ever once in a while it will actually load into a multiplayer game, unfortunatly i run the multiplayer game for a few seconds and it crashes, somthing about parsepacketserver or somthing to that affect. but it does load, 1 in about 25 or 30 tries. the rest of the time it crashes after detecting amd chipset with 3Dnow! tech. i hope they fix this crap soon, the few second i have gotten to play thus far show it to be an awesome game.

hyped1
04-19-2002, 12:04 AM
Raiden, I had been running JK in single player and liking it then I tried to run multiplayer and was having the same problem everyone else had been experiencing! :-( Then your patch saved my Dual system blues and offered me a reason to live. I was damn near taking a lightsaber to my computer and cutting off a cpu! Thanks again for the patch dude it kix azzz!:fett:

Astridar
04-19-2002, 03:22 AM
Incidentally Raiden, what language did you write the loader in, and how would you feel about releasing the source GNU/Open Source?? This is a great example of fine coding, and I think that those of us who do code would benifit greatly from your knowledge. Just a question/suggestion... Thanks again for the expertise bro!!

raiden
04-19-2002, 07:12 AM
@ Astridar

the loader is written in c (with ms vc++ 6.0 standart).

you can get the src here: http://www.htwm.de/~sdoempke/loadersrc.rar

well i would say that the most difficult part for programming this loader was to find good documentation for the win32 kernel api (what is available and how to use it).
a good resource is:
http://msdn.microsoft.com/library/default.asp

R5D4
04-21-2002, 07:35 PM
Oke on to the next games :D RedAlert2 and Emperor Battle for Dune are also a NOGO on a dual AMD system

Tracker00
04-21-2002, 08:38 PM
can someone email the loader at tracker00@cox.net? the link doesn't seem to be working. thanks

sirbakk
04-23-2002, 04:01 PM
same for me
satch.nico@wanadoo.fr
or just repost a good link please..
please please please please.:( :( :(

raiden
04-23-2002, 04:36 PM
the server is up again ... so the links should work for everyone.

mtremel
04-24-2002, 01:10 AM
Hi, just wanted to say thanks for the fix...
I too have been faced with this terrible problem...
Asus A7M266-D
2x Xp1600
1gb Mushkin 222 level2 ddr
Herc GF3 64mb

all your loaders work on my system...

Thanks =)

RoobyRoo
05-03-2002, 03:38 AM
I didn't want this to be another "Raiden rocks!" reply but damnit, Raiden you rock. It's great to see somebody who contributes their knowledge for the greater good of those with "superior hardware". By the way I had the same problem:

Win XP
Tyan Tiger
Dual 1800xp's
ATI 8500

Matrix905
08-19-2002, 05:05 AM
Hi Raiden,

I tried your Loader2f file it seemed to get me past the initial jk2 mp console problem I was having but not it just stalls me on this white screen. The task manager says teh program is running... but I don't get the game...

I just copied the loader file into the same directory with jk2mp.exe and then ran it. ( is this wrong?)

I also got this error " This application has failed to start because MSVFW32.dll was not found. Re-installing the application may fix this problem."

and it also read as such in your loader window:

ExceptionCode:80000003,ExceptionType:EXCEPTION_BRE AKPOINT
EAX:77FC6423 ,EBX:7FFDF000 ,ECX:00000002 ,EDX:77F77004
EDI:00141EB4 ,ESI:00141EB4 ,EBP:0231FC2C ,EIP:77F7F571 ,ESP:0231FB38
DR0:00444B07 ,DR1:00442DDE ,DR2:00000000 ,DR3:00000000
DR6:FFFFAFF6 ,DR7:00000505
FPU-CONTROL:FFFF027F ,FPU-STATUS:FFFF0000 ,FPU-TAG:FFFFFFFF
FPU-ERROROFFSET:00000000 ,FPU-ERRORSELECTOR: 00000000
FPU-DATAOFFSET:00000000 ,FPU-DATASELECTOR:FFFF0000
FPU-NPXSTATE:00000000
Backup CpuDetection says 1098 MHz (its very inaccurate)
Press any Key to exit


any ideas?

if you need to know what I'm running it's:

Tyan Tiger MPX
2X AMD 1600+ MP
Visiontek GF4 Ti 4600
512 MB Ram


Thanks!!!, I really appreciate what you're trying to do for everyone

Demons
08-19-2002, 03:06 PM
You know this problem with Dual CPUs is fixed with the latest patch from Lucasarts/Raven. The loader is no longer needed. It was fixed with 1.03 and the current patch is 1.04. You can get it here:

ftp://ftp.lucasarts.com/patches/pc/JKIIUp104.exe

Again, thanks to Raiden for getting us a fix before the patch came out!

-Demons

Kusuru
12-27-2005, 12:59 AM
3 years later, but I still have the same error. Can anyone send me the link to one of those loaders? Or do I download something else now?

EmPerfectCror
12-31-2005, 11:35 AM
HOLY THREAD RESURRECTION BATMAN!

acdcfanbill
01-01-2006, 09:02 PM
well do you have 1.04?

dumbledore
02-09-2006, 10:27 PM
i do, but half the servers don't :naughty: :: :giveup: :indif:

raiden
02-17-2006, 04:22 PM
Ok here is a working link again -> http://www.megaevil.org/loader2f.rar

Unfortunatly this link will only work for some days before i have to remove the file. So any suggestions for an alternative place where i can put this file are welcomed.

Bas
04-10-2006, 04:02 PM
Ok here is a working link again -> http://www.megaevil.org/loader2f.rar

Unfortunatly this link will only work for some days before i have to remove the file. So any suggestions for an alternative place where i can put this file are welcomed.

Please send me the patch via email.....
I will host it for you so it can be downloaded if the traffic isn't that horrible :lol:

I have my own hosting company, www.plaingoodhosting.com , so I can do it for you.

Bas.

raiden
04-12-2006, 02:10 PM
Here is a new link to the file -> http://forum.msi.com.tw/bas/loader2f.rar

Bas has been so kind to put this file on his webserver @ www.plaingoodhosting.com.

roffle
06-21-2008, 10:40 AM
Hi, Raiden (and everyone :)) first of all i want to say sorry to everyone for rescuing this thread 2years after it was last posted on ! (But im in need of Help ! :D)

However i am in need of your fix specifically. The patching (from raven/lucas) works all well and fine, BUT i ONLY play jk2 to play No Force/Saber Only CTF. And as every server on the orginal patch is this (1.02) and as far as i know (i did check) i couldn't find a single server i wanted on EITHER version of the patches.

Which brings me to my problem...(a similar problem to Matrix905). Your fix works perfectly getting me past the console bit of the load up, however i then am just left with a white screen and i dont actually get to the game itself. The game is running in task manager and everything but i cant actually play it when i end the game in task manager i am left with this from your loader:

ExceptionCode:80000003,ExceptionType:EXCEPTION_BRE AKPOINT
EAX:00141EB4 ,EBX:7FFD5000 ,ECX:00000002 ,EDX:00000004
EDI:00141EB4 ,ESI:00141F48 ,EBP:0231FC94 ,EIP:7C901231 ,ESP:0231FB20
DR0:00444B07 ,DR1:00442DDE ,DR2:00000000 ,DR3:00000000
DR6:FFFF0FF0 ,DR7:00000505
FPU-CONTROL:FFFF027F ,FPU-STATUS:FFFF0000 ,FPU-TAG:FFFFFFFF
FPU-ERROROFFSET:00000000 ,FPU-ERRORSELECTOR: 00000000
FPU-DATAOFFSET:00000000 ,FPU-DATASELECTOR:FFFF0000
FPU-NPXSTATE:00000000
Backup CpuDetection says 2364 MHz (its very inaccurate)
Press any Key to exit :confused:

Any ideas mate i would really really appreciate anyones help on this matter.

You can also contact me: daniel1815@merseymail.com OR anybody has xfire / msn you can add me Xfire: scouser07 / msn: EFC_06@hotmail.co.uk

btw if you need to know im running:

Asus P5K SE Motherboard
Quad Core (Q6600 @ 2.40Ghz)
2 GB RAM
GeForce 9750 GT 512MB

Thanks in advance to anyone that is willing to offer their help :(

aka_mustang
03-26-2009, 11:40 PM
Any change to get this working with jk2Ded.exe?
I tried re-naming it to jk2mp.exe, but no luck
I tried adding "seta dedicated 2" to jk2mpconfig.cfg and launching with the original jk2mp.exe, but it gives a non-continuable exception

P.S. I'm trying to get jk2 to run as a dedicated server on a Xeon quad core

M@RS
03-27-2009, 12:05 AM
Any change to get this working with jk2Ded.exe?
I tried re-naming it to jk2mp.exe, but no luck
I tried adding "seta dedicated 2" to jk2mpconfig.cfg and launching with the original jk2mp.exe, but it gives a non-continuable exception

P.S. I'm trying to get jk2 to run as a dedicated server on a Xeon quad core

Be sure not to bring back an old thread... Or you'll get a warning by a mod... ;)

aka_mustang
09-15-2009, 07:21 AM
Be sure not to bring back an old thread... Or you'll get a warning by a mod... ;)
Sure, however seeming there are lots of old threads
Better to reply to an existing thread than start a new one with the same question
And get told to use search before starting a new thread
If it's not locked, it's fair game IMO