PDA

View Full Version : Bizarre skinning problems -- game crashes


Prox Kolari
04-03-2002, 02:10 AM
I've followed the Raven tutorial to the letter -- right down to the Lando model -- with no luck. Let me tell you what goes on in detail, but the problems I'm having are the game crashes and complains about something not being available at compile time, or the game crashes when I go into setup, or the icon showing up in the list of skins in-game, but not ever appearing while playing.

1. Open up assets0.pk3. Extract everything in the models/players/chiss directory, retaining subdirectories. I'm using WinZip.
2. Modify one image in PS (the face). Save with different name (for chiss: "base_test_prox.jpg").
3. Rename every other .jpg to "whateveritis_prox.jpg".
4. Change name of .skin file to model_default_prox.skin.
5. Edit skin file so all things point at their respective newly-named jpgs.
6. Change icon to icon_default_prox.jpg.
7. Zip it up into "prox.pk3" with subdirectories intact. Opening this file shows me that indeed all files are still under models/players/chiss.
8. Put in JK2's /base directory.
9. Game crashes.

I downloaded the Darth Maul skin -- it works fine as is. What's the difference between his and mine? I'm going to alter the Darth Maul skin and see if it fails then.

Danica
04-03-2002, 02:12 AM
could it possibly be the renaming of your model_default.skin file? I never renamed mine and my skins worked fine!

Prox Kolari
04-03-2002, 02:23 AM
Didn't work, still crashes.

I also noticed that the Darth Maul skin I thought worked fine actually doesn't. In game, it doesn't show up at all. So the better question may be, why don't any skins work for me?

In fact, if anyone cares to wade through it, here's my console output after the crash.

========================================
JK2MP: v1.02a win-x86 Mar 3 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\prox2.pk3 (9 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\DarthMaul.pk3 (15 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

----------------------
14709 files in pk3 files
execing mpdefault.cfg
execing jk2mpconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\SYSTEM\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...62 PFDs found
...hardware acceleration found
...PIXELFORMAT 8 selected
...creating GL context: succeeded
...making context current: succeeded
Initializing OpenGL extensions
...GL_S3_s3tc available
...GL_EXT_texture_compression_s3tc available
...no tc preference specified
.....using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_env_add
...GL_EXT_texture_filter_anisotropic available
...using GL_EXT_texture_filter_anisotropic
...Using GL_EXT_texture_edge_clamp
...using WGL_EXT_swap_control
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...using GL_EXT_point_parameters

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce3/AGP/SSE
GL_VERSION: 1.3.0
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_transpose_matrix GL_S3_s3tc GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_cube_map GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_vertex_weighting GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_evaluators GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_packed_depth_stencil GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_WIN_swap_hint WGL_EXT_swap_control
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_ACTIVE_TEXTURES_ARB: 4

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(8-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU: Intel Pentium III
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
texture bits: 0
lightmap texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: enabled
compressed lightmaps: disabled
texture compression method: GL_EXT_texture_compression_s3tc
anisotropic filtering: enabled
Initializing Shaders
...loading 'shaders/bespin.shader'
...loading 'shaders/cinematics.shader'
...loading 'shaders/common.shader'
...loading 'shaders/decals.shader'
...loading 'shaders/doomgiver.shader'
...loading 'shaders/effects.shader'
...loading 'shaders/explosions.shader'
...loading 'shaders/flares.shader'
...loading 'shaders/fogs.shader'
...loading 'shaders/gfx.shader'
...loading 'shaders/gfx2.shader'
...loading 'shaders/imperial.shader'
...loading 'shaders/items.shader'
...loading 'shaders/marks.shader'
...loading 'shaders/metashader.shader'
...loading 'shaders/models.shader'
...loading 'shaders/mp.shader'
...loading 'shaders/nar_shaddaa.shader'
...loading 'shaders/players.shader'
...loading 'shaders/sabers.shader'
...loading 'shaders/scavenger.shader'
...loading 'shaders/skies.shader'
...loading 'shaders/sprites.shader'
...loading 'shaders/system.shader'
...loading 'shaders/test.shader'
...loading 'shaders/text_crawl.shader'
...loading 'shaders/ui.shader'
...loading 'shaders/yavin.shader'
...loading 'shaders/zoom.shader'
----- finished R_Init -----

------- sound initialization -------
Initializing DirectSound
locked hardware. ok
------------------------------------
----- Sound Info -----
sound system is muted
1 stereo
32768 samples
16 samplebits
1 submission_chunk
22050 speed
0xe042f000 dma buffer
No background file.
----------------------
Sound memory manager started
Loading vm file vm/ui.qvm.
VM file ui compiled to 710050 bytes of code
ui loaded in 9461728 bytes on the hunk
Parsing menu file:ui/jk2mp/main.menu
Parsing menu file:ui/jk2mp/joinserver.menu
Parsing menu file:ui/jk2mp/player.menu
Parsing menu file:ui/jk2mp/createserver.menu
Parsing menu file:ui/jk2mp/connect.menu
Parsing menu file:ui/jk2mp/rules.menu
Parsing menu file:ui/jk2mp/rules_games.menu
Parsing menu file:ui/jk2mp/rules_force.menu
Parsing menu file:ui/jk2mp/rules_weapons.menu
Parsing menu file:ui/jk2mp/rules_items.menu
Parsing menu file:ui/jk2mp/controls.menu
Parsing menu file:ui/jk2mp/setup.menu
Parsing menu file:ui/jk2mp/demo.menu
Parsing menu file:ui/jk2mp/password.menu
Parsing menu file:ui/jk2mp/quit.menu
Parsing menu file:ui/jk2mp/error.menu
Parsing menu file:ui/jk2mp/serverinfo.menu
Parsing menu file:ui/jk2mp/findplayer.menu
Parsing menu file:ui/jk2mp/createfavorite.menu
Parsing menu file:ui/jk2mp/multiplayer.menu
Parsing menu file:ui/jk2mp/advancedcreateserver.menu
Parsing menu file:ui/jk2mp/credits.menu
Parsing menu file:ui/jk2mp/vid_warning.menu
Parsing menu file:ui/jk2mp/videodriver.menu
UI menu load time = 4580 milli seconds
28 bots parsed
--- Common Initialization Complete ---
Winsock Initialized
Opening IP socket: localhost:28070
Hostname: vaporware
IP: [snip]
IP: [snip]
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
-----------------------
Requested feature was omitted at compile time
============================================

Prox Kolari
04-03-2002, 07:03 AM
*bump*

When are the modeling tools supposed to come out? Hopefully this won't happen to me with them.